Websites keep demanding I install a modern browser?!

Discussion in 'Asus (Android)' started by Toller, Dec 21, 2013.

Thread Status:
Not open for further replies.
  1. Toller

    Toller Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I have a ME301T, about a year old.
    About 5% of the websites I go to warn me that they will probably not display properly because I am using an obsolete browser. They recommend IE, Firefox, or Chrome.

    I am using Chrome 31.0.1650.59.
    It seems to update regularly; I think this is the current version..

    So what is obsolete about my browser and what can I do about it?

    Thanks.
     
  2. thierryb

    thierryb Scribbler - Standard Member Senior Member

    Messages:
    1,380
    Likes Received:
    291
    Trophy Points:
    101
    Probably the site is obsolete, and not your browser.
     
  3. Mesosphere

    Mesosphere Geek. Senior Member

    Messages:
    5,277
    Likes Received:
    1,957
    Trophy Points:
    331
    I get the same message occasionally using IE 11. I guess its not browser specific.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page