wacom's newest tabletPC driver issues!

Discussion in 'Fujitsu' started by stoneseeker, Oct 12, 2012.

Thread Status:
Not open for further replies.
  1. Plognark

    Plognark Scribbler - Standard Member

    Messages:
    176
    Likes Received:
    25
    Trophy Points:
    41
    Last edited: Jun 26, 2013
  2. Plognark

    Plognark Scribbler - Standard Member

    Messages:
    176
    Likes Received:
    25
    Trophy Points:
    41

    Ok, this may be premature, but I got fed up and just flat out uninstalled the intel rapid store software and rebooted afterwards. So far, the spikes are gone, and I've been grinding away for a good 20+ minutes in photoshop. No spikes, and the cursor performance is dramatically improved.

    For further testing I saved a big sketch image, rebooted, and then loaded it up again. Even enabled touch again, which has it's own issues around palm rejection, but even then I'm not getting the lag spikes I used to.

    I do have several other things disabled, but I was still getting spikes even without them (Bluetooth, mainly).

    Is anyone else willing to try uninstalling the intel rapid store software and see if that helps? This is consistent with some of my issues with my T901, where I tried some bare-bones driver intallations to try and nail down the issue and didn't get anything until after updating all of the fujitsu drivers and software...

    ETA: Damn, I shut down photoshop and then fired it up again and that wretched lag spike is back.

    ETA2: Ok, I realize that I turned off my touch functionality in the middle of using photoshop. On a hunch, I shut the program down and then started it up again, and the spikes are once again gone. So mental note: photoshop doesn't like it when you turn touch on or off in the middle of operations. I'm using the Touch Toggle utility to enable and disable it.

    ETA3: Yep, still no lag spikes... I'm so happy I could cry...
     
    Last edited by a moderator: May 18, 2015
  3. Plognark

    Plognark Scribbler - Standard Member

    Messages:
    176
    Likes Received:
    25
    Trophy Points:
    41
    Switching the pen around to use the brush gave me a lag spike hit, but actually drawing is remarkably consistent now.

    So I still don't know exactly what's going on; the problem is still there, but with the Intel Rapid Store uninstalled things are running much, much better for me.

    ...

    I have a hypothesis that it's still an issue with the USB... it doesn't handle transitioning between different devices well. I think the intel rapid store must be taxing the USB at regular intervals, so it forces it to compete with the pen input.

    That would explain why my not-quite disabled touch functionality was causing conflicts, because it was still getting the input from two USB devices. I've also got my Bluetooth shut down.

    The pen eraser may register as a different USB device or channel, which would explain the momentary lag when I flipped the pen over to use the back of it. I just ran a test, and I can select the eraser tool with the tip of the pen and there's no problem. So I think it has to do with devices putting too much on the USB...

    Anyway, it's getting late here and I'm starting to lose the ability to form full sentences. Keep up the good fight folks :D
     
  4. stoneseeker

    stoneseeker Animator and Art Director Senior Member

    Messages:
    3,604
    Likes Received:
    1,074
    Trophy Points:
    231
    Uninstalled Intel Rapid Start Technology after reading exwhyzed's post too.
    VAST improvement!!

    This combined with disabling bluetooth and I have seen 1 cursor jump in 2 hours of painting!!

    dude, good find. It's still not a problem solved, but it's so greatly reduced that it's barely noticeable in Photoshop at least.
     
  5. exwhyzed

    exwhyzed Pen Pal - Newbie

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    6
    Plognark and stoneseeker, wow that's great news. Both of your comments have sold me on the Fujitsu T902 being the ultimate tablet and totally worth getting!


    Here's another detail that should drive another nail into "lag's" coffin...

    To sum up this person's post post, they were having a mouse lag issue with a wireless/Bluetooth mouse and did the following to solve their issue...seems like its worth a shot in this case as well:

    1. Go into Device Manager, View devices by type, expand Universal Serial Bus controllers, right click the first USB Root Hub and choose properties (see below)
    [​IMG]

    2. Go to the Power Management Tab, and UNcheck the box that says "Allow the computer to turn off this device to save power" (see below)
    [​IMG]

    3. Repeat this process for all of the other USB Hubs

    4. Reboot your computer and the changes should be in effect.



    EDIT:
    It could very well be that Windows is shutting off the USB hub that connects to the Bluetooth/Wacom device, and the stuttering is caused when it is turned back on again. So I guess one only needs to ensure that this same Hub is always on, and not all the hubs.
     
    Last edited by a moderator: May 18, 2015
  6. mrjh000

    mrjh000 Lurker

    Messages:
    56
    Likes Received:
    6
    Trophy Points:
    16
    I just want to chime in that I also have the pointer lag with my T902 and uninstalling the Intel Rapid Storage Technology helped with lessening the lag a lot. I still see it from time to time but it is not as severe as before (a quick little catch-up as compared to half a screen catch-up).

    On a side note, I don't know if this will help anyone or not, but when I installed Wacom drivers (I did a fresh Windows 7 install on a different hard drive) I noticed that it also installed a thing called "HID-Compliant Mouse". After installing the driver the pen cursor started moving a bit slowly behind the pen by about a quarter of an inch. I disabled the HID-Compliant Mouse in Device Manager (can't uninstall or it will reinstall itself on next boot up) and the cursor became very snappy, though the catch-up lag still occurs (this is way before uninstalling Intel Rapid Storage).

    I also noticed, during my Windows install, that the catch-up lag will still occur even when using default Microsoft Divers without Wacom drivers.
     
  7. jan_c

    jan_c Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    4
    Trophy Points:
    16
    Interesting finding about the Intel Rapid Storage driver. I uninstalled it and noticed some improvement; cursor lag now occurs about half as often now (once every 2-3 mins of continuous drawing).

    It seems the Wacom driver is somehow super sensitive to interrupt/DPC events. iaStor.sys (the Intel driver) was racking up the ISR and DPC counts (though still considerably behind usbport.sys).
    [​IMG]

    I can confirm this too.
     
  8. stoneseeker

    stoneseeker Animator and Art Director Senior Member

    Messages:
    3,604
    Likes Received:
    1,074
    Trophy Points:
    231
    Yes, I'm still seeing a pile of system interuppts. How on earth do we stop usbport.sys to stop all the mayhem?? I imagine if we see it work so well with the Intel RST, it would be a problem completely solved if we could fix the latency issues the USB port introduces. Curiously, if I plug the Cintiq into my T902, the lag problem NEVER happens. Not once. So there is an issue with the specific port that the wacom digitizer uses inside..? Why wouldn't the latency effect the Cintiq as well??

    I'm so glad for this community!! making my life easier everyday!
     
  9. Plognark

    Plognark Scribbler - Standard Member

    Messages:
    176
    Likes Received:
    25
    Trophy Points:
    41
    My next step is to disable the power management for the USB. I've got the bay battery, so this thing is already pulling an easy five hours in high performance mode, so I'm not too concerned about battery life.

    I'll try to read up more on usbport.sys, but that's probably a bit beyond my paygrade as a programmer.

    I think we should put together a log of everything that had to be tweaked/disabled/uninstalled...

    Anyway, I just disabled the HID compliant mouse and unchecked the option for windows to shut off the two USB hubs to save power. I'll report back in a bit...
     
  10. Plognark

    Plognark Scribbler - Standard Member

    Messages:
    176
    Likes Received:
    25
    Trophy Points:
    41
    Ok, DON'T disable the HID compliant mouse.

    Disabling it took away the ability for the pen to make a right click with the buttons.

    I still get a major lag hit when I flip the pen to use the eraser... not sure what that's all about. It's not every time, but it's somewhat regular.

    ETA: OK, I did yet more testing, and I forgot to disable the tabletPC input service after all of these reboots. Once I disabled that the lag from flipping the pen to use the eraser went away... or at least it's diminished to the point that I haven't seen anything yet.
     
Thread Status:
Not open for further replies.

Share This Page