wacom's newest tabletPC driver issues!

Discussion in 'Fujitsu' started by stoneseeker, Oct 12, 2012.

Thread Status:
Not open for further replies.
  1. jan_c

    jan_c Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    4
    Trophy Points:
    16
    Yes, I already have touch switched off like that. But, the hardware is actually still active -- if I let the computer go idle and the screensaver turns on, I can still wake it up by touching the screen (though the cursor doesn't move). So I think I need to reach a bit lower into the driver stack.

    My machine already came pre-loaded with the latest Win7 firmware (0115), but it's interesting there's a separate one for Win 8 (3033). The 3033 firmware has a note that reads, "For Windows 8 only," so I'm not certain I should flash it. Which firmware are you running on your Win 7 installation?

    I'm using Paint Tool SAI most of the time, and that's hardly CPU intensive. I also use Inkscape, which needs more CPU (but single-core only). If it's a process priority issue, I'll try to up the priority levels of the driver. Interestingly, the 2 ISD_Tablet.exe processes are only at priority level 10, and ISD_TabletUser.exe is at priority 8. Could ISD_TabletUser.exe be trying to catch up to the higher priority processes at irregular intervals? I might try locking their affinity to a single processor, too. (Actually, now that I think about it, there's a laundry list of things to try.. adjusting USB buffer size, USB sample rate/overclocking, DPC latency, etc. I might start with capturing USB packets and see where that leads.)

    Yeah, I just need to be reassured that I don't have a dud unit! Warranty repair is severely difficult for me since Fujitsu does not service this part of the world (Hong Kong). I had to import the notebook from Japan (and it took months!).
     
  2. stoneseeker

    stoneseeker Animator and Art Director Senior Member

    Messages:
    3,602
    Likes Received:
    1,047
    Trophy Points:
    231
    ahh, sorry. I didn't realize from your initial post that you are as knowledgeable about windows as you are. My advice was a little 'basic' when I realized this.
    I've noticed this too, when I wake up my computer from sleep, despite having touch disabled at the services level, I can still use touch to navigate the login screen! So your right, there is a deeper hardware level we may have to disable to rule it out. However, I don't think it is the cause... Other systems don't report this issue, and I wear a pinky glove for ease of movement on the screen while drawing, so I don't think I am touching the screen often.

    I am using old school firmware, original windows 7 build, but I installed the windows 7 OS myself on a new SSD and added the drivers manually. I don't think you have a bum unit. I used to experience it once every few minutes or twice in a minute for a while when in Flash. Then for some reason it stopped being so often. It seems to be really random. Sometimes I go a day without seeing it, other times it happens a lot. I did increase the priority of the pen processes in task manager, and have made sure to use CCleaner to do registry cleans in the past to get rid of old wacom driver fragments, not sure if any of that had much effect though.

    I think your onto something when you say you wanted to try DPC Latency test... its kinda over my head I'm afraid, bu tI'm excited someone more knowledgeable may have the ability to hunt a rogue service down. I have noticed a few things over time, that may or may not be related.

    -occasional spike in CPU that effects latency. (the fan whirs up then stops) Happens too quickly to track for me in resources, but may accompany the pen freak out. I've seen it when running DPC latency checker.
    -occasional CPU snag (common in Windows 7) that has a service in windows firewall process eating up 25% of cpu. I can only stop it by reseting my computer, has only happened more recently, and I am thinking it may be dropbox ... probably unrelated.
    -It seems to happen less when I have only the one wacom driver installed ( I also have a cintiq 15x driver on here) but don't know if that's really helpful.

    If you find anything, please share here. Many of us have needed someone who knows a bit more about sleuthing processing to figure this out. I wonder about the new firmware for windows 8 too, could you use it in windows 7? Because Shog has reported that since flashing the new firmware for windows 8 and installing windows 8 the pen lag has almost completely disappeared for him. That's why I was hoping the new firmware for windows 7 would help us too. Sounds like it doesn't though.

    thanks for your effort, any questions or help we can be regarding our experiences with the T902, let us know! This thing is no nice to draw on when it isn't buggin' occasionally!
     
  3. Tab Rocker

    Tab Rocker Pen Pal - Newbie

    Messages:
    52
    Likes Received:
    6
    Trophy Points:
    15
    Hi Guys -

    I disabled a few things on my T902 and it seems to have resolved all of the strange cursor jumping and lag on my machine. I've been drawing in Sketchbook Pro for the last 4 hours without a single glitch. Works great! Maybe I'm just getting lucky? I have my fingers crossed.

    Take in mind I am on Window 7.

    I'm not sure which part below solved it for me, but perhaps it's a mix of things conflicting or draining resources.

    1.) Uninstall the Fujitsu Wacom driver in the control panel. I'm using the native driver which works fine.
    2.) Go to 'power settings' in the control panel and make sure it is on 'high performance'. This way your hard drive doesn't turn off after 10 minutes and graphics are set to max performance.
    3.) Disable touch: control panel>pen and touch>touch> uncheck: "use your finger as an input device"
    4.) Disable 'shock sensor utility': Bottom right corner mouse over and click on 'shock sensor utility'. In the 'action' drop down box, set to 'nothing'. This disables the shock sensor from kicking in. I had the same issue on my X61T - the shock sensor would periodically cause a pause while I was sketching until I shut it off.
    5.) Exit out of the 'Fujitsu menu' utility on the bottom right. You must completely EXIT out.
    6.) Exit out of the 'rapid start' utility(if you have it)on bottom right. You must completely EXIT out.
    7.) Pause the auto rotation using button on the bezel.

    Do all the steps above then restart. After restarting you are going to have to repeat 5,6 and 7 but just go through all the steps to make sure all settings have saved.

    Also, for those that are new to inking, you need to disable 'flicks' in the 'Pen and touch' or else you will have lag and pauses in any of the drawing programs regardless of the tablet used. I know that's obvious for inking veterans, but just wanted to throw that out there just in case.
     
  4. stoneseeker

    stoneseeker Animator and Art Director Senior Member

    Messages:
    3,602
    Likes Received:
    1,047
    Trophy Points:
    231
    Thanks for sharing the tips TR! I have already done most of those, however, the first step in your suggestions is what actually nullifies your problem.
    The issue is many of us need the wacom driver for pressure support in wintab software like Adobe Photoshop, Flash, Corel Paint, TVP animation, ZBrush, etc.

    I have never experienced the lag when the wacom driver is uninstalled, so I think the issue involves an interference with the wacom driver specifically. The problem is said to be way less apparent in windows 8 with the new firmware update, not sure if that really helps in our quest to find out the source of the nuisance or not.
     
  5. Tab Rocker

    Tab Rocker Pen Pal - Newbie

    Messages:
    52
    Likes Received:
    6
    Trophy Points:
    15
    Hi Stoneseeker,

    I knew the first step was going to be a 'no go' for most...I mainly use Sketchbook for 90% of my work so it's not an issue. I get pressure sensitivity without the driver in that program

    I haven't tried re-installing the Wacom driver with the same programs disabled. I may try that today to see if it makes a difference. I have had the cursor jump and draw straight lines randomly with and without the Wacom driver installed in the past, so something tells me there's more to it. Fyi, for me the biggest change in consistency was setting the G-shock sensor to 'nothing' and removing the Fujitsu menu utility. Another random tidbit: when I first started using the tablet I had my browser open with about 10 tabs open. When I was drawing I was getting crazy pauses and skipping every 10 seconds. The inking would literally freeze for a half second. When I closed my browser out everything went back to normal! That makes me wonder if it is partly RAM related. Some sort of leak or interference.

    After 6+ hour of drawing last night, I was able to get two episode of the cursor trying to catch up. This happened right before I closed up when I saved and then tried to draw before it finished saving, and another time randomly when I was inking close to the edge. It could have been that he machine was getting a little hot or just a user mistake. Considering I had zero issues for that long I consider that an overall win.

    I'm going to experiment with some older Wacom drivers. Some tablet PC's do better with older version of the Wacom driver installed. I will report back if I have some success.
     
  6. stoneseeker

    stoneseeker Animator and Art Director Senior Member

    Messages:
    3,602
    Likes Received:
    1,047
    Trophy Points:
    231
    how do you close the fujitsu menu utility? I mean, I don't have it open, bu tit still has a little icon in the task manager. Did you find a way to get rid of this? I never use the silly feature.
     
  7. Tab Rocker

    Tab Rocker Pen Pal - Newbie

    Messages:
    52
    Likes Received:
    6
    Trophy Points:
    15

    Sure thing.

    Just go to your shortcuts in the bottom right corner of your desktop screen. Mouse over the icon (looks like a blue and white rectangle), right click > Exit. That it!
     
  8. stoneseeker

    stoneseeker Animator and Art Director Senior Member

    Messages:
    3,602
    Likes Received:
    1,047
    Trophy Points:
    231
    wierd. Thats what I tried and nothing would happen when you right click on the icon.

    So I decided to open it and then do the same, and this time it exited the program properly and the little icon disappeared entirely from the taskbar.
     
  9. kruzilla

    kruzilla Scribbler - Standard Member

    Messages:
    230
    Likes Received:
    26
    Trophy Points:
    41
    I seem to be having this same problem on my t901. I'm getting stray lines, jumping, etc, and it's driving me crazy. I'm running PS5 on 8gbs of ram, Win 7 32-bit fresh install. I've uninstalled and reinstalled the Wacom drivers but it still keeps happening. Flicks are off and all that. Pressure sensitivity is working. Should I just uninstall the latest drivers and download an older version? Never had this problem with my t4220.
     
  10. stoneseeker

    stoneseeker Animator and Art Director Senior Member

    Messages:
    3,602
    Likes Received:
    1,047
    Trophy Points:
    231
    Wow, your the first ever I've heard reporting this about the T901. Since you did a clean install recently it must be a Fujitsu specific driver that was updated in the last year or so that is causing the conflict. If you can do a clean install again, but slowly install the drivers and test at each stage to discover the culprit we'll all hail you as a hero on the forums! haha But at least we know for sure its not a hardware thing regarding the T902. It's very wierd. If you could get a hold of the original or old drivers for the T901 the problem would go away, as no one had this problem with the T901 before you. But I would love it if you could help us find out first. It may be easier to narrow it down with the T901 than the T902. Try uninstalling synaptics driver temporarily to see if that helps, or the Fujitsu menu/utility.

    please keep us updated.
     
Thread Status:
Not open for further replies.

Share This Page