Ubuntu on Dell XT

Discussion in 'Linux on Tablet PC Forum' started by applesauce, Feb 18, 2009.

Thread Status:
Not open for further replies.
  1. applesauce

    applesauce Pen Pal - Newbie

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    5
    I have been looking around for infor on installing ubuntu on the Dell XT, and its been a little bit here and there. From what I can tell and my own trys it doesnt have touch supported but it can do pen with some modified drivers. My main issue is video driver support. When I try Ubuntu 8.10 it doesnt have the right drivers and kicks me to busybox or something.

    Has anyone had any experience installing a current version of Ubuntu. I tried doing it from a live cd and it loads to the desktop, but when I load the restricted drivers for flgx(spelling might be off) it wont load x server any more.

    Anyone have any luck or point to a link where people have had luck?
     
  2. jhoff80

    jhoff80 Pen Pro - Senior Member Senior Member

    Messages:
    3,309
    Likes Received:
    1,009
    Trophy Points:
    231
    No idea, but I booted an Ubuntu liveCD (well liveUSB I guess, from my flash drive) yesterday to get a script to run for another device, and it doesn't have the wireless drivers for me either.

    I know that's an issue with many wireless chipsets but I thought I'd point it out.
     
  3. Kyle Porter

    Kyle Porter Veteran Moderator Senior Member

    Messages:
    1,724
    Likes Received:
    0
    Trophy Points:
    56
    I personally haven't tried to get it working on a XT yet, but i have got it to work on my 2710p.

    If i find anything, i will PM you.

    EDIT: Found stuff on the internet.

    Xserver:

    1) open one terminal(tty) by Cntl+Alt+F1
    2) sudo aptitude install xorg-driver-fglrx
    3) sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old
    4) sudo nano /etc/X11/xorg.conf
    5) find the Device "VESA" and change it to "fglrx"
    6) Cntl+X, Y, Enter
    7)sudo /etc/init.d/gdm restart

    Wlan:

    1. First step, you must uninstall ndiswrapper & bcm43xx-fwcutter

    sudo apt-get remove ndiswrapper-common ndiswrapper-utils-1.9
    sudo apt-get remove bcm43xx-fwcutter

    2. Add bcm43xx to the /etc/modprobe.d/blacklist file

    sudo vim /etc/modprobe.d/blacklist
    add this line “blacklist bcm43xx” (without “”)

    3. Reboot
    4. Download driver for BCM94311MCG wlan mini-PCI here ( if this link expire or not found, you can contact me :) )

    tar -xzvf WLANBroadcom.tar.gz
    move the folder WLANBroadcom to your home directory
    mv WLANBroadcom/ /home/yourname/

    5. Install ndiswrapper from source :

    sudo apt-get update
    sudo apt-get install build-essential
    sudo apt-get install linux-headers-`uname -r`
    sudo ln -s /usr/src/linux-`uname -r` /lib/modules/`uname -r`/build
    mkdir -p ~/bcm43xx/ndiswrapper
    cd ~/bcm43xx/ndiswrapper
    sudo wget http://downloads.sourceforge.net/ndiswrapper/ndiswrapper-1.49.tar.gz
    tar xvzf ndiswrapper-1.49.tar.gz
    cd ndiswrapper*
    make distclean
    make
    sudo make install

    6. Install windows driver (BCM94311MCG wlan mini-PCI) with ndiswrapper

    cd /home/yourname/WLANBroadcom/
    sudo ndiswrapper -i bcmwl5.inf
    ndiswrapper -l

    sudo vim /etc/modules
    add this line “ndiswrapper” (without “”)

    sudo modprobe ndiswrapper
    sudo ndiswrapper -m

    7. Reboot
     
  4. applesauce

    applesauce Pen Pal - Newbie

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    5
    Yes I think that depending on which wireless card you have it shouldn't be too hard to set up in ubuntu.

    My biggest issue is with the video drivers. I dont have any gui interface after installing. It shows up in the live cd though. It seems like the radeon express 1250 chipset its the best supported for linux drivers.

    I didn't want to make it a long drawn out thread, I just wanted to throw a line in the water to see if anyone has been down this road on a current version 8.04 or 8.10
     
  5. SimsHsia

    SimsHsia "I will do science to it" Senior Member

    Messages:
    3,293
    Likes Received:
    1
    Trophy Points:
    66
    Hi beverly,

    There's plenty of guides out there if you look them up on Google. Ubuntu's installation guide is probably a good start. To get tablet functionality you'll need to search around here on TPCR or via Google to find those modified drivers.
     
Loading...
Similar Threads - Ubuntu Dell
  1. cmd
    Replies:
    2
    Views:
    3,086
Thread Status:
Not open for further replies.

Share This Page