Typing in an IME at system level rather than textbox level

Discussion in 'Microsoft Windows 7' started by Jamie-B, May 30, 2015.

  1. Jamie-B

    Jamie-B Scribbler - Standard Member

    Messages:
    263
    Likes Received:
    31
    Trophy Points:
    41
    Perhaps nobody can help out with this, but here's my problem: in Windows 7, when one chooses an IME (ie. Japanese, French, Chinese...), it stays in your IME only for the textbox you've toggled the IME in. Thus, when you enter into Japanese mode in Notepad, it will stubbornly remain in English when you move to type a Google search into your web browser's URL bar. I can assure you that this is one of the most frustrating things on earth. In Mac OS, the IME is system-level and it's much more ergonomic.

    Also, is there a hotkey to change from the English IME to the Japanese IME without having to move my damned mouse to the language bar? Once I have activated the Japanese IME (with my mouse) for the first time, I can use ctrl + ` to toggle between them, but there is no obvious way to boot up the IME for the very first time using only the keyboard... again, unlike on Mac OS.
     
  2. Kumabjorn

    Kumabjorn ***** is back Senior Member

    Messages:
    3,468
    Likes Received:
    1,568
    Trophy Points:
    231
    Ok, here we go.
    Toggle using Win+Spacebar
    Go into Advanced Language Setting through the Control Panel. There is an option to set your language system wide or separate for each window. You can also assign shortcuts for the different languages you have installed in the Language Settings dialog box.
     
  3. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,161
    Likes Received:
    225
    Trophy Points:
    81
    As Kumabjorn mentioned, you can set keyboard shortcuts through the Control Panel. The default shortcut to toggle between languages on my system is Left Alt + Shift (Win 7 64bit, English). You can also change this shortcut through the Control Panel. On my system, I don't know what Win + Space bar does but my computer goes completely crazy!
     
  4. Kumabjorn

    Kumabjorn ***** is back Senior Member

    Messages:
    3,468
    Likes Received:
    1,568
    Trophy Points:
    231
    Oopps, forgot it was Windows 7, I was talking about Windows 8. In 7 it is Left Alt and Shift to toggle.

    Balbutio ergo sum
     
Loading...

Share This Page