[TX2500] XP display driver with rotation working!

Discussion in 'Hewlett Packard' started by darionco, Aug 14, 2008.

  1. darionco

    darionco Pen Pal - Newbie

    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    5
    Is it really?? weird! I guess it has something to do with the processor then, the TX2524ca has the RM-70 and as far as I know that's the only difference between the TX2524ca and the TX2500z. I hope AMD releases drivers for the puma platform and its processors... for XP... yeah AMD you heard it!!! XP drivers!!!!

    BTW Does the solution above breaks catalyst control center for everyone? or it's just me?

    darionco
     
  2. nagy_peter

    nagy_peter Pen Pal - Newbie

    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    i have got an error message too when I startup my tablet pc and if you try to launch the cc it is not working correctly. (the graphic of the window is weird)
    the graphic is still slow on my pc, so i will give it a week and I will upgrade back to vista
    keep searching and amending, until it will work;)
    peter
     
  3. GreatWizard

    GreatWizard Pen Pal - Newbie

    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    15
    try uninstallin catalyst, doing driver sweep, then installing again (with reboot after each time) and of course the lastest updates.

    Oh and Catalyst Control center needs .NET 2
     
  4. darionco

    darionco Pen Pal - Newbie

    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    5
    I updated the pack with the release of ATI's 8.8 drivers.

    Cheers!

    darionco.
     
  5. nana

    nana Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Please I am very new to this discussion so pardon me. Please I have a tx2510us tablet pc and I have tried several times to downgrade it to XP. I came across this forum through research( reference site: http://tx2500z.googlepages.com/)

    Does this apply to tx2510us or is the tx2500z different.
    This is the problem I encounter when I try to install XP SP2. when I boot from cd it gets to a point where a green screen appears with an error message. Setup will not continue again and I will have to shut down the computer. I read from this forum that I will need sata drivers during installation.

    please help me out.
     
  6. DRTigerlilly

    DRTigerlilly Tablet Lead Mod (Retired) Super Moderator

    Messages:
    7,471
    Likes Received:
    667
    Trophy Points:
    301
    yes your machine is the same as the tx2500z, the tx2500z is just a custom ordered model.

    You need to either slip stream the sata drivers to your xp disks, using a program like nlite, or you need have a floppy drive available to add the drivers during the windows installation.

    One of these tx2500 guides mentions how to do it, i think you can check dorianco's thread here
     
    Last edited by a moderator: May 18, 2015
  7. nana

    nana Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Thanks a lot. I will try this method and if it works I will let you know
     
  8. eborn

    eborn Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Oh right i gave up. After 2 days of fighting with the rotation i have to ask for help. I have tx2525nr and i'm trying to get these keys work but they don't seem to cooperate. My guess is the QuickLaunch drivers. darionco's Ati drivers work great, i can rotate the screen using them and everything is fine. But when I install quicklaunch drivers, that's what i get: (tested with versions C,E,F,H - same results) after reboot it finds new hardware some sort of "keyboard_filter", and automatically installs drivers for it. Another thing that happens after reboot is the appearance of "change tablet and pen settings" icon in tray - rotating screen manually using this works great.
    But no luck with the quicklaunch buttons. It looks like some drivers conflict - i attached the screenshot of my device manager AFTER installing and rebooting. Keyboard changed to the one "with QLB", but i have still got lots of "Hid compliant devices" which i guess are the infamous "quicklaunch buttons" (cause the Hid keyboard devices seen in the screenshot came with the remote control installation). Tried pointing directly to the drivers in quicklaunch folder, but windows says they are not compatible. I have no idea what to do, please help...
     

    Attached Files:

    • wtf.JPG
      wtf.JPG
      File size:
      60.8 KB
      Views:
      945
  9. darionco

    darionco Pen Pal - Newbie

    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    5
    Hey,

    I've been away for a long time.

    Long story short, I had to reinstall xp so i decided to give the latest drivers a try and found that the performance is very improved on this version so i enabled rotation and uploaded.

    Download

    Enjoy!

    darionco.

    P.S. if this doesn't work for you try doing your own following this guide: http://forum.tabletpcreview.com/showthread.php?t=23321

    P.S.2 When I first downloaded the drivers from amd's site they didn't want to install i had to patch some other inf files to get it working... weird!
     
    Last edited by a moderator: May 18, 2015
  10. helloprateek

    helloprateek Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    hi friends,
    I am having tx2500z 64 bit processor.
    I wanted to install XP on it and have XP 64 bit OS.
    When I tried to install XP, it gave me blue screen with error code
    0X0000007B (0XFFFFFFFFC0000034, 0X0000000000000000, 0X0000000000000000)
    Then I made CD of XP by adding SATA drivers asing nLite as guided on the page http://tx2500z.googlepages.com/home.
    Even after that I am getting same blue screen....
    Please help...
    Will really appreciate....
     
Loading...
Similar Threads - [TX2500] display driver
  1. siddhartth
    Replies:
    6
    Views:
    1,415

Share This Page