TX2000 Series XP Drivers

Discussion in 'Hewlett Packard' started by e.pol, Jul 22, 2010.

  1. schj98

    schj98 Pen Pal - Newbie

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    For everyone’s convenience here is a quick rundown on how to get XP Tablet to run correctly on your TX2000 series tablet.

    The information comes from several sources I am just putting it all in one place to ease peoples search.

    Most of the drivers from the TX1000 Series will work on this model with a few exceptions.

    The touch screen driver is not correct you need the Wacom driver. Available here: http://www.wacom.com/tabletpc/driver.cfm?CFID=3806298&CFTOKEN=73182108

    I have only found one video driver that doesn’t break something i.e. the display brightness or the screen rotation it did require inf file modification so I have uploaded the complete driver with modified INF here: http://rapidshare.de/files/39242084/TX2000_Video_Driver.zip.html

    When you install the display driver be sure to enable the nView desktop manager. Which is found in the nvidia display settings.

    You will also need the most up to date quick play buttons software from hp available here:
    http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-56605-1&lc=en&cc=us&dlc=en&product=3686755&os=228&lang=en

    I have uploaded the rest of the drivers that are needed here in a zip file the download is roughly 98mb it can be obtained here: http://rapidshare.de/files/39242248/TX_2000_Drivers.zip.html

    Using the drivers listed above I was able to get my tx2020us to function 100% with no known issues.

    I hope this saves you guys some time. Again all of this info was pulled together from other peoples posts so thanks to them for their hard work.
     
    Last edited by a moderator: May 18, 2015
  2. khadel

    khadel Pen Pal - Newbie

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    thx

    i need the wireless wlan
     
  3. schj98

    schj98 Pen Pal - Newbie

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Last edited by a moderator: May 18, 2015
  4. schj98

    schj98 Pen Pal - Newbie

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Last edited by a moderator: May 18, 2015
  5. sadeel786

    sadeel786 Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    I have everything installed but unfortunately i am unable to load wireless Lan...in device list it shows Broadcom with exclamation mark. Plus when i try swtiching on the the wireless lan with the button...bluetooth gets switch on and off with the Wlan button.

    Please assist....need help
     
    Last edited by a moderator: May 18, 2015
  6. mizzo

    mizzo Pen Pal - Newbie

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    hi,

    I have an Tx 2150, I have a last unknown device: PCI bridge.

    I think it's about the MC chipset but I didn't succeed to fix it.

    do you know how to do ??

    thank you and sorry for my english !!
     
  7. mizzo

    mizzo Pen Pal - Newbie

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5

    edit: it's done with the tx1000 package !
     
  8. medah4rick

    medah4rick Pen Pal - Newbie

    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    5
    sadeel786 i had the very same problem. here's what i did. as far as i can remember and remember maybe some of these steps weren't needed but nevertheless i got my wan working.
    1. turn off wifi hardware button
    2. uninstall bluetooth software
    3. disable wireless zero configuration in services
    4. turn on wifi hardware button
    5. re-install wifi drivers
    at this point i got the message that the card didn't install correctly and you will see the exclamation point
    6. go to device manager -- right click on the broadcom -- update driver -- no this time -- INSTALL FROM A SPECIFIC LOCATION
    7. click DON'T SEARCH I'LL CHOSE THE DRIVER TO INSTALL
    8. UNCLICK the field box for "show compatible hardware"
    9. SCROLL down all the way to the bottom and chose the BROADCOM Version : 4.150.29.0 [7/11/2007] Which should be the 3rd from the bottom.
    10. you're all set the broadcom should be set up and just turn on wireless zero configuration.
     
  9. flooz

    flooz Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I've got a tx2110us and I can't figure out what the other PCI bridge device and the SM Bus controller are. Does anyone have any suggestions?
     
  10. forrestsun

    forrestsun Scribbler - Standard Member

    Messages:
    100
    Likes Received:
    0
    Trophy Points:
    31
    Thanks OP for this thread, the tx2000 users shall keep this one as rich as the tx1000 thread for new coming users. Here is my experience. And you might want to read it before you try installing drivers for your xp (I mean windows xp professional sp2).

    Downloaded everything from the install XP on tx1000 thread (the sticky thread), post #38 and 39. Most of the driver provided work following the instructions, with some exceptions, which you can try my way of solving them.

    1) Installed the realtek audio driver from the tx1000 thread. The sound card worked, however when plug in a headphone, even there are pop-up notification saying "headphone plugged in", the sound still comes out of the speakers. So I downloaded the vista 32 audio driver from hp site and installed, this solved the problem. I guess install the vista audio driver should work at the first place.
    http://h10025.www1.hp.com/ewfrf/wc/softwareList?os=2093&lc=en&cc=ca&dlc=en&product=3689921&lang=en

    2) Installed the TouchKIT from the tx1000 thread, although it said it found a touchscreen, I was unable to actually use the touchscreen (no response when I touch). So I downloaded the Vista Wecom digitizer driver and installed. Now the stylus works, however still no touch screen function. If someone else made there touch screen working, could you please post your solution (note the stylus works just no response to my finger touch).

    3) Do NOT use the quickplay button driver provided in the tx1000 thread. Use the one at the vista driver site instead, it works for the rotation buttom at least. I don't have quick play software installed so can't try the rest.

    4) Tried install the quickplay software from the tx1000 thread, didn't allow me to install "only for authorized machine...". I guess I should use the one in the swsetup folder of my original vista. Too bad I didn't save that folder.

    5) The touchpad driver from the vista driver site works. And although xp support the touchpad natively, this driver will give you more options to adjust the use of the touchpad.

    6) The cyberlink youcam software from the vista site also works.

    7) In the tx1000 thread it mentioned Ritepen and provided a link. However this link is for Evernot software, which now is free but does not include the Ritepen function. I guess Ritepen was used to be there but now it's on a different site. You may give it a try for 30days before purchasing here. There might be other alternative handwriting recoganition software for free? I don't know.
    http://www.ritescript.com/Products/ritePen.aspx

    8) I don't know which driver is responsable for the remote but now my remote works great.

    9) The Pivot software from tx1000 thread works great, the calibration won't be lost even after I rotate the screen.

    To sum up I now have an almost fully functional tx2113cl with xp pro sp2 installed. The only thing not working is the touchscreen for finger touch operation. If someone has solution please share here. Thanks!!
     
Loading...

Share This Page