Trick to installing VZC display cable? (FONE_DB_FPC)

Discussion in 'VAIO / Sony' started by laalaa99stl, May 22, 2019.

  1. laalaa99stl

    laalaa99stl Pen Pal - Newbie

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    So... I was finally able to find a donor VZC to replace the swollen battery in my original VZC. However, when I put it back together, I lost internal video. External video still works, and that is how I'm able to make this post now. Weird thing is, if I swipe in from the right on my VZC, the Action Center still comes up on my external display. If I swipe in from the left, I get the Task View. So my touchscreen is still working, It's just that the display is dark. Display Settings detects just the external display.

    So... I assume I did something wrong in re-installing the notoriously fragile u-shaped display ribbon cable (FONE_DB_FPC). I've tried re-seating it a couple of times now with no change in outcome. I'm nervous that if I keep tooling with it, I'll lose even the touchscreen (not that it's useful without the display). Have I damaged the cable? Is there some trick to installing it? I'd order a new cable if it were possible, but I know from past negative experience that VAIO support is not worth contacting. They don't sell parts. They'll fix it for you for a minimum of $300. I wonder if they deliberately engineered this cable to be one time use -- almost as a way of doing chassis intrusion detection. Still dreaming of the day I can afford to replace this thing with a Surface Book 2.
     
  2. Marty

    Marty Pen Pro - Senior Member Senior Member

    Messages:
    3,060
    Likes Received:
    2,591
    Trophy Points:
    231
    Hey laalaa, I would really like to be able to help you (as we are the few remaining ZC holdouts on here :p).

    All I can do is point you to @MC1400's excellent post where he suggests extra carefully sliding out the cable after lifting black latch securing it:

    [​IMG]

    He also notes the slight left mis-alignment, even before detaching the cable:

    "Note: the tabs on each side of the connector the wire pins ABOVE the cable and that the left side of the connector has already begun to slide outward)"

    So it's possible the cable does wiggle even with the latch attached. I would double check the length of the visible pins compared with the picture, and reseat as necessary.

    If that doesn't work, perhaps clean for dust and apply some light pressure to the tab to ensure it's making a good connection.
     
  3. laalaa99stl

    laalaa99stl Pen Pal - Newbie

    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    5
    Thanks for responding, Marty. I'm not a hold out by choice but by necessity. There's no funding available for a SB2 right now. I did look at phyc's teardown post before starting. I assumed that the white line on the cable serves as an alignment guide -- that it should line up with the white part on the daughter board. But now that you reposted that specific pic, I notice that the cable actually sits at a 1-degree angle. Maybe that's the key. I'll have to find some time to shutdown and try it. Sucks to not really be able to use the stylus anymore. Kind of defeats the whole purpose of having this machine. I has a sad.

    I wonder if it might not be possible to make an end run around VAIO and find out who makes this FONE_DB_FPC cable. Perhaps they might be cajoled into manufacturing a short run of these cables for those of us who might need a new one and who might not want to pay VAIO $300 or more for the privilege.
     
Loading...
Similar Threads - Trick installing display
  1. JoeS
    Replies:
    2
    Views:
    707

Share This Page