TouchScreen clicking by itself?

Discussion in 'EP121 Slate' started by cclee, Mar 26, 2011.

  1. cclee

    cclee Pen Pal - Newbie

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5
    I'm not sure if this is related...
    But my screen rotation doesn't seem to be working either.
    My screen rotation lock isn't on, by the way.

    The tablet seems to be stuck in landscape mode, and motion seemed to be triggering the clicking problem sometimes.

    When I reboot, I'm able to get the tablet in portrait mode, but now I can't get it back to landscape mode.

    What are the drivers or software controlling the screen rotation?
    I'll dig into this as the potential problem as well...
     
  2. CerN

    CerN Pen Pal - Newbie

    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    15
    on and off all the time. Quite a lot of people had it. Bad design on that thing. The reason in went for the asus'
     
  3. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,254
    Likes Received:
    5
    Trophy Points:
    56
    you probably had your finger on the rim of the display.. that is why the EP121 triggered the mouse or pointer. there is learning curve for using a tablet if this your first tablet.

    The other reason why the G sensor is not rotating because you had disabled all the Intel Graphic short cuts. go back and re-enable them and you should be fine.
     
  4. cclee

    cclee Pen Pal - Newbie

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5
    Hi,
    I'm definitely not touching the rim of the display. :)
    In fact, the clicking happens even if I'm not touching the screen...

    If I disable the touchscreen, the clicking stops.
    But that's not a real permanent solution!

    I just did a clean install, and this still happens.

    At this point, I think it's faulty hardware. I have to return it to the Microsoft store.

    Looks like I may have to wait a while until a replacement unit is sent to me too, since the EP121 keeps selling out.

    I love the tablet and hope that my next unit is a good one!
     
  5. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,254
    Likes Received:
    5
    Trophy Points:
    56
    Sorry to hear you still have the problem.

    When you did a clean install..did you format your drive first?

    After install I wonder you would see clicking by itself with just the factory drivers without any updates or additional drivers software etc?
     
  6. cclee

    cclee Pen Pal - Newbie

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5
    Yup, still had problems with only factory-installed drivers.
    Did the clean install straight from the recovery dvd's, didn't reformat first.

    I've talked to the Microsoft online store, and I'm exchanging the unit now.

    Appreciate everyone's help here. The issue wasn't resolved, but I learned a few things in the process. :)

    I'll be back on when the new unit arrives (hopefully soon...)!
     
  7. macariuz

    macariuz Pen Pal - Newbie

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    This is not good! :(

    I've been experiencing the exact same issue with my ep121 for the past week.. this problem just randomly started to occur. I've uninstalled and reinstalled all of the touch/wacom drivers but it didn't help.

    I was hoping that someone on this thread would figure this out, but I guess it's a hardware issue. I love what ep121 slate has to offer, but this has been my second problem with it. The first time was with the fan noise.. blasting away nonstop.. and now this. :/

    I'm not sure if I'll request another exchange at this time (last time around I had to wait nearly 4 weeks for a replacement unit since it's always sold out).
     
  8. cclee

    cclee Pen Pal - Newbie

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5
    Macariuz: Sorry to hear that! Isn't the problem aggravating?? :(

    Maybe you'll have better luck figuring this out than me...

    Try disabling your EETI driver and see if the problem goes away. If it does, I think we have the same problem...

    I'm guessing that there's a loose connection in the unit. I didn't want to risk popping the cover open to check though.

    Hope you can resolve this without sending it back like me...

    Best of luck!
     
  9. cclee

    cclee Pen Pal - Newbie

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    5
    ...side note:

    Before returning the EP121, I'm wiping the free space on the hard drive...

    Of course, while I'm doing this and casually using the tablet to surf the net a bit, the random clicking problem doesn't happen. I continue to use it for a couple more hours, and it's still working perfectly. :confused:

    Hmm...

    I'm still going to send the tablet back tomorrow for an exchange. I know once I decide to keep it, it's going to start freaking out again! :p
     
  10. CerN

    CerN Pen Pal - Newbie

    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    15
    Isn't that just typical?
     
Loading...

Share This Page