TouchScreen clicking by itself?

Discussion in 'EP121 Slate' started by cclee, Mar 26, 2011.

  1. willytbui

    willytbui Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    I have the same problem with my EP121. I fixed this problem by doing these

    1- Reset the calibration data to default by going to control panel => tablet and setting => Reset
    2- Calibrate new setting by selecting Calibrate
    3- Touch every corners but upper right corner => save => done

    Note : if you want to close web browser or windows you have to touch between maximize icon and the Red X icon
    HOPE this help you guy. It works for me since.
     
  2. cloudvalley

    cloudvalley Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    I tried it but it didn't work at all. I got this problem for 2 years ago and I thought only happen to my EP121. It's just happen few time from beginning but now it's clicking very second. I love my tablet but I can do nothing with it anymore. I tried so many way to fix it but no used at all. I tried upgrade every BIOS version, clean up, software etc... I also bought Windows 8 to replace Windows 7 but now it is clicking like CRAZY in Windows 8. I called ASUS warranty since 1 and haft year ago to claim for warranty. They have no technician support number, only contacted by email and I took 3 months with a lots of email and claim cases number. After all the told me they will send me a box for shipping, but it never arrived. Today I tried to upgrade the newest BIOS version EP121AS.704 but the WinFlash doesn't work with windows 8 yet and the AFUDOS just no responded to the command "afudos /iEP121AS.704". I have no idea what to do now, but I'm glad to find you guys with the same problem then now I realize that this is ASUS got problem with their product hardware, but not us. I did research and only clicking problem with ASUS windows tables only.
    I don't think I will buy anything with ASUS logo again.
     
  3. cloudvalley

    cloudvalley Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Send they this forum link tannerwooden
     
  4. Krash

    Krash Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    My EP121 started doing this in the upper right hand corner in portrait. Recalibration did not work as well as all tips on this forum. Started the RMA process with Asus. Tried clearing the calibration for touch. Also left the Tablet on and working for about an hour or two without turning it off. Then the problem just stopped and has not come back. It was either the touch calibration or something heat related to make it stop. Nothing else on the Tablet was changed.
     
  5. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56
    The fan actually drawing air between MB and the Wacom and EETI boards. heat may not be the issue....there was quite a bit of dust trapped under the isolation film on top of the EETI board and Wacom boards...of mine

    if yours is still under warranty...ASUS service is best bet..don't wait after warranty.
     
  6. Krash

    Krash Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Left overnight to charge and again the phantom touch hasn't come back. Really hard to RMA it now when I can't recreate the problem. If Asus can't recreate the problem as well they might just reload drivers and send it back without testing any of the hardware. I will ask them first before actually sending it back in. I think it might have been condensation due to cold that could have been the issue. The heat then just dried it out again.
     
  7. dan300

    dan300 Pen Pal - Newbie

    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    6
    Don't know if it's been reported, but I had the clicking going on with a boot into Android-x86. Guess that implies that it's a hardware issue.
     
  8. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56
    highly likely...even with clean screen?
     
  9. Adonis

    Adonis Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Finally I could solve “ghost tapping” on HP slate 500. –a problem on touch screen that called phantom click or ghost tap.-

    HP have not had any idea and never response about it. It seems that problem is common on some tablet PC or touch screen in windows’ devices.

    If you uninstall or disable completely the driver of touch screen you lost tablet options and you should use it as laptop by using mouse and keyboard! But I found a solution that you can use it as a tablet.
     
  10. Aiffe

    Aiffe Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    I've had this from time to time. I've never found a permanent fix, though I've noticed it can be triggered by the screen getting a larger than normal electrical impulse, such as being touched by a live cable or wet fingers. Sometimes hair of the dog will fix it. These are the fixes I use, in order of how annoying they are:

    Fix 1: lick your finger and press it to the screen for several seconds.

    Fix 2: with a USB keyboard or similar device plugged in, simply touch the cable to the screen. Yes, it reacts to it even through the plastic coating. You can also use the plugged-in power cable the same way: simply grab a loop of cable and touch it to the screen.

    Fix 3: I have a shortcut in my taskbar to completely disable touch in device manager that I use when I draw, so I don't have to rely on palm rejection, which never works all the time. Sometimes I use this to turn touch off, then on, and that resets it.

    Fix 4: tap the power button to put it in sleep mode for a moment, wipe your screen off while it's sleeping, then wake it up again.

    Fix 5: restart.

    I almost never get all the way to fix 5. Usually one of the earlier steps works.
     
Loading...

Share This Page