Touch Not working for ASUS VivoTab 8 (M81C)

Discussion in 'Asus' started by Niraj Nagar, Dec 2, 2015.

  1. Niraj Nagar

    Niraj Nagar Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hello All,

    In Oct. 2015, I purchased one ASUS VivoTab 8 (M81C) from Amazon US. This windows based tab is very good. I upgraded Windows 8.1 - 32 bit to Windows 10. Everything worked fine. In Windows 10 drains battery very fast. The battery backup was reduced to almost 50% as compared to Windows 8.1.

    I forgot to make restore disk and also deleted the old windows folder. I re-installed the Windows 8.1 - 32 bit with Bing along with all the drivers listed on Asus website.

    Right now the screen is not rotating and touch is not working. In device manager I see 2 un-known devices. In property it says something related to I2C controller.

    This device is purchased from North America, The current location is India. Not getting the local warranty from Asus.
    Windows 10 works well but I don't want to use it as it drains battery very fast.

    I request you to suggest a working solution. There are few tricks posted on various sites but those are too technical for me. Still I tried Cold booting, formatting, intel driver updated utility etc. but not working.

    Regards,
     
  2. messiah

    messiah Scribbler - Standard Member

    Messages:
    124
    Likes Received:
    10
    Trophy Points:
    31
    try using those 3rd party driver scanner programs to update...
     
Loading...

Share This Page