Toolbar Creator - v. 2.2 beta available for download!

Discussion in 'Software' started by lblb, Jun 27, 2014.

  1. Naiplak

    Naiplak Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Yes, I do use a physical keyboard to set the shortcuts.
     
  2. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,177
    Likes Received:
    235
    Trophy Points:
    81
    @Naiplak

    We can try a few things.

    First: When you try to set a shortcut to something like Ctrl + s, does it actually show that in the textbox in the Toolbar Creator options?

    Second: Set a shortcut to something like Ctrl + s (whether it shows it correctly or not in the textbok), then quit Toolbar Creator. If you then restart Toolbar Creator and look at that button in the Options, does it now correctly show Ctrl + s in the textbox?

    Third: An easy solution (once you know how to do it) is to manually edit the .ini file of your toolbars (each toolbar is saved as a .ini file in the Files\Toolbars subfolder). For example, if you open the ini file of your toolbar in a text editor (I use the free Notepad++), you can scroll about 90 lines and you will see that each button is defined by a long series of entries. For example, look at your Button1. The 13th entry labeled "Button1_Type" is where the button type (i.e., 1 for simple hotkey) is saved. Then if your button is of type 1, it will send the shortcut on the following line labeled "Button1_Type1".
    If you saved a button to be Ctrl + s, the shortcut should be Button1_Type1=^{s}, which you can adjust manually (then restart Toolbar Creator if it's already running). If you see that ^{s} is already written, it means that the button is correctly sending Ctrl + s. If that's the case but the shortcut still doesn't work in your program, you can try replacing ^{s} with {Ctrl down}{s}{Ctrl up}. (If you are not familiar with AutoHotkey programming, you can look at the list of notations (i.e., where you'll see that Ctrl is ^) on the first two pages of the pdf file I uploaded in the first post of this thread.)

    Let me know what comes out of your investigations!
     
  3. Naiplak

    Naiplak Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hi, thanks for the tips. well I tried them all with Cubase from Steinberg
    rewrote the codes with Notepad++
    saved the .ni file, closed and reoppened ToolBar Creator.

    I tried them all: ^{n}, ^, {Ctrl down}{n}{Ctrl up}, Ctr+n
    with
    Button1_Type1
    Button2_Type2
    Button3_Type3

    each time the new text was showed in the textbox in the Toolbar Creator options.
    But it didn't worked at all with button 1 and 2

    it's working properly but only with Button 3
    with the setting set to
    Ctr+n
    ^n

    but it worked fine with all 3 buttons with a text software like Open Office for exemple.
    ^{n}, ^, {Ctrl down}{n}{Ctrl up}, Ctr+n
    My PC is under Windows 7 Pro.
    That's very strange.

    I also tried with another DAW named Reason 9.5
    Button2_Type2 set with ^n and it works like a charm!
    No problem at all

    It's working also fine with Studio One from Presonus
    Button2_Type2 set with ^n (opens a new project)

    But Cubase from Steinberg is stil not responding, I don't know maybe it's how the software is written.
     
    Last edited: Dec 19, 2017
  4. Naiplak

    Naiplak Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    To make sure, I tried Touch Keys and did some button type 1 with ctrl+s, shift+alt+ ....
    and it worked straight away with Cubase. It's a shame, I prefer Toolbar Creator :(
     
  5. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,177
    Likes Received:
    235
    Trophy Points:
    81
    Does it work if you you run Cubase as Admin (by right-clicking on its icon to launch it)?

    Also, if it (weirdly!) only works with a toggle (type 3), have you tried with a timed toggle (type 4), which would release it automatically? (In the options, the shortest delay is 200 ms, but you could shorten it manually in the .ini file to something like 50.)
     
  6. Naiplak

    Naiplak Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Yep, it's working with a toggle (type 4) :) , how is called the .ini file where to change the setting to 50 for exemple? Many Thanks!
     
  7. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,177
    Likes Received:
    235
    Trophy Points:
    81
    Cool, I'm glad it works! I don't have access to the files right now but it should be something like Button3_Type4_Delay. If you have issues finding it, just select a characteristic value in the Options (say 2200 ms), then look for that number in the button's ini file section. Let me know if you need more help.
     
  8. gahfe

    gahfe Pen Pal - Newbie

    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    15
    hi lblb, I'm trying to use the toolbar in a new system but I don't have the option to select witch kind of system I have, there is an option in configuration for change it?
     
  9. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,177
    Likes Received:
    235
    Trophy Points:
    81
    Hi gahfe,

    I'm not sure what you mean. Could you elaborate?
     
  10. gahfe

    gahfe Pen Pal - Newbie

    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    15
    In my older computer I remember when program opens by first time ask me for what kind of machine I have (to work with the rawinputest) now I haven't this message
     
Loading...
Similar Threads - Toolbar Creator beta
  1. Stevecody
    Replies:
    1
    Views:
    1,822
  2. Kumabjorn
    Replies:
    5
    Views:
    346
  3. HJK
    Replies:
    4
    Views:
    1,097

Share This Page