tm2 & Pressure Sensitivity

Discussion in 'HP TouchSmart TM2 (Wacom)' started by doc Holliday, Feb 5, 2010.

Thread Status:
Not open for further replies.
  1. NamelessPlayer

    NamelessPlayer Scribbler - Standard Member Senior Member

    Messages:
    927
    Likes Received:
    110
    Trophy Points:
    56
    It didn't work? That bites.

    I wasn't too sure because while it works excellently for me on my Gateway E-295C (would've tested it on the HP TC1100 as well if I knew about it sooner) to the point where I'm not making myself suffer with XP Tablet PC Edition, the added touch capabilities of the HP tm2 could have broken that old registry hack.

    If someone can find a fix, though, I have a pretty good idea of what Tablet PC I'm getting next...
     
  2. ironchimp

    ironchimp Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Hi all! BTW awesome group. A possible fixed found.

    I've been trying to sort this out most of the weekend. Finally got my Tm2 to flip 180 and still have side button functionality. After all this, I found that I would have Photoshop pressure but no Sketchbook pressure. Also I would lose pen alignment whenever I flipped the screen. After several reboots, installs and 2 recoveries, I was about to give up.

    ...So. After my last recovery, I looked at the Sketchbook release notes and came across the "Known Issues" part of the doc.

    Performance Issues on Vista
    • There are Vista performance issues due to a conflict between SketchBook Pro and Vista’s Input Services. These services automatically start up whenever a tablet driver is installed and interacts with the tablet for hand writing recognition and more. The services affect performance, the mapping of stylus buttons, and more. For ideal performance when using SketchBook, Input Services should be disabled.
    NOTE Once you restart your machine, Vista’s Input Services turn back on.
    To disable Input Services:
    1. Go to the Start > Control Panel > Administrative Tools.
    2. Double-click the Services shortcut to open the Services window, which lists all the services available through Vista.
    3. Scroll down the list and right-click Tablet PC Input Service.
    4. Select Stop from the menu provided. Input Services is now disabled and your Wacom driver takes over.

    I've tried it and it works! The only drawback is that you lose pen alignment in portrait mode in Skecthbook Pro. I made two batch files to toggle TabletInputService on and off.

    [​IMG]

    To disable pen inking, open up a text file and type: net stop "TabletInputService" and save as a .bat file.

    When you want to have normal pen inking again, open up a text file and type: net start "TabletInputService" and save as a .bat file.

    You may have to select "run as administrator" in properties or right click to get it working properly.
     
  3. RZetlin

    RZetlin Scribbler - Standard Member

    Messages:
    153
    Likes Received:
    0
    Trophy Points:
    31
    I recently got the TM2 1070ca and discovered that the TabletInputService conflicts with the Wacom tablet service when using the drawing programs.

    These are the steps I tried that seem to work.

    1) Install HP Wacom Drivers.
    Select software and drivers HP TouchSmart tm2-1070ca Notebook PC - HP Customer Care (Canada - English)

    2) Go to Control Panel->Administration Tools->Services

    3) Under Services
    Choose Tablet PC Input Service->Disable

    4) Restart the laptop

    So far the it works under Gimp and Sketchbook Pro.

    -------

    The official wacom drivers do not seem to work with the TM2.
     
  4. Voidward

    Voidward Pen Pal - Newbie

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    6
    I made a post about the sketchbook pro issue with using a different service here: Wacom Forum - Wacom Europe GmbH • View topic - HP Touchsmart tm2, Photoshop CS4 pressure sensivity but I'll repost here.

    Make a .bat file with the following:

    net stop TabletInputService
    start /d "C:\Program Files (x86)\Autodesk\SketchBookPro2010\" sketchbookpro.exe
    choice /d y /t 4
    net start TabletInputService

    replace [start /d "xxx" xxx.exe] with your app directory followed by the exectable
    replace [choice /d y /t #] to end with the number of seconds it takes to start the app

    The batch file stops the service, starts your app, waiting # seconds, starts the service so that you can still use it for other apps or the software keyboard. The app seems to work perfectly fine with the service started after the app has started.

    You can also download "Bat to Exe Converter" to make the .bat to an exe which runs invisibly when started instead of watching the .bat file run and also allows you to assign an icon to the file. An app called "IconsExtract" allows you to extract an icon from the original executable if it did not come separate from the original executable. Google for links to these.

    After this, make a shortcut to this new .exe you're made and place it in the start menu or whatever you feel like, it will take a few extra seconds to start up due mostly to stopping the service, but aside from that it seems to work decently enough to work around this issue for now. Hopefully HP or Wacom will get on this issue with an official patch.

    I'm including the .bat for the lazy and the .exe also, which is for the 2010 version of sketchbookpro installed in it's default directory. Just make a shortcut to it and it'll run just like normal.
     

    Attached Files:

    • Sbp.zip
      File size:
      90 KB
      Views:
      184
  5. DRTigerlilly

    DRTigerlilly Tablet Lead Mod (Retired) Super Moderator

    Messages:
    7,575
    Likes Received:
    742
    Trophy Points:
    301
    Nice contribution!
     
  6. tanuki

    tanuki Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Oh thank god- this was so obnoxious on my TC4400 prior to your post. Thankyouthankyouthankyou!
     
  7. animation_nerd

    animation_nerd Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    This is a copy of a post I made on the Wacom forums. Thought it might be helpful, as it doesn't require any hacking or batch files:

    There is a much simpler solution to enable pressure sensitivity in programs like Photoshop and as far as I can tell still keep all the touch functionality of your Tablet PC in Windows 7:

    This works with an HP 2740p.

    1. Download your Tablet PC manufacturer's Wacom Digitizer Driver.
    In my case: HP EliteBook 2740p Tablet PC- Wacom Digitizer Driver - HP Business Support Center

    2. Download the Penabled driver that is located on Wacom's European FTP:

    ftp://ftp.wacom-europe.com/pub/WINDOWS/Penabled_522-11.zip

    This driver does not yet appear on Wacom's official support page, it's probably an alpha or beta driver so use at your own risk.

    NOTE: I did a fresh install on Windows 7 64bit and installed the drivers in the order above.
    This method has the added bonus of providing you with the Pen Tablet Control panel which allows you to adjust the sensitivity of the input.
     
  8. schaba4

    schaba4 Pen Pal - Newbie

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    5
    Hello All,
    thank you very much for your precious information that helped me to make a working clean install on my brand new tm2 2190sf !
    I had trouble with sensibility in photoshop in the begining.
    After long install/uninstall processes, the solution described just above by animation_nerd worked for me ! I got sensibility in photoshop CS5 and also GIMP (which is quite more responsive in fact !...).
    Just one more precision: after the installation of the penabled pilot, I still had non reproductible strange behaviour with the pen in different applications.
    It turns out that I solved the problem by turning off definititly the tablet input service (you can do it by going in administrative tools / services / find the tablet input service / edit properties and turn it off).
    I don't no why, when I start windows and start using the pen, the service still launches once, I cut it then with the command "net stop tabletinputservice", and then everything works perfectly !
    Get acces to the tuning panel of the pen also, and the sensitivity adjustment works fine.
    The only drawback is that I loose of course the input panel functionnality, but I replaced it by a virtual keyboard, that does the job when required.
    Furthermore, I added a smal keypad to my computer that I remapped to use zoom/pen size... in Photoshop with keytweak software : works great !

    Hope this will help...
    thanks again !
     
  9. animation_nerd

    animation_nerd Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
  10. schaba4

    schaba4 Pen Pal - Newbie

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    5
    In addition to my post, I did not find any way to have multitouch working...
    Not a problem for me, Idid not care about this functionnality, but as long as I remember, I did not manage to have it working with the "out of the box" installation...
    Did someone manage to have it working together with pressure sensitivity ?...
     
Thread Status:
Not open for further replies.

Share This Page