The folder Itunes is on a locked disk....

Discussion in 'Microsoft Windows 7' started by Maianbarian, May 19, 2009.

Thread Status:
Not open for further replies.
  1. Maianbarian

    Maianbarian Pen Pal - Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I've been pulling my hair out all day over this error. I upgraded from vista to windows 7 (I know a clean install would be better but I didn't want to install all my programs/settings again) and itunes would no longer load, giving the error in the title.

    Reinstalling itunes didn't work, but after mucking around for a while I found out that if you find your itunes folder (I found mine under the "Libraries" menu in My Computer) and go to the secruity tab, then click edit permissions and tick the allow full access tab, itunes should work. Note that your Itunes folder is where your Itunes library is, not where the actualy itunes.exe is.

    I couldn't find a solution to this on google so I figured it can't hurt to post it here.
     
  2. airforcematt

    airforcematt Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I registered on here just to say thanks for this - been pulling my hair out on how to to fix this since I upgraded over a month ago, your tip worked perfectly.
    Thanks!
    Matt
     
  3. trulyhealthy

    trulyhealthy Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I had the same problem on Windows Vista and Windows 7 and drove me crazy.

    If everything else fails:

    Open the registry: Run regedit

    Make sure you are at the top of the registry: at "My Computer"

    Click Edit - Find, search for "My Music" without the quotes and select Values

    For each of around 6 instances, make sure the data points to either of:

    C:\Documents and Settings\USERNAME\My Documents\My Music
    or
    %USERPROFILE%\My Documents\My Music

    After you make all changes, Reboot the computer or log-off and log-in.

    Presto !!
     
Thread Status:
Not open for further replies.

Share This Page