Surface Pro 4 Discussion Thread

Discussion in 'Microsoft' started by spinedoc77, Oct 6, 2015.

Thread Status:
Not open for further replies.
  1. dream3

    dream3 Scribbler - Standard Member

    Messages:
    320
    Likes Received:
    14
    Trophy Points:
    31
    Guys can you check your units and see if the central part of the screen seems a bit raised when looking from the bottom or top side?

    Mine seems to behave like that. Near the type cover connector and near the cameras, which is right in the center of the screen, it seems to be 1mm or less higher and then it tapers. I tried pushing it down but it comes back up after some time.
     
  2. metalsiren

    metalsiren Scribbler - Standard Member Senior Member

    Messages:
    851
    Likes Received:
    261
    Trophy Points:
    76
    well my i7 replacement i5 has been working MUCH better than the i7. runs very quiet and almost no fan noise at all even on flash videos. so happy with that one for sure. not to mention I saved the 300 difference in models and an extra 100 since they are on sale at bestbuy right now :) so extra bonus there.
     
  3. Dayton

    Dayton Scribbler - Standard Member

    Messages:
    230
    Likes Received:
    24
    Trophy Points:
    31
    I think the fan noise / flash issue was with the last firmware and not with the i7. That issue disappeared for me with the 2/17 Surface 4 update.
     
  4. pokenguyen

    pokenguyen Pen Pal - Newbie

    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    6
    I found my SF4 works much better with 4352 intel hd driver compared to latest driver from windows update.
     
  5. metalsiren

    metalsiren Scribbler - Standard Member Senior Member

    Messages:
    851
    Likes Received:
    261
    Trophy Points:
    76
    yea I was at the end of my return policy on my i7 and the 2/17 update didn't help with that at all. Also after using it for 45 days or so found I didn't need the i7 so that was another excuse as well to step down and get some cash back.
     
  6. spinedoc77

    spinedoc77 Scribbler - Standard Member Senior Member

    Messages:
    1,871
    Likes Received:
    464
    Trophy Points:
    101
    Bleh, I'm getting the black screen on wake as well. My SP4 was one of the few that was functioning flawlessly, no issues with wake, no power drain. So for me this update went backwards, hopefully they fix it quickly.

    Also anyone know why MS strips out the Intel Graphics Utility? It's interesting because you NEED that utility in order to get some setups running like 4k monitors on the dock. I'm just curious what the reasoning is to strip out the utility and force us to hack our own devices to get them to work the way they should out of the box.
     
  7. jyan_osu

    jyan_osu Scribbler - Standard Member

    Messages:
    407
    Likes Received:
    115
    Trophy Points:
    56
    After the first day of the update where i got 2 black screens, I haven't gotten to black screen on wake yet. I did change all the power settings back to default and so far so good. I'll see how much longer this goes and if it happens again I'll try the latest beta video driver.
     
    dstrauss likes this.
  8. spinedoc77

    spinedoc77 Scribbler - Standard Member Senior Member

    Messages:
    1,871
    Likes Received:
    464
    Trophy Points:
    101
    Mine is actually getting worse. At first it was only once or twice a day, but today it's done it 4 times out of probably 15 or so starts. This is nuts, I wonder if Microsoft plays the Keystone Kops theme at their offices when they work on surface updates. Worst part is I'm stuck as you can't rollback firmware updates, otherwise I would have stayed on the previous one which was stable for me. I can't believe I own a freakin $2k device that needs to be force rebooted 1/3 of the time I use it.
     
  9. jyan_osu

    jyan_osu Scribbler - Standard Member

    Messages:
    407
    Likes Received:
    115
    Trophy Points:
    56
    Is there anything in the system event viewer for the times it won't wake back up? I'm not at my machine right now but I had a few things, which I can't remember what they are but I think it was display related.

    Sent from my SM-N910T using Tapatalk
     
  10. dstrauss

    dstrauss Comic Relief Senior Member

    Messages:
    9,755
    Likes Received:
    7,724
    Trophy Points:
    331
    Doc - so sorry to hear about your SP4 - you sound more like me these days. I can't believe I'm saying this, but my SP4 (i7/16gb/512gb) is actually better, in fact operates just like it is supposed to, since the 2/17 update. The first day after I installed I had two failures to resume from sleep, and a disconnect from my DP monitors attached to my dock, but I did a hard reset (power plus speaker buttons) and it has been stable and smooth since. Occasionally the fan comes on, like now, but no showing of excess CPU usage. Otherwise about 1-2% drain/hour.

    The only difference I've noticed with a lot of folks is I have disabled Windows Hello camera recognition, because I bought the fingerprint Type Cover for my SP3, and just kept it when I traded up to the SP4. I actually prefer the fingerprint login; when getting ready to dock just flip open, touch power button, touch reader, then snap off and dock. Not much help if going pure tablet mode (have to enter 6-digit pin) but I just have this feeling the camera login is what is causing power drain. I've got a long trip coming up, but if I get some time I'll try re-enabling it and see if I'm right.
     
    Last edited: Feb 22, 2016
Loading...
Thread Status:
Not open for further replies.

Share This Page