Surface Pro 3 - The problems thread

Discussion in 'Microsoft' started by MSGaldenzi, Jun 20, 2014.

Thread Status:
Not open for further replies.
  1. Taikero

    Taikero Pen Pal - Newbie

    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    5
    Is anyone else experiencing play in their Surface Pro 3 hinge? I went to Best Buy and their display model was the same as mine, but I wanted to see what others' experiences are like. It's loose and moves easily within the range shown.

    Here's a video I took.
     
    Last edited by a moderator: May 18, 2015
  2. soh5

    soh5 Wait and Hope (Bronsky et al.) Senior Member

    Messages:
    1,362
    Likes Received:
    692
    Trophy Points:
    131
    My hinge is ok, but when you prop it in the 150 degree position/easel mode you shouldnt sit on it.
     
  3. lancorp

    lancorp Scribbler - Standard Member

    Messages:
    141
    Likes Received:
    13
    Trophy Points:
    31
    How can something so blatantly broken get past QA testing and be included with a released product? Don't real people test these tablets before they are finalized and released? The WIFI issue is pretty bad, everyone seemingly is affected, so how could this be released?

    On battery, my down speed is fine (tested @40Mbps with adapter speed at 117Mbps) but my up is only 0.16Mbps, while the WIFI status sticks at 6.0Mbps during the up speed test. No one saw this during pre-release testing?
     
  4. symph

    symph Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Since none of the reviewers mentioned this, I would imagine it's a result some unforseen circumstances.
     
  5. be77solo

    be77solo Scribbler - Standard Member

    Messages:
    674
    Likes Received:
    171
    Trophy Points:
    56
    I have been dumbfounded by this problem since the Surface Pro 1.... their hardware is for the most part solid, but they (the very company that makes Windows ha) have the buggiest drivers of any device I use. I have used the SP2 since October and they finally fixed the crippling mSD/high CPU bug a few weeks ago!

    I guess I was hoping they figured things out by version 3 but they have not.

    My SP3 has the same Wifi issues... once it's actually connected, download speeds are fine but upload is atrocious on battery, causing a very laggy experience.

    Let's hope you talked to someone with a clue!
     
    JoeS likes this.
  6. JoeS

    JoeS I'm all ears Senior Member

    Messages:
    5,071
    Likes Received:
    3,201
    Trophy Points:
    331
    Each time you bring that up is basically a free 'like' from me. :) I'm still p!ssed off about how long that took them, and even more about the total lack of communication on the issue. I agree with the broader point too, it's crazy that drivers are so much of a struggle for MS itself.
     
  7. opasha

    opasha Scribbler - Standard Member

    Messages:
    208
    Likes Received:
    29
    Trophy Points:
    41
    Anyone else having static noise with your headphones when connected to the headphone jack if a video is paused or just browsing? I used two different headphones and the same issue occurs, but when I select playback devices, it goes away, but then returns when I close that menu. I'm confused as to what is causing it. Anyone experience this or have any tips on how to get rid of it? I tried to mute the mic, but that didn't solve the issue. Thanks.
     
  8. stoneseeker

    stoneseeker Animator and Art Director Senior Member

    Messages:
    3,601
    Likes Received:
    1,072
    Trophy Points:
    231
    Have you ever tried a Fujitsu?? They win buggiest drivers award hands down.

    If your experiencing issues, just uninstall the custom Fujitsu apps and drivers!
     
  9. jnjroach

    jnjroach Technology Strategist Super Moderator

    Messages:
    3,940
    Likes Received:
    1,266
    Trophy Points:
    181
    Osiris, demandarin and mack4000 like this.
  10. dstrauss

    dstrauss Comic Relief Senior Member

    Messages:
    10,064
    Likes Received:
    8,275
    Trophy Points:
    331
    As always a hearty thanks for a great tip. Just followed directions; got a solid connections; put it to sleep and on waking up was still connected.
     
    jnjroach and demandarin like this.
Loading...
Thread Status:
Not open for further replies.

Share This Page