Surface Pro 3 - The problems thread

Discussion in 'Microsoft' started by MSGaldenzi, Jun 20, 2014.

Thread Status:
Not open for further replies.
  1. johnchad14

    johnchad14 Scribbler - Standard Member

    Messages:
    172
    Likes Received:
    26
    Trophy Points:
    41
    I noticed its possible to pull out one side more than the other giving a slight wobble which can be corrected by matching the sides...due to the slight amount of give
     
  2. darkmagistric

    darkmagistric Scribbler - Standard Member Senior Member

    Messages:
    2,583
    Likes Received:
    1,686
    Trophy Points:
    181
    Haven't had any Wi-Fi problems with my device.....yet

    However today I did have a little scare.

    It was on Metro...and kind of froze....the cursor would still move but I couldn''t press or select anything, it was like the screen was frozen, then the unit shut off and went into restart mode.

    By itself it starting doing the whole Windows Update crap and it was taking a while....it restarted again, went into update mode again, restarted again......and then 10 seconds of super loud fan noise. I haven't heard a fan noise that loud since the HP TX2 days....and with the Pro3's design I didn't even think it possible for it to make such a loud fan noise.

    The unit then turned off....and I couldn't get it back on for almost 30 seconds....then finally it started up again loaded regularly.....its been fine the whole day.

    I hope that was an isolated incident with the update to blame, but for such a new and expensive device it does issue concern with me.
     
  3. Robotica72

    Robotica72 Scribbler - Standard Member

    Messages:
    129
    Likes Received:
    6
    Trophy Points:
    31
    Anyone else running into Phantom swipes in IE?

    I'll be typing (like this reply) and suddenly IE will open the URL up and I lose the focus on the reply box and have to tap to continue. It also happens when I'm just reading a page - BAM the URL box and all Tabs show up....

    Thinking it could be the touch cover since my enter key seems touchy (Not working after hitting it 3-4 times)

    FYI The Phantom swipes happened 5 times during this short reply...
     
  4. Lent53

    Lent53 Pen Pal - Newbie

    Messages:
    18
    Likes Received:
    2
    Trophy Points:
    6
    Thanks for the help. I did notice that as well. I am wondering because it my hinge is past half way and I go to write anywhere on the top half of the screen, my palm will actually push the rest of the hinge down. I was under the impression that this should be very difficult to do.:confused:
     
  5. sirbang

    sirbang Pen Pal - Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I am having the same issues also. If Surface sleeps for a long period of time when it is awakened the network driver is gone.
     
  6. darthhen

    darthhen Scribbler - Standard Member

    Messages:
    226
    Likes Received:
    0
    Trophy Points:
    31
    My SP3 won't recognize the Logitech dongle that's inserted into the USB port when it wakes up. So I end up rebooting.
     
  7. be77solo

    be77solo Scribbler - Standard Member

    Messages:
    674
    Likes Received:
    171
    Trophy Points:
    56
    Expect than fan noise any time you push the CPU/GPU :eek:
     
  8. gpmic

    gpmic Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Only one minor wifi issue all weekend (No adapter detected but a reboot fixed it). Today I'm trying to set up internet sharing and I don't know where the problem lies. When I first turned it on with my Nokia 1020 it seemed to work perfectly. Unfortunately, I didn't use it for a few minutes and my phone turned it off. Not a big deal but ever since I can only get it to work for about 30 seconds before the SP3 drops it again. I've tried rebooting both devices multiple times and nothing.

    I tried connecting via Bluetooth and that too drops out after a few seconds. Per the recommendation earlier, I re-installed the network adapter and rebooted (side note: I still see the Marvell network adapter, when I was expecting to see a generic adapter. Is that right?), still issues.

    I'm not sure if the issue resides on my 1020 or SP3 but it is extremely frustrating. I was hoping to replace my LTE iPad and so far I really love the SP3, but this is a dealbreaker, I might be returning the SP3. Any thoughts?
     
  9. ctonylee

    ctonylee Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    This is the driver version that doesn't throttle me when on battery power: April 24. This is the driver version: 15.68.3036.67 It still names Marvell as the adapter. When you uninstall the adapter make sure you check the box to delete all driver files.
     
  10. tallshorty

    tallshorty Pen Pal - Newbie

    Messages:
    21
    Likes Received:
    3
    Trophy Points:
    5
    Here is another one to add to the list:

    I left my tablet yesterday night in Connected Standby to see how much battery drain there will be. I went into CS at 96%. This is what happened in the morning:

    -turned on tablet (came out of hibernate I believe) and battery at 86%
    -keyboard lights up but doesn't work. Can't type anything. Detached and reattached and still doesn't work but lights up
    -right hand swipe from screen doesn't work

    So I shutdown and restarted the tablet:
    -Keyboard started to work but then it stopped working again. Detached and reattached but still didn't work although lights up
    -Battery now reads 69%

    I shutdown and restarted the tablet again:
    -Now keyboard works consistently
    -Right had screen swipe still doesn't work but swiping from touchpad on keyboard works

    Anyone else have this problem or have a solution the screen swipe issue?
     
Loading...
Thread Status:
Not open for further replies.

Share This Page