Surface Pro 3 - The problems thread

Discussion in 'Microsoft' started by MSGaldenzi, Jun 20, 2014.

Thread Status:
Not open for further replies.
  1. omegafiler

    omegafiler Pen Pal - Newbie

    Messages:
    62
    Likes Received:
    17
    Trophy Points:
    16
    Anybody else seen any light bleed along the edges? I've got a minor amount at the top. Not a huge deal, but it is slightly annoying when watching movies. Especially considering the 3:2 ratio leaving larger-than-normal black bars at the top/bottom.

    Best way to check is to connect power, max brightness, and view a black background/image/video, while in a dark room.

    I first noticed while it was sitting at the Suface logo forever during the firmware update.
     
  2. Mesosphere

    Mesosphere Geek. Senior Member

    Messages:
    5,313
    Likes Received:
    2,060
    Trophy Points:
    331
    Probably a good idea to have a backup anyway... if you need a rationalization =P
     
  3. MSGaldenzi

    MSGaldenzi Scribbler - Standard Member

    Messages:
    374
    Likes Received:
    65
    Trophy Points:
    41
    I don't have any lightbleed issues on my second SP3.

    I am on battery power now and getting the same results on my wifi. I am not using ac, just n on a dual band apple airport router.
     
  4. be77solo

    be77solo Scribbler - Standard Member

    Messages:
    674
    Likes Received:
    171
    Trophy Points:
    56
    Well the good news is you can have multiple pens synced at the same time I have discovered :thumbsup: Wasn't sure how that would work but new pen synced seamlessly and old pen button still opens one note as well.

    Edit: Any thoughts on this issue? Its driving me nuts... Problem 3:


    "Originally Posted by lonaysta View Post

    Oh I'm totally confused about the processor frequency management policy...Each time I play a online video (Chrome..you know, takes a lot of CPU..), the frequency drops down to around 1GHz and other tasks become slow...As soon as I pause the video the frequency goes up above 2GHz....Why not the opposite?...

    And there seems to be no way to configure my own detailed power management profile..."


    I'm having this problem too with Flash items, literally brings the device to an unusable crawl... never run into this before. Any ideas? This is a deal breaker issue!
     
    Last edited: Jun 21, 2014
  5. opasha

    opasha Scribbler - Standard Member

    Messages:
    208
    Likes Received:
    29
    Trophy Points:
    41
    Ok, for everyone having wifi issues. I'm running a d-link 865L AC router (solid/fast router) with 5GHz band. I just tested this and got the annoying 6mb wifi when on battery power as opposed to my 865mb while plugged in. So as per really poorly written instructions I found in one these threads, I found a solution. While remaining on battery power, I went into Control Panel > Device Manager > Network Adapters > Marvell AVASTAR Wireless-AC Netwrok Controller.
    1) Right click the network controller and Uninstall - a pop up will warn you that you are about to uninstall this device from your system. Also, check the box that says "Delete the driver software for this device." Then select Yes for the uninstall. You will see a computer in the right corner of your screen with a big red X on it indicating you no longer have a wifi driver.
    2) RESTART your Surface Pro 3
    3) Sign in, wait a few seconds and you will see the wireless bar symbol with an Asterick there indicating that there a new wifi networks available - select your wifi network and put in the password again.

    You can now go into network settings and click on your wifi network and see the same speed as it is plugged in while on battery power. After I did this, both plugged in and on battery were 865mb and fast internet again! Good luck :).
     
  6. Romer

    Romer Pen Pal - Newbie

    Messages:
    49
    Likes Received:
    24
    Trophy Points:
    16
    This improved the wifi speed and increased my large file transfer from 10-18MPS to 20-25MPS. Across other computers in my house I can transfer these same files at 45MPS. I am guessing the difference isn't the wifi but the encryption on the surface. Anyone unencrypt their surface HD?
     
    demandarin likes this.
  7. minnus

    minnus Pen Pal - Newbie

    Messages:
    27
    Likes Received:
    5
    Trophy Points:
    5
    You have no light bleed at all? Or are they just minor and acceptable? The former would be fairly impressive.

    Mine has minor bleeding. Enough to bug me, but not enough for me to do anything about it.
     
  8. omegafiler

    omegafiler Pen Pal - Newbie

    Messages:
    62
    Likes Received:
    17
    Trophy Points:
    16
    Yeah, I'm still contemplating exchanging it anyways to see how the 2nd one looks. Especially with so few reports of it. It's just that in my experience, if one has light bleed, they all do. Then there's a risk of having one even worse light bleed. Plus the good possibility that they all have it, and very few people are noticing it. :)
     
  9. be77solo

    be77solo Scribbler - Standard Member

    Messages:
    674
    Likes Received:
    171
    Trophy Points:
    56
    Mine's got a bit of light bleed as well, mostly around the corners and a bit in the middle top. Nothing that's a problem in my opinion, as I don't know of any devices I've got that don't have some sort of light bleed. It's not bad enough that I think it will distract me while watching a movie, and I doubt you'll find one with none. But, if yours is particularly bad or annoying swap that puppy out.

    On a new note, I'm getting across the board worse performance from my SP3 than my SP2. Temps are hotter, fan is louder, and everything just feels a bit more sluggish (this is after letting it sit a couple days powered on letting Windows sort itself out, so not related to that). Benchmarks are ~20% slower. Is there hope for this via a possible firmware update or is this just a design compromise MS made with the thinner chassis? Louder fan and hotter temps I'm ok with given the thinner size, but slower performance is NOT acceptable. I fear we are back in the SP1 territory where the hot running Ivy Bridge hurt enjoyment.... <Broadwell> cough.

    Having said that, I also remember the SP1 received a firmware update after release that stabilized/improved performance.

    In summary, my SP3 problems are:

    1) Crippling WiFI performance on battery
    2) Pen Nibs are impossible to come by and easy to lose
    3) Windows screeches to a halt when running anything FLASH related, dropping the CPU to 1GHZ and stutters constantly, literally requiring a reboot.
    4) Overall slower performance across the board compared to the SP2.

    Love the new keyboard and screen, honestly as much as I was initially vocal against the new size, it's noticeably more useful and productive. Hoping I can get these issues sorted.... otherwise back to SP2.
     
  10. maximum360

    maximum360 Pen Pal - Newbie

    Messages:
    41
    Likes Received:
    3
    Trophy Points:
    16
    I tried this but once I delete the driver software it's gone [there's no auto install] and I'm not sure what directory it's in. A very frustrating experience.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page