Surface Pro 2 discussion thread

Discussion in 'Microsoft' started by JoeS, Sep 23, 2013.

Thread Status:
Not open for further replies.
  1. Vogelbung

    Vogelbung Pen Pal - Newbie

    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    16
    What, do you think, are my realistic chances of getting a full resolution for the 'Cover engages electrically only ~70% of the time' problem?

    I know I can get it replaced. But
    a) I'm not sure at this point in time it'd be replaced by a refurb - possibly not this early in the game, but I don't know. Like the previous Surface disasters I don't want mine - which does not appear to have any physical defects - replaced by ones which do.
    b) I have no idea if the problem will actually be resolved. It never was with my Surface Pro and Surface, no matter how often I had it replaced.

    I'm buying / planning to buy other Core based tablets and considering moving on for good if any of the others are less annoying in this respect - as I do take the cover off often.

    ?????
     
  2. Dayton

    Dayton Scribbler - Standard Member

    Messages:
    230
    Likes Received:
    24
    Trophy Points:
    31
    Use the Type Cover 2, in the two plus weeks I think my SP2 hasn't detected it twice. When I tried the Touch Cover 2 I experienced what I think you are referring to.
     
  3. Vogelbung

    Vogelbung Pen Pal - Newbie

    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    16
    I am using the Type Cover 2.
    (I have two)
     
  4. be77solo

    be77solo Scribbler - Standard Member

    Messages:
    674
    Likes Received:
    171
    Trophy Points:
    56
    Well, not that it means much, but I've rarely had the issues you seem to be having with the keyboards, so not sure if it's your keyboards or the device. I have two SP2's and also had a SP1, and with both a gen 1 type cover and a gen 2 type cover alternating between devices, I've never had the keyboard not recognized on the SP2's in the past 3 weeks used for work and play daily with keyboard attached and removed regularly.

    I can remember with the SP1 once that I had to unsnap and reattach the type 1 cover, but it was just never an issue. I believe the design is solid and reliable, subject to wear of course, but I fold mine back regularly as well as remove when mobile and attach when needed and it just hasn't been an issue.

    So, for what that's worth, yes I'd be shocked if you had this problem further once you determine what the problem is. Maybe a bad initial batch of keyboards and you unluckily got two? Maybe you did get a defective SP2, it happens. But, with my two SP2's (one from Microsoft Store and one from Best Buy, so theoretically random examples) the keyboards are totally reliable thus far, so can't see it as a wide spread problem.

    Good luck, problems are always frustrating on a high end device. I'm currently battling a Sandisk Extreme micro SD memory card that decides to randomly disappear... top end premium card and still has issues.
     
  5. Dayton

    Dayton Scribbler - Standard Member

    Messages:
    230
    Likes Received:
    24
    Trophy Points:
    31
    I am having the exact opposite experience with the Type Cover. I had detection issues with the Touch so just assumed.
     
  6. SAM 2013

    SAM 2013 Scribbler - Standard Member Senior Member

    Messages:
    859
    Likes Received:
    221
    Trophy Points:
    56
    Greetings

    I apologise if this has been asked before, but I could not find the post.

    I have purchased a Venue 8 Pro with 32 bit Windows 8.1 and
    it runs our older programs, but the digitizer is not comparable
    to the Surface Pros as of yet.

    My Surface PRo has Windows 8 and is 64 bit and will not run all of our older
    programs. Can you install 32 bit Windows 8.1?
    Or is there another solution.

    Thanks in advance
     
  7. DragonGamer

    DragonGamer Pen Pal - Newbie

    Messages:
    61
    Likes Received:
    3
    Trophy Points:
    15
    Have you tried compatibility modes for the programms?
     
  8. jnjroach

    jnjroach Technology Strategist Super Moderator

    Messages:
    4,150
    Likes Received:
    1,606
    Trophy Points:
    181
    The Touch and/or Type Covers disconnect issue was dealt with in the Surface 1st Gen products with a Firmware Update and I believe there is a Firmware Update coming this week....
     
  9. jnjroach

    jnjroach Technology Strategist Super Moderator

    Messages:
    4,150
    Likes Received:
    1,606
    Trophy Points:
    181
    Are these applications 16bit DOS/Windows 3.1 Applications? Or perhaps legacy 32bit Applications that won't install on the 64bit Windows? If it is the former, you may investigate using a Virtualization Solution to run a 32bit Install. If that won't work, you could attempt loading a 32bit Install of Windows but drivers may be an issue and I doubt you will receive any further Firmware Updates.

    If it is a legacy 32bit application that won't install, the most likely issue is the InstallShield Installer was created using mid-2000s default settings which created a 16/32bit Installer, this typical when the installer is called setup.exe (this was the default through 2006). You can use a solution like the Microsoft Application Compatibility Toolkit to remove the 16bit installer or sometimes an easier solution is to use a program like 7zip and extract the files from the installer and find the appname.msi and install it from that as it would be a true 32bit installer.
     
    Last edited: Nov 12, 2013
    internalaudit likes this.
  10. SAM 2013

    SAM 2013 Scribbler - Standard Member Senior Member

    Messages:
    859
    Likes Received:
    221
    Trophy Points:
    56
    Thanks for the tips. I am going to try them.

    The software does not like 64bit, 32bit Windows seems to be OK
    in compatability mode.

    I did not know 7xip would tear apart an .exe
    I have tried VirtualBox but it did not solve my problem.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page