SUDDEN FAN NOISE, AFTER YEARS OF USE

Discussion in 'EP121 Slate' started by anguscoleman, Apr 24, 2016.

  1. anguscoleman

    anguscoleman Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    15
    Hi, the fans of my tablet has begun to get active some weeks ago. Never heard them, before. It is not a strong noise, but it is quite annoying aniway. In the beginning, I just had to turn off the ep121 and to turn it back on for fixing the problem. But now the fans keep working non-stop.
    There are a lot of old threads online, and it is quite tough to find some solutions. Does anibody have the right answer to my problem or some good advice to follow?

    Thank you very much.


    Angelo
     
  2. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56
    If your EP121 had not been openned before..probably dirty vents. Or fan thermo cable is loose.

    Otherwise many other possibilities.
     
  3. anguscoleman

    anguscoleman Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    15
    Thank you, CF. I indeed opened the tablet (I had to do it many times before, for other reasons) and checked the thermo cable, that looked regularly connceted. I had no idea what else to do: I just blew some air with my mouth in the fans zone, and I moved delicately the thermo cable to make it less bent. Well, it seemed to have worked for now: Ep121 has been silent all afternoon. If the trouble comes back, is there a more serious maintenance I can do?
    Thank you again.
    Angelo
     
  4. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56
    What you described is cable loosen..you might add a tape to hold the connector latch down...
     
  5. anguscoleman

    anguscoleman Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    15
    You mean..I should use some tape to keep the extremity of the cable that goes to the cover more stable? My english is a bit limited..:)
     
  6. anguscoleman

    anguscoleman Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    15
    Excuse me, CF77, my problem is back and it seems to have gotten worse. Fans start up when I start the slate and never stops anymore. I tried to reopen it and fix better the cable, with no success. What did You mean precisely with "add a tape to hold the connector latch down". Wich part of the cable is the latch? The one that connects to the cover or the one that goes to the motherboard?
    In the worst scenario, if I shoud buy a new cable (but it seems not so easy, here in europe), is it easy to replace the old one?

    Thank you

    Angelo
     
Loading...

Share This Page