Softwares that works/not working with Win10

Discussion in 'EP121 Slate' started by CF77, Aug 7, 2015.

  1. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56
    realtek driver is 7541 64 bit from jun 2015

    bluettoth module 8.0.01.314 64bit from qualcomm 2013 dec
     
  2. hgkamath

    hgkamath Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    This post is just troubleshooting for the hotkey-gsensor problem and pinch-zoom.
    See post 10 link for EP121/B121 "Windows 10 EEE Slate Driver Information"

    hotkeys for Hardware buttons, G-sensor-autorotate Investigation

    Symptoms:

    G-sensor (not working)
    Asus hardware keys (not all working)

    a) hw-osk-button brings up osk(On-Screen-Keyboard) before login, but does not work after logging in as non-admin user. system-tray-ui-keyboard-icon in system tray does brings up osk. If the osk has been brought up by the system-tray-ui-keyboard-icon and showing on screen, then pressing the hw-osk-button does work to hide the osk instantly.
    b) hw-home button works; win10 brings up start-menu
    c) hw-volume buttons work; volume changes, win10 shows changing vol level overlay-ed on display
    d) action-center-rotation-lock-toggle-button works; ie grey/ungrey. When greyed. rotation state can be manually set in settings->system->display
    e) hw-rotation-lock slide button has not affect on the action-center-rotation-lock-toggle-button or on the settings->system->display.
    f) g-sensor rotation not working even though not-under-rotation-lock.
    g) power button short-press puts eee-slate into standby.

    Duncken on "[drivers] windows 8", page-10, post #93 (link) says installing hotkey service driver solved the issue that keyboard-hw-key can only hide OSK, by installing hotkey service-driver

    Info/investigation
    Is Asus launcher service enabled in msconfig startup? is it running?
    - yes it is enabled, yes "Asus Launcher service" can be seen running in taskmgr

    Press on keyboard Windows+R keys to open the Run dialog, type services.msc
    Are there any other Asus services other than "Asus Launcher service"
    - no

    Where are the files Asussender.exe, Asusservice.exe (asus launcher serivce)
    - they are located in c:\windows\syswow64

    is hkcmd.exe running?
    - yes, hkcmd.exe is not directly provided by Asus but is related to hotkey feature of the intel-graphics-manager. It can be seen running in taskmgr. It is started by
    HKEY_LOCAL_MACHINE\software\microsoft\windows\currentversion\run

    does Hotkey-Service show up in control panel?
    - no

    Start the windows task-manager. Are there any asus programs running in taskmgr
    - other than asusservice (asus launcher service), no

    does EEEslateatk200(ASUS EeeSlate Hotkey) show up in control panel?
    - no, but it is surely installed as windows-10 pulls the 1.0.0.5 driver automatically from the windows-updates. In the device manger "EeeSlate ACPI Utility" device is present with driver version v1.0.0.5

    is the Intel graphics properties hotkey feature enabled?
    - yes, and the ctrl-alt-up/down/left/right work

    Are padkeycontrol, hotkeyservice, hotkeymon services running, or are they just programs that asus launcher service invokes?
    - they are programs invoked by asus launcher service via asus sender

    Does windows 8/windows 10 use hotkeyservice or are they windows-7 only tools?
    Users seem to suggest that Windows-8 recognizes volume rockers and home button via the bios, for which bios updates were also necessary and so they work fresh out of the box without any drivers or services.
    - It is needed for osk and autorotation-lock

    Do these file exist ?
    C:\Program Files (x86)\ASUS\EeeSlate Hotkey\PadKeyCtrl.exe
    C:\Program Files (x86)\ASUS\HotkeyService\HotKeyMon.exe
    C:\Program Files (x86)\ASUS\HotkeyService\HotkeyService.exe
    C:\Program Files\ASUS\Gsensor\LoadSensor.exe
    - they ought to, but only if install was success

    Check is any of the above is in HKCU/HKLM?
    They are usually started by via asussender in HKCU run entry or in HKLM as in
    [HKEY_LOCAL_MACHINE\software\microsoft\shared tools\msconfig\startupreg\HotkeyMon]
    AsusSender.exe C:\Program Files\ASUS\HotkeyService\HotKeyMon.exe
    - nope not there

    Check registry [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run]
    - yes, the corresponding asus sender entries ought to be here
    AsusSender.exe "C:\Program Files (x86)\ASUS\EEESlate Hotkey\PadKeyCtrl.exe"
    AsusSender.exe "C:\Program Files (x86)\ASUS\HotkeyService\HotKeyMon.exe"
    AsusSender.exe "C:\Program Files (x86)\ASUS\HotkeyService\HotKeyService.exe"
    There is also an entry for asusetdcfg.exe. whatever it is it runs in taskmgr with the program name "Fix Win8 Elan TP issue". The name seems to imply that it has something to do with an elantech touchpad. In the context of eee-slate it is unclear what it really does.

    Diagnosis and Fix
    The only packages needed are
    * EeeSlateUtil_atk0200_1_0_0_5 for the hotkey driver, hotkeyservice-eeeslate-app
    * EeeSlateUtil_atk0201_1_0_0_2 for the asus gsensor driver, and gsensor eeeslate-app
    Each Package contains both drivers as well eeeslate-apps
    To complicate things, Windows 8/10 can automatically download and install the drivers through the online driver search in addition to getting the package via windows update channel.
    Its very likely that the driver-installation has already happened though the eeeslate-apps are not properly installed with the right registry keys, services and startup items.
    Speculation is that when the asus setup files determines that the "Eeeslate ACPI utility" drivers are already installed, the setup decides to skip installing the eeeslate-apps, ie the hotkey-service and the gsensor eeeslate-apps

    unzip the two zip files in the download s directory

    Open a command prompt window with admin privileges
    cd c:\users\username\downloads
    cd EeeSlateUtil_atk0200_1_0_0_5

    rem This directory contains a data directory
    cd data
    rem this directory contains an executable 'InstEeeSlateApps.exe', ignore that, and also two directories PadKey, HotkeyService. Install each eeslate-app separately.
    cd Padkey
    msiexec /i 409.msi
    cd ..\HotkeyService
    Setup.exe

    rem check files are installed
    dir "C:\Program Files (x86)\ASUS\EEESlate Hotkey\PadKeyCtrl.exe"
    dir "C:\Program Files (x86)\ASUS\HotkeyService\HotKeyMon.exe"
    dir "C:\Program Files (x86)\ASUS\HotkeyService\HotKeyService.exe"


    cd c:\users\username\downloads
    cd EeeSlateUtil_atk0201_1_0_0_2

    rem As before it contains a data directory with a 'InstEeeSlateApps.exe' . so as before descend.
    cd data\Gsensor\64
    msiexec /i 409.msi

    rem If it asks to repair the Asus G Sensor, select that and click finish
    rem check if file installed
    dir "C:\Program Files\ASUS\Asus G Sensor\LoadSensor.exe"

    reboot

    goto devicemanager
    This will recreate the 'Asus G sensor device' and the 'sdo sensor v2 device'
    under ACPI find "Microsoft compliant acpi system" ,expand it, right click on it
    click on "scan for hardware changes"
    This will recreate the "EeeSlate ACPI Utility (Gsensor)" device
    Make sure "autorotation is on" which is same as saying "windows 10 action center rotation lock toggle is off"
    swivel tablet to check that gsensor rotation is working

    Status
    (success) Hardware-osk-button brings up osk and hides the osk as well
    (success) Hardware-autorotate-lock button toggles the rotation-lock status and the software button in "action center" is also toggled, it also displays a autorotation-on/off overlay message on-screen
    (the-same) G-sensor autorotate not yet working

    ...more trouble-shooting
    The device manager showed that now, there were three Asus-G-sensors
    1st Asus Gsensor, device-id 0000, green sensor icon, 2006 microsoft driver 6.1.7600.16385 10/12/2010
    2nd Asus Gsensor, device-id 0001, blue sensor icon, with Asus driver 6/13/2012
    3rd Asus Gsensor, device-id 0002, green sensor icon, also asus driver but with no date

    So what is happening is that windows is taking its rotation input from the asus-g-sensor device device-id 0000, which is perhaps a relic from a previous install and hence non-functional.

    In the device manager,
    Delete all three asus g-sensor devices from device manager (right-click uninstall)
    Under "Microsoft WMI-ACPI" uninstall the device "EEEslate ACPI utility (Gsensor)" Also

    Repeat the g-sensor install procedure from above from the g-sensor part starting with entering EeeSlateUtil_atk0201_1_0_0_2 folder.
    msiexec /i 409.msi
    This time around the procedure will end with one working asus g-sensor device with sensor device-id 0000

    check device manager
    There will be one asus-g-sensor, however the "EEEslate ACPI utility (Gsensor)" will still not be created.
    The below is the strategy suggested by "The Drake" in post #3 link of this thread.
    In order to recreate the device, right click "Microsoft WMI-ACPI" and scan for hardware devices
    Windows-10 will again automatically find the "EEEslate ACPI utility (Gsensor)" 1.0.0.2 and install it

    This time around the auto-rotation will work.

    Status
    (success) This time g-sensor auto-rotation works

    ...more trouble-shooting
    * One observes that there are three AsusSender processes in the taskmgr, corresponding to padkeycontrol, hotkeyservice, hotkeymon

    Pinch-zoom Investigation

    Other's have complained that touch-panel becomes stuck or system-crashes after first touch. If this is the case, then the most likely the touch-driver is wrong. usually this happens with the latest Egalaxtouch drivers. Make the touch device "HID\VID_0EEF&PID_A001&COL01" have the right driver EETI PCAP 1.2.0.0.

    symptoms
    EETI PCAP multitouch digitizer driver (1.2.0.0, 01/21/2011) and Wacom-Pen driver (7.2.1-21, 3 Feb 2015) installed
    pinch zoom works in:
    (*) desktop-application Firefox
    (*) metro-app multi-touch-test confirms 2-point-touch and tracks the touch of two fingers and shows cross-hairs for each.
    pinch zoom does not work in:
    (*) metro-app Edge-Browser
    (*) metro-app Photos

    The control panel has a "pen and touch" panel item.
    Enter the "pen and touch" panel dialog and then click on the "touch"-tab.
    The touch tab lists double-click and right click but nothing else.
    The settings button allows to change duration associated with each of the touch gestures.

    Speculate that windows-10 is not adding the full-suite of Windows-OS touch gestures if it doesn't see a 10-point touch device, and maybe new metro-apps directly treat OS touch gestures as an input of interpreted key-messages similar to mouse-clicks and key-strokes (MSGesture-Object) link. Maybe Firefox may be falling back to a legacy desktop-app method of reading multi-touch api features allowing it to do pinch zoom. Mozilla multi-touch project link, Bugzilla bug 508906 suggest that mozilla is reading win-7 experimental touch-apis. In Win7, touch is included in the MSPointer APIs. There seem to be MS patents link involved and maybe MS strategy is to make OEMs, peripheral and driver makers to pay in order to be win8/10 ready. The metro app "multi-touch test" is an app that can be used to see if multi-point touch inputs are readable by metro-apps. It so happens that on eeeslate the "multi-touch test" app can register the touch of two fingers, but the touch tracking is lost the moment one makes contact with a third finger. This demonstrates that metro-apps can directly read MS-pointer multi-point touches.
    So the question boils down to whose responsibility is it to recognize multi-touch gestures? Is it the role of the touch-driver to relay Touch-gesture-events to windows-8/10, in which case unless EETI-PCAP driver is win8-ready, it will not detect and relay such gesture-events. On the other-hand, if it is the OS that recognizes and configures these touch-gestures, then because the OS is not creating these touch gestures by itself, there could be a 3rd party software utility that adds these OS touch gestures, so that they can be further customized in the "pen and touch" panel

    Status for pinch-zoom
    (unresolved) no way to proceed, pinch-zoom needs OS-level metro touch-gesture recognition somehow.

    EEE slate B121 64/4 Win10x64 bios->603AS
     
    Last edited: Nov 7, 2015
  3. Dallas Vette

    Dallas Vette Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    UPDATE: For those who are STILL having problems with the touch screen despite the above recommended drivers (they come default with a fresh Win 10 install these days) My relief FINALLY came from a driver dated in 2006! Google this .cab file and download:
    MICROSOFT.10.0.10240.16384.578f8608-ed651474-31ac6640-99c6cbed.cab
    I don't know what is in the file because I didn't install it directly. I used a program called DriverAssist that saved my ass. It is fully endorsed by Microsoft. It detected the driver issue somehow (along with a dozen other driver issues). I only installed the USB driver entry in the Human Interface Device section. I installed that driver only (not the entire batch of drivers it recommended across all devices) You will need a license key to install it & if you don't have one the software takes you to the website easily enough to do so. I took a chance on this software & after I pasted the license key the driver install took place and result was instant. Now I'm going to go back & check out some of the other recommendations now that I know it works!

    Came across the Driver Assist prog as an ad on DriversGuru (all they had to offer was the same modern drivers by ASUS.

    I can't recommend this third party installer enough to us EP121 users as it dragnets every driver in your system and gives the recommendations. You pick & choose what you want & it even has an "automatic rollback timer" if you don't like the result of the install.

    PS: I am NOT a newbie on here and this isn't SPAM. I haven't posted on here since EP121's "hey day" & spent days updating this software. I was one of the first to crack it open to upgrade the hardware! So much time has gone by & couldn't remember old email addresses & pwds.
     
    Last edited: Sep 1, 2017
Loading...

Share This Page