Softwares that works/not working with Win10

Discussion in 'EP121 Slate' started by CF77, Aug 7, 2015.

  1. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56
    Just to start a thread to note which software does or does not work in W10 with Ep121/B121.
     
  2. seenick_art

    seenick_art Pen Pal - Newbie

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Heres my list of NOT Working Win 10 items

    1. Auto Screen Rotate | Lock out button (G sensor) - disabled
    2. Keyboard button - disabled
    3. Two finger touch/pinch zoom on metro style software (i.e.Microsoft Edge) 1 finger works perfect but as soon as a second finger touches the screen at the same time ...touch freezes.
    4. Bluetooth on/off - missing


    The volume buttons didn't work either but I just flashed to 704 and it fixed that. Now home button also brings you back to the desktop.
    Everything else runs smooth.

    Thanks
    Nick
     
  3. TheDrake

    TheDrake Pen Pal - Newbie

    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    6
    1 & 2: That's due to incorrectly installed drivers, it's happened to me too after I did a full reset.
    In order to get them back working you have to go to "Device Manager" and do the uninstall with ticking the remove drivers checkbox. You need to do it to both the "EEslate ACPI etc" that are under "System devices".
    Once you're done you just need to do the usual "Scan for hardware changes" and do the automatic find driver thing on both. Then reset and it'll work.

    4. This one baffles me, when I updated from windows 8.1 I had a greyed bluetooth button in the notification panel, but I didn't actually try it...
    After a full reset I had no button, so I guess it installed the wrong driver, the Device Manager dance led to no result.
    Then I downloaded a 8.1 driver from Atheros and the bluetooth button reappeared... the catch is that when you disable it, the button itself disappears because it literally disables the device under "Device Manager" so I have to go back there to reenable it.
    I wish I had my hands on the previous driver to see if it worked properly... damn.
     
  4. kamikaze458

    kamikaze458 Scribbler - Standard Member

    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    31
    1&2 The Drake solved them (i didnt try it)
    3.Ultra annoying bug. Surprisingly Google Chrome works better the Edge browser. For example... In chrome with windows 10, pinch to zoom works flawlessly and keyboard auto pop up works automatically with every textbox.
    I had to install de Touch driver posted here: http://forum.tabletpcreview.com/threads/windows-10-on-ep121.64143/ to make it work (before thar touch worked like a mousepad in the screen). But even with that driver, touch does not work well with metro apps.

    4.I had to reinstall bluetooth driver.

    5.Picture thumbnails never showed up in folders.
    6.Opening programs and folders was considerably slower than in win7.
    7.I had to create a hotmail account to download Apps from the market.
    8.DrawboardPDF has the same issue as Edge explorer... as soon as you try pinch to zoom... touch becomes weird.
    9.Cortana's text box is too long.. can we narrow it.
    10.Double tapping (an icon from desktop) does not work very well. Is extremely laggy (works ok with the pen).
    11.OSK many timed pops up with handwritting as default input method. I couldnt make classic keyboard to be the default one.


    Anyways, as my ep121 is my main laptop and i use it every day i needed to be 100% functional so i did the recovery to win7. Thankfully the recovery worked great and return my computer to the exact same way it was before the upgrade. I guess i'll try w10 again in a few months.
    I hope asus do some drivers upgrades.
     
    Last edited: Aug 17, 2015
  5. seenick_art

    seenick_art Pen Pal - Newbie

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Thanks the drake... keyboard and Auto rotate function properly now! Bluetooth is working and stable but i still don't have a toggle switch. So Bluetooth always on.

    I guess we will have to wait for an update regarding the pinch zoom in the metro apps.

    Thanks
    Nick
     
  6. kamikaze458

    kamikaze458 Scribbler - Standard Member

    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    31
    i think it's not just pinch to zoon... as soon as your second finger touches the screen... touch becomes useless (even for panning) in metro apps, making them useless. If you have a mousse or the pen you pan and scroll a little bit and seems to reset the touch for one finger, but again... as soon you try some two finger function.... bas news.

    After rebooting once or twice my edge icon dissapeared (it's still in there... i mean i can click it and edge opens... but no image).

    Other thing i noticed is that the jump list of my frequent folders takes too long to display (it was generally instantaneous in W7).
     
  7. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56

    I asked ASUS about the drivers...there is no real answer.only to pass the request to their manager.
     
  8. kamikaze458

    kamikaze458 Scribbler - Standard Member

    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    31
    Hopefully they'll post drivers as they did with win8.
    I guess you were not running W8, but W7? or am i wrong?

    I was very happy to see W10 in my EP121, but i guess i'll ve to wait a bit longer.

    If' you 're still running W10 y recommend seang ong's surface 3 youtube videos. Some things can be useful for our ep121
     
  9. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56
    still on win 7...I'll wait until the number of major bugs decreased.
     
  10. hgkamath

    hgkamath Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    moved Hotkey/G-sensor/pinchzoom trouble-shooting to post-12 link

    " people please mention
    1] device-manager-device-name
    2] and it's driver-name-and-version
    3] Whether it works / It does not work"

    status: success: AFAIK Everything works as best as it should

    Link to this post: http://forum.tabletpcreview.com/thr...rks-not-working-with-win10.67214/#post-445646

    Windows-10 EEE-Slate DRIVER INFORMATION for EP121/B121

    Touch Screen (works)
    HID\VID_0EEF&PID_A001&COL01
    Install EETI PCAP multitouch digitizer, 1.2.0.0, 01/21/2011
    Find the touch panel device in device manager, then regardless of whether you have latest driver for USB Touchscreen Controller (A001) or egalaxtouch or something else, uninstall driver/roll back/update.
    DeviceManager--->Right Click --->Update-driver--->browse-locally--->pick-from-list---> choose
    The "EETI PCAP multitouch digitizer 1.2.0" driver definitely solves touch problems on B121
    Palm rejection also works
    Note that eee-slate capacitive touch is 2-point only, and hence only one-finger and two-finger gestures (pinch-zoom/rotate) will work. Currently, Windows hardware quality certification for windows-10 requires 10-point support for new devices. Full range of win-10 3,4,5-finger gestures will-not and cannot work on asus-eee-slate.
    The EETI touch screen is part of the Wacom Dual-touch Digitizer.
    The touch screen on the eeeslate is set to operate at a lower scanning field frequency of 50Hz perhaps in order to save power as compared to the installation of identical touch screen in other devices on the market.
    EETI PCAP multi-touch digitizer v1.2.0 01/21/2011 (for download info see post 4 link by "Washington Junior" in thread "Windows 10 on ep121?" 8/6/2015 link )
    pinch-zoom working in firefox, but not in metro apps edge-browser and photos.

    Wacom Pen (works)
    HID\VID_056A&PID_0090&COL02\7&29BDEF88&0&0001
    Windows-10 finds and installs the pen driver automatically
    Download Wacom Legacy driver from link
    "ISD DualTouch Driver", 7.1.0-8 30, Oct 2012 is claimed to work link
    I installed "Tablet PC – Enhanced Tablet Driver", 7.2.1-21, 3 Feb 2015. no problems, at first glance most things seem to be working.
    * The Wacom drivers also install a "Wacom Pen" Utility Desktop-application for calibration and other customizable settings like ripple effect, pen button action, hover-effect etc. It is available as a short-cut in the start-menu.
    * One-finger touch works.
    * This undoes the EETI-PCAP driver, and the "USB input device" that corresponds to the touch screen with device id VID_0EEF&PID_A001 is reset to a Microsoft 2006 driver. As before goto Device_properties->driver->update-> browse->pick and again switch to EETI-PCAP multi-touch digitizer.
    * There is speculation that the Wacom drivers were not necessary and they might have just installed a second ghost pen, changing Wacom pen setting say for ex changing the ripple does not have any effect by the pen even after a restart.
    pinch-zoom working in Firefox, but not in metro apps edge-browser and photos.
    * Wacom has a "diagnostics" window, which can be located as follows. Open the Wacom Tablet Properties, click ABOUT and then DIAGNOSE to open the Diagnostics window.
    * Wacom provides the utility “WacomHardwareCheck” for customers to verify that their tablet is compatible with the Wacom FEEL driver for Tablet PCs (link)
    * See CF77's discussion on "Wacom Enhanced Driver Penable Device" posts 218 (link), 294 (link) for a lot more info on wacom driver.

    Note on the display/touchscreen hardware
    A very radical way to make the touch-screen completely modern might be to replace it with another modern hardware which hopefully has the same dimensions and uses the same connectors. Perhaps, someone will figure this out and create a youtube video on how this can be done.
    • HYDIS HV121WX6-112 : This Korean company is now defunct as it got acquired by e-ink for patents and subsequently lost prominence.
    • It is a 12.1" display (diagonal)
    • the side lengths are 10.2" x 6.4" (276.8+-0.3 x 180+-0.2 x 6.6 mm)
    • WXGA 1280x800
    • 12V backlight power supply
    • 3.3V logic power supply
    • 1 channel mini-LVDS interface
    • glass+LCD assembly touchscreen with digitizer attached
    • aliexpress
    • pdf manual

    Upgrading BIOS (works) (at your own risk, a few have encountered a brick)
    Install ATK-WMIACPI_v1-0-0002. This driver is for communication and updating with the Bios
    install win64 winflash 2011/01/13 V2.31.1 WinFlash_2_31_1.zip
    winflash allows you to compare onchip and update-file versions with option to flash/exit.
    Select flash to upgrade to B121AS.603
    After the upgrade, winflash can be run again to read on-chip and confirm new version is successfully upgraded.
    winflash is not needed after the upgrade and it may be uninstalled.
    I took the risk and flashed the bios on windows-10. So yes it is possible to flash on windows-10. It is advised to update all drivers on windows-7, then install winflash, and only then upgrade to windows-10. Windows-7 is the OS of minimal risk. The operating system depends on asus-technology and wmi-acpi in a very fundamental way. Windows-7 state of drivers are final. For Windows-10 drivers are in flux, and no version is certain, there will be more variation/factors in the state of drivers after upgrading to windows-10, and a brick is possible if something does not go smoothly for winflash. If a brick does happen then the only way to flash it is to open the tablet up and have a professional do their thing.
    Bios: B121AS.603 (Official latest for B121) EP121AS.704 (Official latest for EP121)

    There are user-hacked modded versions of the same, where in some advanced users disable temperature CPU throttling (ProcHot). CPU's have a safe operating temperature range. ProcHot is a way by which the intel cpu lowers its clock speed in order to lower its heat dissipation when the CPU temperature exceeds a Manufacturer(intel) preset safe value, in order to lower the temperature and protect the cpu. Modded BIOSes are only for users who know what they are doing. CPUs often have a lenient tolerance meaning they can theoretically run a little hotter than they are allowed to do. The danger is that higher the temperature higher the chance one will court failure/CPU-burn-out. Disabling ProcHot means the user believes the CPU can handle the higher temperature, and disables the check to throttle. This allows high CPU applications and gaming to run more smoothly, but if your CPU accidentally burns-up one day you will have no choice but to go shopping for a new tablet. Modded BIOS are not necessary for regular home/tablet/office use, because most of the time the CPU cranks through in micro-bursts and is usually just waiting for the user to move mouse or type something. Even video playback and music are also not very CPU intensive and constantly consume only a small percentage of a full-cpu-load. For more info see the thread "[BIOS] EP121AS 501 [Modding thread]" link

    Wireless/Bluetooth (works)
    USB\VID_13D3&PID_3304\6&22F1F821&0&4 : Bluetooth Module
    PCI\VEN_168C&DEV_002B&SUBSYS_2C371A3B&REV_01\4&ECA0E71&0&00E1: Atheros AR9002WB-1NG Wireless Network Adapter

    device names:
    Qualcomm Atheros AR3011 Bluetooth 3.0
    Atheros AR9002WB-1NG Wireless Network Adapter

    latest working driver:
    bluetooth: 10.0.1.6 01/21/2016 (works)
    wireless: 10.0.0.340 5/3/2016 (works)

    first working driver:
    Bluetooth_Atheros_8.0.1.318_W81x64_A.zip
    The above file is made available for Acer for some models of their laptops.
    bluetooth 8.0.1.318, 02/21/2014
    wlan 10.0.0.285, 3/07/2014

    info on other/older versions:
    bluetooth: 6.17.624.302 6/24/2010 (this was before which was working without yellow sign)
    bluetooth: 8.0.1.244 7/31/2013 (found by win10, this has a yellow, sign but bluetooth works)
    bluetooth: 8.0.1.318 02/21/2014 (works)
    bluetooth: 10.0.1.4 9/21/2015 (works, gone through WHQL for win10)
    bluetooth: 10.0.1.6 01/21/2016 (works)
    wireless: 10.0.0.260 7/15/2013 (works)
    wireless: 10.0.0.263 2013-08-25 (not tried)
    wireless: 10.0.0.285 3/07/2014 (works, came simultaneously with Bluetooth 8.0.1.318, suspect but unconfirmed spurious wifi drop issue, see below for temporary fix)
    wireless: 10.0.0.308 12/11/2014 (not tried)
    wireless: 10.0.0.326 9/6/2015 (works, this has gone through WHQL for win10)
    wireless: 10.0.0.340
    5/3/2016 (works)
    Drivers around 2014, There is some spurious wifi drop issue speculated to be because of power saving wifi feature not being properly used by win10 (kb928152 link). After using the laptop for sometime the wifi changes to some limited connectivity state. the symptom is that the ip address on the ipv4 interface is has changed to the end-point ip-address 169.254.xx.xx. The interface ip address cannot be renewed manually or via the gui and it will complain the adaptor is in an invalid state. The temporary way to resolve this is to goto device manager, find network adaptor, atheros wireless, right click disable, right click enable, then make interface renew ip address in your preferred way (ex goto cmd and type "ipconfig /renew")

    Probably, Qualcomm also makes the driver bundles meaning that a qualcomm driver bundle of version 10.0.0.308 might actually contain driver specification for a whole lot of drivers for network adaptors from qualcomm both before and after the AR9002WB-1NG. Newer laptops come with newer hardware network adapters. It's not known if recent drivers are well tested for AR9002WB-1NG/win10 combination. I speculate the last known official driver tested for win7/8.1 might be 10.0.0.263 2013-08-25


    Microsoft lists the AR9002WB-1NG as compatible with windows-10 (link) in its compatibility center. You can find WHQL drivers by going to https://catalog.update.microsoft.com in the internet-explorer-browser(not other browsers, because it has to install some IE-browser component) and search for "ar9002wb-1ng" (without the quotes) and sort by last-updated
    Unofficial atheros drivers at atheros.cz categorizes the device under chipset-21 system-8 (link exercise caution while downloading).
    Unofficial atheros drivers at alldrivers.ucoz.net info is posted with 3rd party download links with post title "Qualcomm Atheros AR5xxx / 9xxxx Wireless Lan drivers" (link exercise caution while downloading)

    Intel Chipset Drivers (works)
    PCI\VEN_8086&DEV_3B09&SUBSYS_1F371043&REV_06\3&11583659&4&F8: Intel(R) HM55 Express Chipset LPC Interface Controller - 3B09
    Asus B121 system-board is based on Intel's HM55 express chipset.
    Microsoft windows-10 selects for HM55 Express Chipset LPC Interface Controller driver version 9.1.1.1022 10/28/2009. In device manager connection view, there is one "legacy device" listed under HM55 Express Chipset LPC Interface Controller, for which no driver is loaded. The HW-ID-device-path of the legacy-device is ACPI\INT0800\4&1C85B3C4&0 , bios name is LB.PCI0.LPCB.FWHD. The name suggests its the intel-82082 firmware hub device. it is responsible for interrupt based input. [??? speculation: could it be the hotkeys or is it normal for this device to show up as a legacy. It could also be the atk-wmiacpi firmware update mechanism ???]
    Intel provides a Intel driver update utility v2.2 07/28/2015(link) to auto-detect and update all chipset drivers, however it will not go beyond 9.1.1.1022 perhaps because that is the best known generic to intel/microsoft.
    The Latest driver-bundle from intel is 9.2.0.1030 and the Asus official chipset driver, which lists win7-64bit chip-set driver-bundle 9.2.0.1015, 2011/12/12, 9_2_0_015. Both of these bundles actually contain the file ibexcore.inf for Intel(R) HM55 Express Chipset LPC Interface Controller driver 9.1.1.1022 10/28/2009. This must mean that 9.2.0.xxxx is a bundle-version for a whole bundle of inf files that constitute the chipset.

    Intel HD Graphics (works)
    PCI\VEN_8086&DEV_0046&SUBSYS_1BE21043&REV_18\3&11583659&4&10: Intel(R) HD Graphics
    The processor 1.33Ghz dual core i5-470UM is based on westmere 1st generation core architecture. The GPU is a Intel 5th generation Intel graphics westmere-HD-graphics-ironlake(arrandale) which pushed on-board-graphics-media-acceleration into on-chip-HD-graphics. The ironlake, which came in 2010 was a short-lived technology that precedes the more capable HD-graphics-3000 that came with 2nd generation intel core sandybridge.
    Microsoft windows display driver model windows-7 drivers could be XDDM or WDDM-1.1. Windows-8 was WDDM-1.2, windows-8.1 WDDM-1.3, windows-10 WDDM-2.0
    The arrandale drivers from Intel are essentially WDDM-1.1
    Asus win7-64bit V8.15.10.2226, 2011/12/12, 8_15_10_2226_64
    8.15.10.[2555, 2559]
    8.15.10.[2827] is claimed(link) to work
    8.15.10.[2858, 2900] generic by Microsoft, has win8 support, OpenGL 2.1.0 link
    15.22.58.64.2993 (8.15.10.2993) Win7Vista_64_152258 Intel final generic link Intel will not be releasing a win10 driver as it considers the device as legacy device.
    Windows-10 finds and installs 8.15.10.2900 by default. No trouble.

    Intel graphics also has its own keyboard short-cut feature called intel-hotkeys. If enabled it runs in the background as hkcmd.exe Which is different from the asus hotkey service. Intel-hotkeys on Intel Graphics Manager is configured as follows
    • Right click on desktop
    • Click Graphics Properties, this will bring up the intel-graphics-manager
    • Select Advanced , next
    • In section-"Display", ensure rotate to "normal is selected"
      you can test "rotate to 90" and back to check if it is working
    • In section-"Support and Options". under subsection "hotkeys"
      Disable, and then re-enable hotkeys.
      check that ctrl-alt-up-arrow-key(normal) and ctrl-alt-right-arrow-key(90deg) which rotate the screen work.
    Realtek HD Audio (Works)
    HDAUDIO\FUNC_01&VEN_10EC&DEV_0269&SUBSYS_104384A2&REV_1001\4&21AB8FEA&0&0001: Realtek High Definition Audio
    realtek hd audio: V6.0.1.6704 08/14/2012
    info on older versions:
    realtek hd audio: V6.0.1.6220, 10/12/2010 (worked no issues)

    WebCam (works)
    USB\VID_13D3&PID_5205&MI_00\7&36253593&0&0000 : USB2.0 UVC 2M WebCam
    Loads standard Microsoft uvc-2 driver 10.0.10240.16384 6/21/2006

    Trusted Platform Module TPM (not used)
    ACPI\IFX0102\1 : Trusted Platform Module 1.2
    This is only for the B121 (EP121 does not have TPM)
    I don't use this but here-in note drivers
    win7 came with asus official version 1.0, TPM-AP.rar, 2011/08/05
    win8 support included asus official version 1.1, TPM_Utility_for_Win_8.rar, 2012/10/30
    Windows 10 seems to have found and installed device "Trusted Platform Module 1.2". The 1.2 in the device name refers to the tpm-security-standard.
    The TPM device manufacturer is Infineon

    The Home-button and the Volume-rocker-buttons (works)
    These work directly without need of drivers because bios identifies them as such and Windows-8/10 can directly interface with them

    Hardware OSK, Autorotation-Lock button and Asus G-sensor autorotate
    Hotkey/Gsensor eeeslateapp/devices/drivers/services (works)

    See Post 12 link for discussion on resolution of hotkey/g-sensor troubles

    There are 3 distinct downloads on the asus support site
    The drivers involved are:
    [1] win7 64bit atk wmiacpi driver 1.0.0002 2011/8/5 ATK-WMIACPI_v1-0-0002
    [2] win8 64bit hotkey service driver 2012/10/30 v1.0.0.5 EeeSlateUtil_atk0200_1_0_0_5
    [3] win8 64bit gsensor driver 2012/10/30 v1.0.0.2 EeeSlateUtil_atk0201_1_0_0_2
    The below are just older versions, they are not required, even though the precise wording of their names can be different
    [2b] win7 64bit hotkey service utility 1.0.0.2 2011/02/21 EeeSlateUtil_atk0200_1_0_0_2_110209
    [2c] win7 64bit hotkey service driver 1.0.0.3 2011/02/21 EeeSlateUtil_atk0200_1-0-0-3_110608
    [3b] win7 64bit gsensor driver 1.0.0.1 2011/08/05 EeeSlateUtil_atk0201_1-0-0-1
    devices involved maybe:
    : EEE slate ACPI utility 1.0.0.5
    : EEE slate ACPI utility (gsensor) 1.0.0.2
    : keyboard filter device
    : acpi fixed feature button
    : asus G sensor
    : sdo sensors v2
    processes/executables/services involved:
    : asusservice/asussender/hotkeysender/hotkeymon/hkcmd.exe/wudfhost

    One asks if Win7-64bit-asus atk-wmiacpi driver v1.0.0002 necessary for anything else other than bios upgrade, whether it be uninstalled after bios has been fully updated. I think its better to have it installed and leave it around as its specific need or non-need by the other drivers is not documented.

    The sequence of the installation of these drivers matter. Install the asus atk wmiacpi first, then hotkey-service then g-sensor. The trouble is that windows-10 automatically finds and update eeeslate acpi utility drivers automatically from its driver repository and the windows updates, not giving a chance for fresh installation by the Asus packges

    I am unsure if the keyboard-device-filter necessary. I recall seeing it before experimentation. so I found and installed it from elsewhere. There seemed to be two keyboard like devices. For some reason asus-eee-slate hotkey-service-driver did not install it

    Hardware buttons/Hotkeys (works)
    ACPI\ATK0200\2&DABA3FF&6 : EeeSlate ACPI Utility
    The following are necessary
    * atk-wmiacpi utility driver v1.0.0002 (install this first)
    * EeeSlateUtil_atk0200_1_0_0_5 201/06/11 Utility
    * EeeSlateUtil_atk0200_1_0_0_5 EEEapp Hotkey service v1.48
    Found and installed KBFilter_Win8_64_V1005 to bring back device "keyboard device filter" which had somehow disappeared (suggested by link).
    CF77 suggests in thread "EP121 home button not working" to check if padkeycontrol, hotkeyservice, hotkeymon are started on boot " link
    * make sure ASUS Launcher Service is turned on

    G-sensor (works)
    ACPI\ATK0201\2&DABA3FF&6 : EeeSlate ACPI Utility (GSensor)
    ROOT\SENSOR\0000 : ASUS G Sensor
    SWD\UMDF2\SDOV2 : Sdo Sensor V2
    The following are necessary
    * EeeSlateUtil_atk0201_1_0_0_2 2012/07/19 G-Sensor utility
    * EeeSlateUtil_atk0201_1_0_0_2 EEEapp Gsensor 1.0.2
    It is said that the Asus G-sensor device is not a true windows-8 compatible orientation device, and Asus perhaps uses its own proprietary way to read orientation.
    You will also need to enable Intel graphic manager shortcuts (link). I speculate that the mechanism used by eee-slate is that the Asus G-sensor device directly sends a shortcut hotkey to the Intel graphics driver to change the display orientation, windows will see it only as a screen resize, touch-screen and pen input will accordingly do a coordinate transformation, mouse pointer will be constrained by new screen size. This mechanism is the same as for table desktop swivelling LCD panels.
    On the other-hand, Windows-8 onwards, sensors (orientation and accelerometers) are a class of devices recognized by the windows-8 operating system, which in addition to the display rotation can also read or relay the sensor inputs to various applications, apps and other drivers. Hence, tilt-maze games that depend on windows standardized app/driver-to-os sensor-API-s may not work in EEE-Slate.
    not tested: It is said metro applications may not read the sensor readings even though the gsensor auto-rotation is functional.
    start-menu -> settings -> system -> display -> lock-rotation=off
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\AutoRotation
    regkey: enabled=1
    regkey: lastOrientation=0
    regkey: sensor present=1
    EEE Slate utility (G-sensor) 1.0.0.2 07/19/2012 EeeSlateUtil_atk0201_1_0_0_2
    Asus G sensor 6.1.7600.16385 10/12/2010
    sdo-version v2 10.0.10240.16384 6/21/2006

    Upon un-installing the Asus-G-Sensor, followed by sdo-sensor-v2 device in the device-manager, and then adding legacy device, sensor Asus-G-Sensor will automatically also add back the sdo-sensor-v2 device.

    Asus control deck
    Asus control deck is not needed. It is completely substituted by the toggle buttons in the "Windows 10 Action Center"
    * brightness, volume, flight-mode, wifi-enable, bluetooth-enable
    * All-settings-->system->display to control 2nd-display-device presentation mode.
    You might as well un-install it.

    Stop windows-10 form updating drivers
    It can happen that every once in a while windows-10 will download drivers and upset the fragile balance of the eeeslate windows-10-drivers.
    In order to prevent this from happening, once you get all the drivers working on your tablet working to your satisfaction, it's a good idea to prevent windows-10 from downloading and automatically updating driver updates (link).
    Control-Panel --> System --> Advanced-system-settings --> Hardware-tab --> Device-Installation-Settings --> No,let-me-choose-what-to-do --> never-install-driver-software-from-windows-update
    It's very unlikely that there will be any useful/new-feature driver-update for any of the legacy-hardware. There won't even be minor bug-fixes. Even security fixes are doubtful. Once one has a working system it is better to leave it that way. The only time one might want to investigate if driver updates is if something breaks, which would be because the OS is expecting the driver to confirm to some new interface or it is definitely known that a new feature is advertised to work.

    Post Upgrade Performance
    * In terms of app startup speed, feel and response no deterioration.
    * Battery life seems to be 2.5hr with normal use on wifi.
    * There seems to be intermittent cpu hog, the cause of which is uncertain but could be windows defender, spybot or immunet scanner, or windows downloading and applying updates in the background.

    Win-10 Upgrade log
    • 2015 Aug 1st : Windows 10 Initial Release 1507 (build 10240)
    • 2015 Nov 15th: Upgrade to Windows-10 1511 (build 10586) : smooth, no-issues
    • 2016 Jul 29th: Upgrade to Windows-10 1607 (build 14393) : smooth, no-issues
    • 2017 Apr 11th: Upgrade to Windows-10 1703 (build 15063) : smooth, no-issues

    EP121 B121 differences
    The hardware is nearly identical
    B121 has TPM module, EP121 does not
    B121 comes with Windows-7-vista-ultimate which has windows-services that facilitate server-functionality and enterprise-connectivity, like RDP, EP121 comes with Windows-7-Home-Premium. The specific differences can be read on the Microsoft site. Windows 7 Ultimate upgrades to windows 10 professional, windows 7 home premium upgrades to windows 10 home. Only windows 10 professional and enterprise have the ability to defer updates.
    EP121 comes in 2 variants RAM:SSD capacities being 2Gb:32Gb and 4Gb:64Gb
    The BIOS are different, and different firmware-files and versions need to downloaded from the Asus site.

    Benefit of an upgrade to Windows 10-Professional from Windows-7-Ultimate
    Is upgrade worth it? possibly yes for most
    • The problem G-Sensor automatic rotation and hotkeyservice for hardware osk/rotatelock buttons can be hard to fix and one might eventually choose to let it be, but their loss is cosmetic, and their absence can be easily substituted by using the win10 on-screen ui-element for OSK in the system tray and Manual rotation via intel-hotkeys or through system-display-settings
    • Like windows 8
      • The modern-interface-metro-apps work
      • Touch friendly UI.
      • Desktop-apps that use the conventional win7 multipointer api-s are touch ready.
      • Metro apps working nicely with one-finger touches.
        [ Metro-apps, Though Touch gestures are integrated into and apps, as of now multi-touch gestures not working] .
    • Better than windows-8
      • Metro apps no longer exclusive to tablet mode
      • Start menu brought back
      • Windows-10 takes far less disk-space than win-8, creating more room for your files. To begin with one needs 13Gb at-least in order for the upgrade to succeed, One will end up with 16Gb after removing all upgrade files and windows.old.
      • In windows 10 Cortana is the integrated search and voice assistant
      • multiple desktops
      • Microsoft-Edge-browser is a metro-app and is much faster than IE (if you prefer to use that browser over Firefox/chrome/IE)
      • One-login-account over multiple devices, and integrated one-drive
      • Action center, notification bar. (replacing unintuitive win8 charms bar)
    • Surprises
      • Windows media center(wmc)/player is deprecated in favor of preparing for online media players and media management. Download, install and use the popular VLC player if needed.
      • Windows no-longer has an integrated dvd/bluray-software-decoder, in case you use an external USB optical drive then a software dvd/bluray player may be necessary. (VLC can play bd/dvd)
      • The slide in tablet writing panel is not there, and in Control-Panel->Tablet PC Settings->Other no longer contains a section for the tablet-pc-input-panel-options. So instead of a slide-in writing panel, Windows-8/10 introduces a new handwriting interface integrated as a mode in the on-screen keyboard link
      • Windows 7 desktop gadgets functionality removed, thought it seems like the sort of feature that Microsoft may reintroduce it in some form in a later version of windows, because every other OS has some notion of a homescreen-widget.
    Ref:
    • Rogarc first said/confirmed (link) bluetooth 8.0.1.318 works
    • Jonathan Kong, post#10 (link) says that windows media center(wmc)/player is necessary for g-sensor to work unsure if really so. windows-10 does not come with wmc. This link says that wmc installs the "windows driver foundation service" that the g-sensor driver refers to. By default windows-10 comes with UMDF-2.15. The Windows-7-vista-ultimate latest update was UDMF-1.11, which is available on Microsoft downloads advertised for win7 and 2008-server link. So wmc is not required on windows-10.
    • Extensive information documented in tabletpcreview threads by
      • 20130207, Marty "Full Windows 8 Upgrade Guide" link
      • 20130627, Justin@NoProblemAtoll "Windows 8.1 Preview Experience with Ep121" link
      • 20120619, NePheus "[drivers] Windows 8" link
      • 20110913, visualj, "Windows 8" link
    • Intel may not provide a newer win-10 graphics driver for ironlake/arrandale because it is a legacy device link . reddit post link warns about lack of full win10 compatibility
    • The Driver subsystem for eee-slate is basically compliant only up-to windows-7 with a little accommodation for window-8 User-interface hooks in a few places. If Windows-8 and Windows-10 work it is only because they are backward compatible and using the driver-frameworks for windows-7.
    • Asus B121 specifications link

    Action Item : Goto asus.com support link, goto "customer service/email-us" and bug asus for your dollars worth by making a complaint, tell them they are doing a horrible service to asus-eee-slate-patrons with windows-10, remind them they were paid good money and ask them to provide driver information in order for windows-10 to work with windows-8.1 drivers and/or to release windows-10 drivers.

    EEE slate B121 64/4 Win10x64 bios->603AS
     
    Last edited: Aug 2, 2017
Loading...

Share This Page