Serious problem with TX2500 - system board drivers are not working!!And other devices!

Discussion in 'Hewlett Packard' started by nagy_peter, Aug 16, 2008.

Thread Status:
Not open for further replies.
  1. nagy_peter

    nagy_peter Pen Pal - Newbie

    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    Hi,

    I am not sure, if somebody noticed, but if you go to device manager and select the details of the system board, it will probably say:
    No drivers are installed for this device.
    The same is for the following:
    ATI SMBus
    Direct Memory Access Controller
    Motherboard resources,
    Numeric data processor,
    Programable interrupt controller,
    System speaker,
    System timer,

    All these thing altogether are cousing the Firefox to be slow, the graphic performance to be really slow. (everything under Windows XP of course)
    I am not an expert in hardware. I tried to find a proper drivers and everything, but no result. The motherboard is the M780G on TX2500, as I read it somewhere, so if somebody finds a proper driver, I will really appreciate that.

    Thanks a lot, I am almost bold from this laptop now.

    Peter
     
  2. DRTigerlilly

    DRTigerlilly Tablet Lead Mod (Retired) Super Moderator

    Messages:
    7,575
    Likes Received:
    742
    Trophy Points:
    301
    Did you follow forrestsun's/ agashka's thread, i find it unusual that you are the only tx2500 user that seems to be having these problems, did it have problems w/ vista?

    If it did you might want to consider having HP check the notebook out.
     
    Last edited by a moderator: May 18, 2015
  3. nagy_peter

    nagy_peter Pen Pal - Newbie

    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    15
    Hi, I did, but as I said, I do not have any unknown devices, except one, which was mentioned in this forum. the same issue has probably the following user:
    http://forum.tabletpcreview.com/showthread.php?t=19739
    I would like to just confirm with somebody, who has the same laptop, that they have the same status of the devices in the device manager. If no, I will try to install back the Vista..
    THanks,

    Peter
     
  4. darionco

    darionco Pen Pal - Newbie

    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    TX2524ca here and my results are:

    ATI SMBus - I don't even have this one instead I have Generic bus and it's reported to be working properly.
    Direct Memory Access Controller - No drivers are installed for this device.
    I have two Mother Board Resources, both say - No drivers are installed for this device.
    Numeric Data Processor - No drivers are installed for this device.
    Programmable Interrupt Controller - No drivers are installed for this device.
    System Speaker - I don't have this one
    System Timer - No drivers are installed for this device.

    This is weird but I know that's not the issue since the results I just posted are from the computer I'm using and thats not my TX2500 this is my Toshiba Satellite M100 I also checked on my desktop computer with the same results.

    I don't think this devices need drivers because they are controlled by the BIOS, not Windows. Windows is aware of the existence of such devices but doesn't control them directly.

    Interesting find though.

    darionco
     
Loading...
Similar Threads - Serious problem TX2500
  1. johnsmith_90
    Replies:
    0
    Views:
    1,090
  2. kruzilla
    Replies:
    5
    Views:
    2,157
Thread Status:
Not open for further replies.

Share This Page