1. You may have noticed that TabletPCReview looks a little different. That's because we've moved to a new, streamlined platform, XenForo. Have yourself a look around and engage with your peers. Tips for completing basic tasks are here. Should you encounter any bugs or issues, please post them in this thread, so that we can prioritize and fix them. And feel free to let us know your opinions of the new site.

Scramble cursor in portrait mode (with solution)

Discussion in 'Microsoft Windows 7' started by s3n4te, Aug 7, 2009.

  1. s3n4te

    s3n4te Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    6
    I've been using Windows 7 since build 6801 on my Lenovo x61 Tablet, and I have filed multiple bug reports on this problem since then:

    1. Switch to portrait mode
    2. Open Journal
    3. Do some doodling
    4. Change cursor pen size to Marker (2mm)
    5. Do some doodling
    6. Change cursor size back to smaller size such as "fine chisel"
    7. Cursor is scramble with a mix of the larger marker dot and the fine chisel dot.

    Now I'm using the RTM build from MSDNAA and this still happens (32bit and 64bit)!!! I have tried updating video drivers, and wacom drivers, but none of that fixes it.

    I wonder if this only happens on the x61t or other tablets as well. Can those with Windows 7 installed report back please?

    Searching on the internet I found people with similiar problems:
    http://forums.lenovo.com/lnv/board/message?board.id=Beta_OS&thread.id=1623
    http://www.neowin.net/forum/index.php?showtopic=778412&st=0
    http://www.gottabemobile.com/forum/forum_posts.asp?TID=7348
    http://www.gottabemobile.com/forum/forum_posts.asp?TID=6191

    If this is happening to all tablet pcs then Microsoft must fix this ASAP!

    edit: This does not happen in landscape mode.
  2. primexx

    primexx Scribbler - Standard Member

    Messages:
    197
    Likes Received:
    0
    Trophy Points:
    30
    It actually happens in every orientation except the default one. Problem existed since the Beta, I reported it at least twice. Obviously not important enough to be fixed by RTM. Nothing much we can do aside from waiting for a patch that may or may not come.
  3. TabbedOut

    TabbedOut Scribbler - Standard Member

    Messages:
    1,369
    Likes Received:
    0
    Trophy Points:
    56
    Since I don't use journal I hadn't noticed it, but I can confirm that it happens on my tablet as well.
  4. s3n4te

    s3n4te Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    6
    Is anyone else getting this problem?
  5. Frank

    Frank Scribbler - Standard Member

    Messages:
    3,848
    Likes Received:
    0
    Trophy Points:
    66
    I have the same problem.
    First, I thought it was a problem with InkFlash Cards, which wasn't 'designed' for Win 7 x64. But then I tried Windows Journal and there it was even worse.
    I also tried Bluebeam PDF Revu, same effect.

    Because all of you experience the same problem I also know that it's not the Wacom driver I've installed.

    It's pretty annoying.

    The problem does only occur in portrait mode. In primary and secondary landscape mode this issue does not occur:

    [​IMG][​IMG][​IMG]
    Feel free to use those images.

    I'm happy that you spread this issue around the web. Keep it on.
  6. angilinmago

    angilinmago Pen Pal - Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I just installed the windows 7 RTM on my x200 tablet, and got the exactly the same problem. I have been searching the web for hours to see if anyone else has the same problem, so frustrating.

    double/retaining cursors happens to windows journal, Bluebeam PDF Revu, and photoshop CS4. Strangely, onenote is spared.

    I also have the latest wacom driver 5.05 (intended for vista) installed on my x200t. Don't know if that's the cause. Can anyone clarify?
  7. Frank

    Frank Scribbler - Standard Member

    Messages:
    3,848
    Likes Received:
    0
    Trophy Points:
    66
    I also posted a thread at Technet, sadly no one responded so far.

    in my opinion PS CS4 is worst, because there the pen doesn't even switch back to normal after I quit Photoshop and there it has the most distracting 'ghost' cursor.
    In Bluebeam PDF Revu you can turn this issue off by changing the pen cursor in the setting to 'Default' or 'None'
    OneNote, yes, you're right, no problems, maybe it does not use the default pen cursor for the tablet but a proprietary icon.

    And no, the Wacom drivers don't have anything to do with this, because the thread starter, s3n4te, tried it with both Wacom and standard drivers.
  8. jhoff80

    jhoff80 Scribbler - Standard Member Senior Member

    Messages:
    2,308
    Likes Received:
    325
    Trophy Points:
    101
    Not having the issue on my Dell XT or my HP tc1100.
  9. angilinmago

    angilinmago Pen Pal - Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    can you tell us which version of windows 7 you are using and whether you have installed wacom driver? Thanks
  10. jhoff80

    jhoff80 Scribbler - Standard Member Senior Member

    Messages:
    2,308
    Likes Received:
    325
    Trophy Points:
    101
    Final RTM build of Windows 7 from Technet. Obviously did not install the Wacom driver on the Dell XT. On the HP, Windows Update installed a newer Wacom driver, but that's it.
  11. Dev1ant

    Dev1ant Pen Pal - Newbie

    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    I also experience this problem. Windows 7 Ultimate x86 RTM from Technet. It's annoying as it can get confusing sometimes.
  12. Az2002

    Az2002 Pen Pal - Newbie

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    Hello!

    After long time with the slowest ever machine - original Vista ultimate factory installed with my x61t CTO, and must say not much problems but really slow actions and behave! I finally installed the RTM 32bit great and fast win 7.

    After the first windows update I got all my drivers working great and the only one I had to install was the Intel turbo mem. from Intel's website. win 7 driver was there for me.

    Right after the installation I installed my main working propose : OneNote 2007 and got updated automatic to office 2007 sp2.
    Since I always used sp1 in office on my vista I thought our cursors problem is the sp2! Well, no. after uninstalling I found out it wasn't fixed, so I tried new drivers for the Intel graphics card, saw no changes neither.

    Now I can see that I'm not alone but I didn't try the wacom drivers. I'm also thinking about all the Lenovo stuff I installed such as Active Protection, On screen OSD and some others...

    Another small but annoying issue I noticed is some "pauses" in windows explorer while working on a program either if its onenote or even firefox/iexplorer windows task bar and the input panel are not responding... Only after pressing ctrl+alt+del and then "cancel" or "esc" I can work again normally....
    I'm not sure if that also happens in portrait mode only but I removed the Active Protection from Lenovo in order to check if that's the thinking...

    Anyway, I'd love to hear more and update myself if I have any news.

    AZ.
  13. Az2002

    Az2002 Pen Pal - Newbie

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    Another thought... if this won't happen to the dell / hp ones, what is the graphics card Installed there ? also 965 Express like in our X61T ?
    Right now I'm thinking its the graphics driver since they might use another graphics card, we might need to post on Intel's website...
    Tried 2 versions : Original windows update driver & Intel's driver....
    Both gave the same issue so still searching....
  14. DMichael

    DMichael Pen Pal - Newbie

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    5
    I am having the same problem, ever since I upgraded to Windows 7. I have a Dell XT2 and use my tablet in Word 2003, in OneNote 2003 and Equation Writer and whatever cursor I was using before I start inking doesn't go away. The little arrow will be there or the eraser, etc. I am a graduate student and take a large amount of notes with my tablet and its really a pain with the cursor in the way. I might have to go back to Vista because of this. :( Anyone knows a solution please let me know!!!!!!!
  15. TSR

    TSR Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hello,

    I had the same problem with my X61T since I moved to W7. Using Windows Journal on portrait mode became a real pain and lost all its value (and if you look closer, on every window there's also a small "sub cursor" next to the arrow when pointing the menu bar).

    Anyway, I just found a tip (not a solution) to decrease the annoyance generated by this sub cursor. I use French version of windows so, I will do try my best to translate menus.

    On desktop>right click>customize>modify mouse pointers

    tab pointer settings>show mouse trace

    Configure the length of the trace according to your needs, I personally set it to the shortest setting.

    Return on Windows Journal and enjoy.

    :)

    TSR
  16. stevem64

    stevem64 Pen Pal - Newbie

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    5
    Holy Cow! I think you found the solution!

    The menu choice is a bit different for users in the U.S.
    Let me try to go through this:

    Go to Control Panel
    Find "Mouse Properties"
    Go to "Pointer Options"
    Put a check mark in the "Display Pointer trails"
    Slide the bar over to "short"
    Apply the changes and then restart journal.

    This problem seems to have solved. I am a heavy Journal user and this has driven me CRAZY!!!

    Thank you! Thank you! Thank you!
  17. Az2002

    Az2002 Pen Pal - Newbie

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    5
    What a nice trick to get over this issue :)))

    Thanks a lot for the solution !!

    AZ
  18. MBFin

    MBFin Pen Pal - Newbie

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    5
    This is fantastic. Thanks!
  19. johnsoex

    johnsoex Pen Pal - Newbie

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    5
    I love this forum. This issue was sooooooooooooooo annoying.
    I tried loading fresh intel drivers and wacom drivers, even different programs for note taking all to no avail. A little searching on this forum and vuala! Thanks everyone!!!
  20. David.Schmidt

    David.Schmidt Math and my Tablet

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Great job, yes, same scrambled cursor error with digital pen mouse-over in portrait mode. I find the bug distracting while trying to do my math with the cursur of a hand, eraser, etc. --> my environment --> Running Windows 7, 64-bit (6.1.7600) on X200. I had read on another blog that the Wacom driver was the fix. I installed 7wgf07ww w/o success. Wonderful work with your creative fix, proud to be a member of the Tablet PC Review, you guys rock!
Similar Threads: Scramble cursor
Forum Title Date
Microsoft Windows 7 cursor bug Jun 20, 2010

Share This Page