Samsung Galaxy Book 2 (2018)

Discussion in 'Samsung' started by Cuberdon75, Aug 10, 2018.

  1. JoeS

    JoeS I'm all ears Senior Member

    Messages:
    5,786
    Likes Received:
    4,121
    Trophy Points:
    331
    Posting this random observation so Google can find it.. Probably relevant to the Surface Pro X and other Windows on Arm / WOA devices.

    I was suddenly having trouble running CCleaner on my Samsung Galaxy Book 2. The exe would show in Task manager but not show any UI. Sometimes running it would not even result in a visible task.

    Solution: it's possible to modify the x86 emulation settings, and setting it to "safe emulation" fixed the problem. Not sure why this issue suddenly cropped up, seems likely that it was a Win10 update that did it.

    To get to these settings, locate the executable (ccleaner.exe), right click it, select properties, select compatibility, select Change emulation settings, and then switch from Default to "Safe emulation". There's also "Strict execution" and "very strict execution", not sure how those would impact performance. More technical info here.

    upload_2021-1-23_16-11-55.png
     
  2. JoeS

    JoeS I'm all ears Senior Member

    Messages:
    5,786
    Likes Received:
    4,121
    Trophy Points:
    331
    Random note / PSA: I had to tighten the Philips head screws that connects the hinge to the kickstand. Had I waited a bit longer they might have fallen out and gotten lost. So: if the kickstands feels more wobbly than usual, check the screws.

    Other than that, the Book 2 is still alive and kicking.
     
  3. dstrauss

    dstrauss Comic Relief Senior Member

    Messages:
    11,223
    Likes Received:
    9,823
    Trophy Points:
    331
    Are you saying you have a loose screw? o_O:p:D
     
  4. JoeS

    JoeS I'm all ears Senior Member

    Messages:
    5,786
    Likes Received:
    4,121
    Trophy Points:
    331
    It's the least of my problems.
     
    desertlap likes this.
  5. desertlap

    desertlap Pen Pro - Senior Member Senior Member

    Messages:
    3,111
    Likes Received:
    3,987
    Trophy Points:
    231
    @JoeS FWIW our lab unit has the same issue. It has gotten annoying enough that we used a tiny bit of loctite the last time we tightened them.
     
    Last edited: Mar 30, 2021
    JoeS likes this.
Loading...

Share This Page