Re install your bios in damageed Acer Iconia Tab W500 W501

Discussion in 'Acer (Gateway)' started by isenhart, Jul 14, 2013.

  1. isenhart

    isenhart Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    After a bios upgrade my Acer W501 Iconia tab was bricked. Black screen and no working.
    I have fix the problem

    1)Download Acer Bios Driver for W500 from support acer website, unzip and open the DOS folder. rename the file .fd into EAB00x64.fd
    2)Create a USB bootable with DOS (I have used a software named RUFUS)
    3) Copy the three file present in the dos folder into the usb key
    4) Insert usb in your tablet. Put the power supply, lock the rotation and press together WIN BOTTON / VOL DOWN/ POWER ON for 5/10 sec and release.
    5) the tablet remain in black screen for 10 mins then automatically restart and all is fixed.
     
  2. LinYuta

    LinYuta Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Dear isenhart, I need your help

    I got the same trouble in my W500 after bios upgrade.
    however, black screen keeps on although I follow you step by step.

    1)Download Acer Bios Driver for W500 from support acer website,
    ^^^^^^^^^^^^^ vision 1.05? 1.08? 1.10? 1.13? or 1.14?

    I's sure my USB boot is OK (I try it in other computer)
    But after I restart my W500 with WIN BOTTON / VOL DOWN/ POWER, i wait and wait and wait..5min. 10min.. 15min. The screen is still black
     
  3. isenhart

    isenhart Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Try do download an old version of bios from internet ( u can find easily) and try.
    If u write to me at nglgnn@gmail.com i can send to you my bios version.
     
  4. LinYuta

    LinYuta Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Dear isenhart

    I tried the 4gb bootable USB and the old version of bios.
    But it failed. So sad.


    It's my story:

    Initially, I installed "windows 8" vie USB successfully.
    Win 8 worked well & perfectly till I upgraded bios (vision 1.05) from acer website.
    The upgrade process in that time was smooth; it finished and restarted the WIN automatically.
    Then, tragedy happened.

    The screen is black.
    However, the windows 8 systems seems to work as usual.
    -> I could hear the alert sound of Win 8, when I insert or remove a USB.
    -> I could use the W500 keyboard to shut down the windows system
    of course, the screen is black in the whole course.

    I wonder that the failure to bootable with EAB00x64.FD is also caused by "Hybrid Boot" (or other BOOT setting) in windows 8???? It leads error of screen driver??


    What OS is your W500?

    ps. I tried to use W500 HDMI to 2nd screen.
    I use "Fn + Win + F5" after I "enter the windows system" in black screen, but the 2nd one is black, too.
     
  5. LinYuta

    LinYuta Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    ==
    It's my story:

    Initially, I installed "windows 8" vie USB successfully.
    Win 8 worked well & perfectly till I upgraded bios (vision 1.05) from acer website.
    The upgrade process in that time was smooth; it finished and restarted the WIN automatically.
    Then, tragedy happened.

    The screen is black.
    However, the windows 8 systems seems to work as usual.
    -> I could hear the alert sound of Win 8, when I insert or remove a USB.
    -> I could use the W500 keyboard to shut down the windows system
    of course, the screen is black in the whole course.
    ==

    Dear all
    I fixed it!!!

    1. download "BIOS Acer Updates EC version in BIOS" (vision:1.14) from acer website
    2. copy the "WT1V114.exe" from "windows folder" to USB
    3. press power on, and wait about 20 seconds for entering windows 8 system
    (the screen is black)
    insert your USB, then you would hear the alert sound
    4. (the screen is black)
    press "Tab key" for 6 times
    press "Down Arrow key" for 1 time
    press "Enter key" for 1 time
    then you would hear another alert sound
    it means that you start the file "WT1V114.exe"
    5. (the screen is black)
    press "left Arrow key" for 1 time
    press "Enter key" to confirm/allow the file to change your W500
    6. wait for about 5~10 minutes, the computer shut down itself
    7. press power on, then your W500 reborn
     
  6. henryjose

    henryjose Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    hello,

    Thanks for the help it works for me just downloaded the 1.14 version and just followed your instruction, thanks

     
  7. williamcas

    williamcas Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    What a GREAT info ... i recovered my recently damaged W500 , with this ... thanks a lot ...
     
  8. don hyphen

    don hyphen Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    Hello I have the same problem however it arose, during Start up of UBUNTU 13, right after the screen switches at start up to high res it power down, and the screen never came back on after that. Unlike the inital post, I had windows 8.1 and Ubuntu, dual boot through Grub2, the windows 8.1 does not load.

    Right after I I press power, USB flash drive lights for a second than no activity. Black screen I traid updating the bios from both the SSD and a USB flash, to no avail.
    Nor is there any beep sound on start up or when I press a key on the Key Board.

    If I leave the tablet sitting, the processor will heat, showing some internal malfunction,

    Any advice would be welcomed ;']
     
  9. KonradPL

    KonradPL Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Do You have any solutions?? I.ve got the same problem...
     
  10. ThanksABillion

    ThanksABillion Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Thanks a billion man. I used your fix for W500P and worked. Acer support was useless and asked me to send the tablet back for RMA. It sucks that they would post BIOS upgrade files without clear instructions and let the users brick their tablets! Anyway, thanks isenhart! You made my day!!!
     
Loading...

Share This Page