Processor speed

Discussion in 'Asus' started by woutervegter, Jan 14, 2007.

  1. woutervegter

    woutervegter Pen Pal - Newbie

    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    16
    When i click on my computer info, i get the following screen, see attachment

    my cpu runs at 997 mhz? But i have a t7200 which should run at 2.0 ghz.
    also NHC says my cpu is 1.0 ghz

    Can someone tell me what's going on?
     

    Attached Files:

  2. SimsHsia

    SimsHsia "I will do science to it" Senior Member

    Messages:
    3,293
    Likes Received:
    1
    Trophy Points:
    66
    Hi woutervegter,

    That's the Enhanced Intel SpeedStep at work (EIST). :)
    To preserve battery life, usually the CPU "steps" down or clocks down the speed of the processor to about half of the total clock speed (other wise known to computer engineers or others as "CPU states" or "p-states"), sometimes it's less, sometimes it's exactly at 1GHz. One of my family member's company laptop has a Intel Core Duo at 2.0 GHz and it reports at 999 MHz, other times at 1 GHz - even when on AC power.

    If you run an application which is processor intensive, and you revisit both NHC and the System Properties, you will see that the number will rise to 2.0 GHz or approaching it.

    If you wish to turn this feature off, go to Control Panel, Power Options, Power Schemes tab, select the "Always On" power scheme and the feature is disabled. To turn it back on, set it to "Minimal Power Management" or "Maximum Battery". There could be a driver which controls this, I'm not sure, as I haven't checked out this feature on that system one of my family member's has.

    I know that with Asus there's a Power Management application, try experimenting with that to see if EIST is disabled with the different power schemes listed there.
     
  3. woutervegter

    woutervegter Pen Pal - Newbie

    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    16
    thank you:)
     
  4. kudoskun

    kudoskun Scribbler - Standard Member

    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    31
    Ive had a gateway 1.6GHz step down to ~50mhz. At least thats what the sysinfo told me.

    While my R1F T5500 can bottom out @ ~ 300, 700, or 900 depending on its fancy.
     
  5. ignacykrasicki

    ignacykrasicki Pen Pal - Newbie

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    5
    Hi!

    I've just installed NHC to check my battery wear level, but i found out that processor clock is 998 constantly (profiles don't change it, ie. Battery saving or super performance). Even when runnig processor intensive application.

    Super Pi used to calculate 2m digits in 1min 02sec . Now it needs 2min in Super Performance. Turning Power Gear off and setting max performance doesn't change anything.

    Can anyone check Super Pi 2M digits and processor clock?

    Funny thing is my battery wear level: 44% :)
     
  6. Grinner

    Grinner Pen Pal - Newbie

    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    15
    I have exactly the Same problem under Vista.
    XP seems to do the speed- stepping just fine, but Vista occasionally gets stuck at 900 Mhz. Not sure why.
    The issue seems to be random though, since right now it works at 2GHz.Not sure what to do either, but what seems to help more often than not is to go into standby or hibernation and when you come out again, the CPU seems to have the correct clock.
    No Guarantees though :)
     

Share This Page