Photoshop toolbar

Discussion in 'Artists' started by lblb, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. dream3

    dream3 Scribbler - Standard Member

    Messages:
    320
    Likes Received:
    14
    Trophy Points:
    31
    Hey lblb,

    I really don't see another way to make the update process easier. But ti seems alright if people just make a copy of their Image folder. Download new updated and paste it over. As long as the settings and the images' names don't change think it'll be fine.

    The DPI scale thing worked. It was that line messing things up!

    About the New Layers and Undo, it's actually "ALT" the true culprit. If you hold ALT then CTRL then Z, it will ring on you, if you switch and hold CTRL first, then it's alright. Same thing for layers, if ALT is the first button pressed. And I tried changing the order at the .ini file, didn't help. I guess the commands are being sent too quickly to make any difference. Maybe something like "CTRL + delay + ALT + Z". Same for layers, "CTRL + SHIFT + delay + ALT + N".

    It does make sense what you said about the position of the "quit" option. Logically it does. Actually all the developers should've thought like that in the past! For me it seems awkward but just because I'm pretty used to doing the other way around. Muscle memory kind of thing.

    CHEERS!
     
  2. dream3

    dream3 Scribbler - Standard Member

    Messages:
    320
    Likes Received:
    14
    Trophy Points:
    31
    Sup lblb!!!!

    Hows it going?

    Any sweet news regarding those past reported issues?

    cyaa
     
  3. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,197
    Likes Received:
    240
    Trophy Points:
    81
    Hi dream3,

    I've been mostly working on a big update for Toolbar Creator.

    For the previous issues that you mentioned, is the only one remaining the Alt thing? I don't get any sound when I try what you mention so it's difficult for me to test. Do you want to test something:

    - Create a new AHK script and replace the text with the following:

    Code:
    
    F8::
    Send, {Ctrl down}{Alt down}z{Ctrl up}{Alt up}
    Return
    
    F9::
    Send, {Ctrl down}
    Sleep, 30
    Send !z{Ctrl up}
    Return
    
    
    - Save the file then launch it by double-clicking on it.
    - If you press F8 or F9 while in Photoshop, do you still ear the sounds?
     
  4. dream3

    dream3 Scribbler - Standard Member

    Messages:
    320
    Likes Received:
    14
    Trophy Points:
    31
    Hey lblb!

    I've narrowed it down actually:

    Just hold ALT then hit N, or ALT then Z on your keyboard. You will definitely hear the bam sound. That's why when ALT is held first, it has to be followed by another modifier before the N or Z keys. Even though the order at the script is not ALT first, I think it sends the commands faster than photoshop can handle.

    With your little F8 and F9 scriptie it worked alright! No sounds at all.

    -
    Besides that, the only thing I see left to perfection highlighting icons also when right clicking, even if it shows after the click is done. To remedy that a bit, add a sticky delay to all highlighted icons, be them right or single clicks. The delay could be user-defined, or hardcoded, whichever is easier for you.

    edit: If you think adding that delay for every single icon is too much, maybe you could tell me just how to enable/add the activated version of the icons to the rightclick functions so I can test it out.

    best regards!!
     
    Last edited: Jul 21, 2014
  5. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,197
    Likes Received:
    240
    Trophy Points:
    81
    Hi dream3,

    I'll see what I can do about the right-click highlights, thanks for the suggestion.

    For your alt issues: It's cool that both codes solve your problem. The first one will be easier for you to implement. Open the ini file for your toolbar (in the Files\Toolbars\ subfolder) in a text editor. After the general settings at the top you will see that each button has its own multiple settings. The three buttons at the top of the toolbar are buttons 30-32, the buttons in the first column are 1-10 and in the second 11-20. To assign the first code to a button, go to the section for that button number (let's say the number is 20).

    If this is a right-click command, then adjust the right-click hotkey like this

    Button20_RT_Hotkey = {Ctrl down}{Alt down}z{Ctrl up}{Alt up}

    If this is not for a right-click, then adjust the hotkey for the correct button type. For example, if the button is of type 1 (i.e. it just sends a hotkey), then adjust the following key:

    Button20_Type1 = {Ctrl down}{Alt down}z{Ctrl up}{Alt up}

    Save the ini file, then relaunch the toolbar.

    Does that work?
     
  6. dream3

    dream3 Scribbler - Standard Member

    Messages:
    320
    Likes Received:
    14
    Trophy Points:
    31
    Alright lblb, looking forward to that!

    As for the alt issues, they are gone! Finally.

    Should I worry about the Type1_Long line or leave it as is? And do you think you can make it so the toolbar creates shortcuts with "alt" that way, or every time I create a new shortcut with "alt" I'll have to manually edit it?

    Cheers!
     
  7. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,197
    Likes Received:
    240
    Trophy Points:
    81
    Hey dream3,

    That's good news about your Alt issues. Since I can't reproduce these issues (maybe it's an issue with a software/driver on your computer?) and since no one else has reported it, the best solution will probably be for you to just manually adjust the code whenever Alt is involved. Just report back here if you encounter any issues.

    Whether it's for a type 1-6 button, or for a right-click action, as you mention you can see that there is always a TypeX_Long key. This is just the text that will show up in the editbox in the Options (i.e. the editbox where you would usually punch in the hotkey when customizing a button). So the value of Type_Long is just an easier-to-understand reflection of what the actual hotkey is. For your button, you could leave it as is (knowing that what you will see in the editbox for this button will be wrong) or just write something like Ctrl + Alt + z for Type_Long (and then you'll see this exact text in the editbox in the options).
     
Loading...
Similar Threads - Photoshop toolbar
  1. YVerloc
    Replies:
    3
    Views:
    1,219
  2. desertlap
    Replies:
    2
    Views:
    1,185
Thread Status:
Not open for further replies.

Share This Page