Photoshop toolbar

Discussion in 'Artists' started by lblb, Feb 3, 2012.

Thread Status:
Not open for further replies.
  1. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,196
    Likes Received:
    239
    Trophy Points:
    81
    Hmmm... Ok, I understand what you mean, but whatever I try, and wherever the menu appears, I get to Blend Mode by pressing Down 7 times on my keyboard...
    Let me try something...
     
  2. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,196
    Likes Received:
    239
    Trophy Points:
    81
    Let's see if the problem is that the menu is appearing slower on your computer. Let's introduce some delays and just see if the expected seuqence is observed.

    In the file that you just replaced, change lines 165-169 which now say

    Click, 128, %YMultiply%
    Send {Down 7}
    Send {Right}
    Send {Down 7}
    Send {Enter}

    To this:

    Click, 128, %YMultiply%
    Sleep 500
    Send {Down 7}
    Sleep 500
    Send {Right}
    Sleep 500
    Send {Down 7}
    Sleep 500
    Send {Enter}

    Save the script, then recreate the hover icon. This should now wait 0.5s after each step. Is this any better? Do you see the expected sequence of menus?
     
  3. Steve B

    Steve B Moderator Moderator

    Messages:
    3,370
    Likes Received:
    556
    Trophy Points:
    181
    Yeah, I see your point. I tried it with the down key and it works like you say. Hope you come up with something "out of the box".

    BTW, I'm sure you've noticed, but just in case- definitely the SIDEM is not attached the to movement of the Layers Pod when opened. Essentially, if I move pod, they stay just where they were and only migrate back to their place on the Pod layout when I'm done moving it. I don't remember them doing that before. Just fyi.
     
  4. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,196
    Likes Received:
    239
    Trophy Points:
    81
    Yeah the buttons don't automatically move with the window. It was actually like that before and I don't think I can do anything about it (it just seems like AHK doesn't recognize the windows when they are being dragged). I'll see.

    BTW, I posted a test two posts up.
     
  5. Steve B

    Steve B Moderator Moderator

    Messages:
    3,370
    Likes Received:
    556
    Trophy Points:
    181
    Ok, that allowed everything to go slower.... but didn't fix the problem.

    However, it did allow me to see the issue. AHK is starting with Edit Layer Texture when I press the M button. That part is clear. If you count 7 down you reach the Merge All Layers. Perhaps it is somehow starting the 7 count from where the "E" button left us?
     
  6. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,196
    Likes Received:
    239
    Trophy Points:
    81
    Does it work if you use a mouse (I'm thinking maybe it's the Wacom drivers that are getting in the way again)?
     
  7. Steve B

    Steve B Moderator Moderator

    Messages:
    3,370
    Likes Received:
    556
    Trophy Points:
    181
    Nope. Unfortunately, I get the same response with the trackpad. It's clearly choosing the Edit Layer Texture as its point of entry to the menu, pen or no pen. :(
     
  8. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,196
    Likes Received:
    239
    Trophy Points:
    81
    Could it be that the first Down is lost. What if you change the first Send {Down 7} to Send {Down 8}?

    Alternatively:
    Let's try it stupid: this should work then (that is, if it reliably always starts at Edit Layer).

    Click, 128, %YMultiply%
    Send {Down}
    Send {Right}
    Send {Down 7}
    Send {Enter}
     
  9. Steve B

    Steve B Moderator Moderator

    Messages:
    3,370
    Likes Received:
    556
    Trophy Points:
    181
    OK, that new bit of code at the bottom of your last post opens up the Blend Modes but doesn't press any buttons in the flyout menu. I wonder if that's a fine option. My sneaky mind says "Boy, wouldn't it be cool if I could choose which blend mode I wanted to go there, with a menu?" LOL. In the short term, either 1) hitting Multiply is cool is with me or 2) just having it very quickly get me to that menu is cool. Don't know where you want to go from there.
     
  10. lblb

    lblb Scribbler - Standard Member Senior Member

    Messages:
    1,196
    Likes Received:
    239
    Trophy Points:
    81
    Well, whatever works for you. You could have many buttons... One to open Blend Mode... or one to go directly for multiply... or one for "Add New Layer then set to Multiply)"...

    Just to be sure:
    Are you saying that

    Click, 128, %YMultiply%
    Send {Down 8}
    Send {Right}
    Send {Down 7}
    Send {Enter}

    Does open Blend Mode but it doesn't select "Multiply". Could it be that it's actually selecting Darken and not Multiply (so we would need to adjust the second one to Send {Down 8} as well to select Multiply?
     
Thread Status:
Not open for further replies.

Share This Page