oversampling pen hack :: wac_tch :: not working

Discussion in 'Asus (Android)' started by atilla, Dec 10, 2011.

Thread Status:
Not open for further replies.
  1. atilla

    atilla Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hi,

    First time posting after many months reading, downloading and learning from this site and freenote. Many thanks, all the generously shared experience on here convinced me to get the eeenote in the first place and since then the info has been amazing. Thank you.


    PROBLEM
    [1] When I use consoleq and execute "./ wac_tch --1" from root I get the response of "Permission denied". Same thing if I set sample rate to 2 or 3. Can anyone understand why that's happening and how to get round it please?


    BACKGROUND
    a - I loved Blacknight's tip to hack the pen sampling rate http://forum.tabletpcreview.com/asus-eee-line/43517-what-pen-you-using-ea800-4.html#post252867
    b - Used it for a while with the qconsole command method.
    c - When I tried to change the profile I must have made an error 'cos I bricked the tablet - completely, horrifyingly.
    d - Tried the debricker and the enoteimg.exe, my gratitude to Pbarrette but no joy.
    e - Resorted to taking a deep breath and opening the tablet, thanks to Mcznarf. Rescued the device using the russian rom (my unit was shipped with the TW rom, I don't know if that change makes a difference).
    f - Updated the firmware using the desktop sync. Now using bootloader v1.0.4 and software v1.0.16.139.
    g - Loaded up fullinstall and qtpacker (so pretty much back to where I was when the pensampling hack worked), tried the hack - permission denied.


    ANOTHER WAY OF LOOKING AT IT
    [2] Is there any chance that someone could post up a dvt file which makes the profile change please? I'm really not keen to mess with the profile again myself because I rely on the eeenote at work and even one day lost is a real pain.
    (btw, what is dvt??)

    Thanks in advance.
     
  2. BlacKnight

    BlacKnight Scribbler - Standard Member

    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    31
    Hi atilla,

    I'm sorry to hear that you had problems using the oversampling hack.

    [1] You have written a space between ./ and wac_tch. There should be no space.

    [c] The script engine on the Eee Note seems to be really sensitive to EOL characters, character encoding, and white space. If you get any of these wrong the engine will halt while processing your script. This can make the Eee Note hang at boot time. IMO the simplest solution is to open the Eee Note, take the internal SD card out, and edit the broken script on a Linux PC. If you edit scripts on a Windows PC then you have to be even more careful about EOL and encoding.

    For example, if you typed "/" [space] "wac_tch --1" in your profile script then that would cause the script to hang at boot time. I usually start by copying and pasting an existing code block from inside the script, so that I get the syntax exactly right, then change the file names, etc.

    Note: IMO it's a good idea to put any additions to the profile script after it runs dvt_check, near the end of the script. Otherwise, you won't be able to use dvt_check to fix it if the script hangs at boot time.
     
Thread Status:
Not open for further replies.

Share This Page