One Solution to Enable/Disable Touch with VivoTab

Discussion in 'Asus' started by curtissh, Dec 8, 2012.

  1. curtissh

    curtissh Scribbler - Standard Member

    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    31
    So, building on this guy's work, click the link below to download a .zip for the Asus VivoTab (not RT) TF810C. If you unzip the contents into a folder you create called c:\Touch, you can create shortcuts on your taskbar to Touch On and Touch Off. I set them both to run as administrator. Pretty self-explanatory. Asus should create an officially supported solution, but in the meantime, this works great for me. With these, you can toggle touch on and off while continuing to use the stylus. Super useful in Onenote or art applications.

    [​IMG]
     

    Attached Files:

    Last edited by a moderator: May 18, 2015
  2. Tonitti

    Tonitti Scribbler - Standard Member

    Messages:
    288
    Likes Received:
    27
    Trophy Points:
    41
    Many thanks, it worked perfectly. Unfortunately I couldn't solve my problem with pressure not working in Photoshop and Sai, hopefully a solution will be found soon.
     
  3. eaton46

    eaton46 Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    This did not work for me. I extracted the files to a folder named Touch on C: drive. Then I clicked on the DevManView.exe file. This did something, but I don’t know what. After doing this, I went back and clicked on the two shortcuts called: Touch off and Touch on; but, a message tells me to check the spelling because windows cannot locate the files. What do I need to do to get the two shortcuts to work? Any help would be greatly appreciated. By the way, under the properties of these two files the target points to:
    C:\Touch\DevManView.exe /disable "HID\ATML1000&Col01\4&20a10191&0&0000" and
    C:\Touch\DevManView.exe /enable "HID\ATML1000&Col01\4&20a10191&0&0000"
     
  4. curtissh

    curtissh Scribbler - Standard Member

    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    31
    Running DevManView.exe without any parameters wouldn't do anything.

    Provided the shortcuts are located int the same folder (i.e., C:\Touch), they should activate and deactivate touch. If they're not working, it may be because the HID for your touch digitizer is different (curious that Asus would change it). Let me know if you need help identifying the HID for your device.
     
  5. eaton46

    eaton46 Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Thank you for answering my post. Yes, I do have both shortcuts in C:\Touch. I went into System Devices to check the HID Devices on my computer. This is what I found:
     
  6. eaton46

    eaton46 Pen Pal - Newbie

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    5
    Don't know why the message send before I was finished with it. Sorry about that. To continue, here is what I found.

    System Devices
    Human Interface Devices
    HID-compliant device
    Device HID\ATML1000&Col01\4&20a10191&0&0000 was configured
    Driver Name: input.inf
    Class GUID: {745A17A0-74D3-11D0-B6FE-00A0C90F57DA}
    Driver Date: 06/21/2006

    Hope this info will help figure out why the shortcuts will not work. Thanks again.
     
  7. curtissh

    curtissh Scribbler - Standard Member

    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    31
    That's the same HID. Provided you've followed the instructions above, I'm not sure what to tell you. Apologies. Works great for me and others.

    Just to be clear, this disables/enables your ability to actually touch the screen with your finger to interact with the device.

    Note also that the shortcuts trigger the UAC, but that's simply a matter of approving the change each time.
     
  8. bam3000

    bam3000 Pen Pal - Newbie

    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    6
    But this utility will disable the touch even if you restart your machine. It will remain disabled.
    Is there a way to enabled when rebooting wiidows by default?
     
  9. curtissh

    curtissh Scribbler - Standard Member

    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    31
    I haven't tried it, but I suppose you could copy the Touch On shortcut to the Windows startup folder, located here:

    C:\Users\<User Profile folder name>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup
     
  10. meshein

    meshein Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    I was looking everywhere for this! So stoked. Works well too. Much better than the shortcut to the device manager and 5 clicks away. Only issue is that my computer asks for permission every time that I click on or off... I tried to look into ways to disable this for this program only. Any suggestions?
     

Share This Page