New Asus Drivers for 810 2-20-13

Discussion in 'Asus' started by swagner53, Feb 20, 2013.

Thread Status:
Not open for further replies.
  1. Breed

    Breed Scribbler - Standard Member

    Messages:
    218
    Likes Received:
    4
    Trophy Points:
    31
    Okay, I've spotted your problem. All the drivers in 2.03 are newer EXCEPT for the Sensor Firmware. In 2.03 it is 0017, but in 2.1.0.5 it is 0020. For some reason, in the new pack they've reverted to the older sensor firmware. Don't know why, perhaps 0020 is not stable or they found a bug in it? Anyway, the install errors out here because it's trying to install an older version over the new one and failing.

    You can force the update to skip this step by modifying the Install.cmd (right click and press edit). Find this line:

    Code:
    STMicroSensorHubTool.exe /getinfo | findstr /c:"Current Version" | findstr "17"
    and change it to:

    Code:
    STMicroSensorHubTool.exe /getinfo | findstr /c:"Current Version" | findstr "20"
    Save this and then run Install.cmd again. It should complete successfully.

    I can see from the log it's already installed the Intel drivers from 2.03, so you'll see a lot of "...does not need updated" on the screen.

    Pretty poor show from Asus. It means anyone who Support gave the older 2.1.0.5 update to and then tried to install 2.03 from LiveUpdate would see the same error! Not good.
     
    Last edited: Feb 22, 2013
  2. galtom

    galtom Pen Pal - Newbie

    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    15
  3. Breed

    Breed Scribbler - Standard Member

    Messages:
    218
    Likes Received:
    4
    Trophy Points:
    31
    As mentioned in the thread, that looks like a Windows TCP/IP stack issue. Nothing to do but wait for MS to release a HOTFIX that actually work, I'm afraid.
     
  4. curtissh

    curtissh Scribbler - Standard Member

    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    31
    Well, finally had my first crash since the updated drivers. Opened the lid to nothing, and had to hard reset. Came up requesting that I submit a Windows system crash report, which is better than before. Made me think it may have been a Windows issue. Curious . . .
     
  5. mm289

    mm289 Tablet Business User

    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    15
    Woohoo, it might have worked!!

    After multiple complete restores I still couldn't get LiveUpdate to work. I had downloaded the driver pack, tried running install.cmd as admin, even tried playing with the cmd file to run as seperate components, installing the Intel drivers on their own crashed the machine so had to do another complete restore :(

    Then used the elevated cmd instruction as per Breed's post and it seems to have worked!! Log file as follows:
    [ASUS Driver Install Start]
    22/02/2013 23:24:56.59

    Install Intel Driver Start ...
    Insatll Inter Drive Done with 3010

    Sensor Hub Firmware does not need update!!

    Digitizer BootLoader does not need update!!

    Digitizer Firmware does not need update!!

    Write TF810C Driver Package Version:

    HKEY_LOCAL_MACHINE\Software\ASUS\Driver
    DisplayName REG_SZ TF810C
    DisplayVersion REG_SZ 2.03

    22/02/2013 23:27:55.30
    [ASUS Driver Install End]

    Far more successful than before! Thanks Breed :)
     
  6. Breed

    Breed Scribbler - Standard Member

    Messages:
    218
    Likes Received:
    4
    Trophy Points:
    31
    Definitely worked all right. Matches my log file and I installed via LiveUpdate. Your BIOS should update upon restart.
     
  7. galtom

    galtom Pen Pal - Newbie

    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    15
    Just woke up. I have not run final update yet (again) as Breed instructed but stuff that is already updated did not seem to fix sleep/wake up issue I have :(.
    Still when I leave tablet for few minutes it goes dark and does not want to activate after I touch power or Windows button. All I get is (as I did), vibration and that is it :(
     
  8. vadimpelau

    vadimpelau Scribbler - Standard Member

    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    31
    Maybe it's a RMA issue?
     
  9. galtom

    galtom Pen Pal - Newbie

    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    15
  10. vadimpelau

    vadimpelau Scribbler - Standard Member

    Messages:
    107
    Likes Received:
    0
    Trophy Points:
    31
    Return to manufacturer.
     
Loading...
Similar Threads - Asus Drivers
  1. Luca92
    Replies:
    10
    Views:
    5,158
Thread Status:
Not open for further replies.

Share This Page