New ArtDock for Surface Pro

Discussion in 'Microsoft' started by DoctorBunsenHoneydew, Feb 17, 2013.

Thread Status:
Not open for further replies.
  1. whazzup

    whazzup Scribbler - Standard Member

    Messages:
    531
    Likes Received:
    32
    Trophy Points:
    41
    Hi, would like to check: is there any solution that allows me to use the artdock without any gloves / keep my palm off the screen? Tried using Tguard, but it only helps in disabling the touch without logging off, but somehow not the palm detection.
     
  2. dream3

    dream3 Scribbler - Standard Member

    Messages:
    321
    Likes Received:
    14
    Trophy Points:
    31
    Man, that did work, thanks!


    Now I have another problem. Everytime my pen is near the tablet, I cant press the artdock buttons. I have to lift the pen enough so the pointer disappears, then I can touch the onscreen buttons.

    THATS VERY ANNOYING! Im hoping thats not default cause it defeats its own purpose.

    Anyone having similar issues?

    Fixes for that?
     
  3. Steve S

    Steve S Pen Pro - Senior Member Super Moderator

    Messages:
    8,390
    Likes Received:
    3,886
    Trophy Points:
    331
    <<...Everytime my pen is near the tablet, I cant press the artdock buttons...>>

    ...That is how the tablet is designed to work. When the digitizer senses the pen, touch is turned off. When the pen is withdrawn, touch is reactivated...
     
  4. DoctorBunsenHoneydew

    DoctorBunsenHoneydew Scribbler - Standard Member

    Messages:
    168
    Likes Received:
    23
    Trophy Points:
    31
    After some tests:

    - It happens on both windows 7 and 8. Not unique to the new OS.
    - it happens across different hardware. Not unique to the surface pro.
    - it only happens when a large touch area is activated. When a large enough touch area is detected, all touch disables until the offending area is small enough to register as touch again.

    It's impossible to tell where in software this killswitch is coming from ( could be os, or touch drivers), but in any case it's coming from a lower level than what ArtDock can access.

    Someone might be able to get around it by switching the keys to a toggle, but that probably wouldn't feel very intuitive.

    So long story short: use Tguard and wear a fingerless glove on your drawing hand. That's the best it's going to get for now.

    I'll release an updated version of art dock with Tguard packed in, and the old palm disable ripped out.
     
  5. DoctorBunsenHoneydew

    DoctorBunsenHoneydew Scribbler - Standard Member

    Messages:
    168
    Likes Received:
    23
    Trophy Points:
    31
    Hey Steve; this isn't "touch disables when the pen gets close". This is "the entire touch input stops taking input if it detects too large of a touch point."
     
  6. whazzup

    whazzup Scribbler - Standard Member

    Messages:
    531
    Likes Received:
    32
    Trophy Points:
    41
    Thanks for the explanation! Good to know what's happening, but a real bummer that it's beyond the capabilities of Artdock / AutoHotkey. I guess the issue will only be solved when someone figures out that we don't really need touch capabilities on the whole screen....and give us configurable touch regions....
     
  7. DoctorBunsenHoneydew

    DoctorBunsenHoneydew Scribbler - Standard Member

    Messages:
    168
    Likes Received:
    23
    Trophy Points:
    31
    Yeah, I think this is a case where there are very, very few apps that use touch and pen input at the exact same time. I can't think of a single one offhand.

    I did a bit more digging, and apparently there IS a value buried in the windows touch API that disable palm rejection specifically:

    http://msdn.microsoft.com/en-us/library/windows/desktop/dd317326(v=vs.85).aspx

    TWF_WANTPALM is the one that would do it. It allows "palm" touch as an input, (apparently palm touch just means any touch point larger that a certain radius). In our case, since Tguard is already doing that work for us, we want that value toggled. Not sure if its even a global registry value that can be tweaked. I'll keep looking.

    UPDATE: as far as I can tell, there is no global reg/gpedit setting to disable this palm filtering feature in windows. The only reference to this filtering anywhere is that:

    - Raw data from touch hardware produces a blobby map of touch points.
    - windows touch drivers interpret that blobby map into its best guess of what a finger touch is.
    - There's an additional killswitch built in, that temporarily disables all touch registers if it detects an extremely large touch point. (This is the thing we would want to disable)
    - If you are programming your own application, you can set up a specific window in your own app only that can accept these palm touch inputs. Apparently it's faster too, on account of not having to filter palm touch every frame.
    - there is absolutely no information at all that says you can disable this palm filtering system wide. :(

    Not sure why they would disable ALL touch points anyway, instead of just the errant palm touch. Seems like kind of a dumb way to do it :(

    So yeah, good news is that errant finger touches won't happen anymore (Tguard), and the bad news is that touch never, ever works anywhere in windows if you have your big fat palm meat resting on the screen.

    TLDR version? Use Tguard, use art dock, and get a glove that covers your palm and you should have no problems at all.
     
    Last edited: Sep 2, 2013
  8. BluEgo

    BluEgo Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Hi There, first of all thank you SO MUCH for this amazing add-on.
    I have a problem since I installed the latest version of AutoHotKey though: now when the pen goes over the ArtDock, this starts flickering while the pen still moves, and eventually it disappears/crashes. If I try to relaunch it again, a popup window appears saying that there is already another instance of AutoHotKey running.
    Before I was using an older version of AutoHotKey (the same suggested here in this thread), but I was unable to use the command "GUI -DPIScale".
    May I ask you which version of AutoHotKey do you use?

    Thank you and great job!
     
  9. DoctorBunsenHoneydew

    DoctorBunsenHoneydew Scribbler - Standard Member

    Messages:
    168
    Likes Received:
    23
    Trophy Points:
    31
    thanks! i'd try fresh installing all. never seen that issue.
     
  10. DoctorBunsenHoneydew

    DoctorBunsenHoneydew Scribbler - Standard Member

    Messages:
    168
    Likes Received:
    23
    Trophy Points:
    31
    Ok, uploaded version 2 of ArtDock. Fixed dpi scaling bug, Integrated Tguard, made it all run from a taskbar toggle, and simplified things further. Enjoy!
     
    Last edited: Sep 4, 2013
Loading...
Thread Status:
Not open for further replies.

Share This Page