New ArtDock for Surface Pro

Discussion in 'Microsoft' started by DoctorBunsenHoneydew, Feb 17, 2013.

  1. surfaceproartist

    surfaceproartist Scribbler - Standard Member Senior Member

    Messages:
    2,979
    Likes Received:
    1,900
    Trophy Points:
    181
  2. Precurve

    Precurve Scribbler - Standard Member

    Messages:
    258
    Likes Received:
    200
    Trophy Points:
    56
    Hello surfaceproartist,
    I've tried the legacy versions of ArtDock on my Fujitsu t904 and they don't seem to run (device profiles missing in sourcecode). I had used a modified version of ArtDock on my SS7 and I really love the utility. Is there any chance your new version might work on wider set of devices, including t904, than the original code? I could always just try it but I thought I'd check first. If the current version won't work on t904, any idea about how to update the source with new device profiles?

    Thanks for whatever time you have to reply. I know you keep very busy running your web site and testing products. Excellent work by the way. You are a real nexus for creative tablet users.
     
  3. surfaceproartist

    surfaceproartist Scribbler - Standard Member Senior Member

    Messages:
    2,979
    Likes Received:
    1,900
    Trophy Points:
    181
    I wish I could say but I simply don't know enough about the underlying Authohotkey code. All that Alex Cheparev and I have done is mess with the bitmaps and dock scripts. I've inquired from ArtDock creators here, but they don't seem to know either.
     
    Precurve likes this.
  4. nrek

    nrek Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I am trying to get artdoc running on my dell venue 8 pro windows 8.1 tablet. It seems to install and launch just fine, however it doesn't seem to register inputs. And when I touch it the doc goes away, and if I touch anywhere else the doc comes back. Any thoughts on how I may get this working? Does this on/off issue sound like something you guys have seen elsewhere. Since the venue and surface are pretty similar I'm thinking this may be more of an error on my part. Any help would be much appreciated. My end goal is to get this working so I can test out my workflow before deciding to buy a surface pro.
     
  5. ron2k_1

    ron2k_1 calibuchi Senior Member

    Messages:
    1,013
    Likes Received:
    173
    Trophy Points:
    81
    @DoctorBunsenHoneydew and @surfaceproartist.

    What all you guys change on the original ArtDock for it to work on the Surface? I have a new Lenovo x230t coming anytime now and I'm planning on seeing if I can figure out how to create a Rawinput profile for this device. Your input will be of help

    Sent from my GT-N5100 using Tapatalk
     
  6. Precurve

    Precurve Scribbler - Standard Member

    Messages:
    258
    Likes Received:
    200
    Trophy Points:
    56
    What you are describing is the behavior of Artdock when it is running on a machine that does not have a compatible device profile in the Artdock code. Its not something you are doing wrong. I have so far been unsuccessful at figuring out the black art of researching and writing new device profiles. I was hoping to do that for a Fujitsu t904.
     
  7. thewish

    thewish Pen Pal - Newbie

    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    6
    Same thing happens on the Thinkpad Yoga. From what I can tell, the guys like surfaceproartist who have modified the themes of the dock, didnt create the device profiles. I've encountered many deadends in the search for the origins of those profiles unfortunately..
     
  8. thewish

    thewish Pen Pal - Newbie

    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    6
    Hi All, I stumbled across a couple forums that may be helpful in setting up your own profiles:

    Possible RawInput solutions:
    http://forum.tabletpcreview.com/artists/58400-artdock-guide-compatibility-links-4.html#post343381
    http://forum.tabletpcreview.com/software/56322-apps-tablet-pc-5.html#post334187

    New Art Dock for Vaio Duo 13(+others)
    http://forum.tabletpcreview.com/artists/63005-chomp-toolbar-sony-vaio-duo-13-other-tablets-2.html
     
  9. Mr.Tough

    Mr.Tough Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Hello,

    I am having some trouble with Artdock on my Surface Pro 1. (Windows 8.1)
    I have installed it and it starts up just fine, but Tguard (which starts along with artdock) seems to block both the touchscreen&digitizer aswell as my mouse from clicking on any buttons. (Nothing happens when trying to click on anything, so I can't inactivate Tguards function).
    The only thing that works for me is to swipe and open metro. This allows me to either restart the computer or turn T-guard off by starting task-manager and with my keyboard shutting the application down.

    Has anybody got a solution for this? Thanks in advance!
     
  10. jaekqubp

    jaekqubp Pen Pal - Newbie

    Messages:
    93
    Likes Received:
    6
    Trophy Points:
    16
    I experienced this issue the first time I ran the dock on my Surface Pro 1, as well. After shutting down and booting back up it seems to work fine.

     
Loading...

Share This Page