Music player - some thoughts

Discussion in 'Asus (Android)' started by d.goryachev, Nov 12, 2011.

Thread Status:
Not open for further replies.
  1. d.goryachev

    d.goryachev Scribbler - Standard Member

    Messages:
    275
    Likes Received:
    0
    Trophy Points:
    31
    Could you try to execute such script:

    Code:
    #!/bin/sh
    
    lo = `ifconfig|grep -i loopback|awk '{print($1)}'`;
    if ! [ "${lo}" = "lo" ]; then
        ifconfig lo up 127.0.0.1
    fi
    
    mpd_pid = `ps aux|grep mpd|grep -v grep|awk '{print($2)}'`;
    
    if [ "${mpd_pid}" = "" ]; then
        /opt/bin/mpd /eTablet/Settings/mpd/mpd.conf
    fi
    
    /opt/bin/QtMPC
    wait
    
    killall mpd
    
     
  2. osowiecki

    osowiecki Scribbler - Standard Member

    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    31
    Works on eeenote (consoleq)
    Fails via Telnet. (which makes sens)
    Do you want the output from the console?
     
  3. d.goryachev

    d.goryachev Scribbler - Standard Member

    Messages:
    275
    Likes Received:
    0
    Trophy Points:
    31
    No, I hope it will work for all users, finally.
    This problem was .. unexpected :)
     
  4. T_B

    T_B Scribbler - Standard Member

    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    30
    Script didn't work for me.
    3: lo: not found
    8: mpd_pid: not found
     
  5. osowiecki

    osowiecki Scribbler - Standard Member

    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    31
    1. Check your default lo "ifconfig" and write it down.
    2. Set up your 'lo' manally.
    3. Tell if that works.
    4. restore default lo
     
  6. T_B

    T_B Scribbler - Standard Member

    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    30
    Ifconfig
    lo Link encap:Local Loopback
    inet addr: 127.0.0.1 mask 255.0.0.0 etc...

    I can ping 127.0.0.1

    not sure what you mean with 'default lo "ifconfig"'
     
  7. osowiecki

    osowiecki Scribbler - Standard Member

    Messages:
    175
    Likes Received:
    0
    Trophy Points:
    31
    inet addr: 127.0.0.1 is your 'default lo'

    By "default" i meant : your lo config before making any changes.

    Have you tried to Purge QtMPC / removing all 'libmad libs' manully / reinstall all from pb-repo ?
     
  8. T_B

    T_B Scribbler - Standard Member

    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    30
    default is 127.0.0.1

    Just tried to manually removing the libmad libs from /usr/local/lib/ but it gave me a "unable to remove : read only file system' message. Should I delete them from somewhere else, or is my filesystem corrupt?

    Probably need to do this... first.

    mount -o remount,rw /dev/mss/blk0p5 /usr

    Let me try..

    I could delete the files, but it didn't help. QtMPC seems to remember the last settings even after removing and re-installing. Maybe there is a default settings file I need to remove? Any idea where I might find such a file?
     
  9. d.goryachev

    d.goryachev Scribbler - Standard Member

    Messages:
    275
    Likes Received:
    0
    Trophy Points:
    31
    All settings can be found into /eTablet/Settings/mpd (don't delete mpd.conf, it's vital) and /eTablet/Settings/QtMPC (can de safely removed)

    /eTablet is mounted in read-write mode

    without libmad mpd will not start
     
  10. T_B

    T_B Scribbler - Standard Member

    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    30
    Well, before I will do other attempts..
    I have the luxury of owning another eee note (software V108). I couldn't have messed up settings on that one and just did a clean install and had the same result.
    My other eee note has software version V1.0.16.126
     
Thread Status:
Not open for further replies.

Share This Page