Installing and using the Windows 8 Release Preview

Discussion in 'EP121 Slate' started by chapmattman, Jun 1, 2012.

Thread Status:
Not open for further replies.
  1. chapmattman

    chapmattman Pen Pal - Newbie

    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    15
    The Win 8 Release Preview is out as of yesterday, and like the fool I am I am going to install it on the EP121 (and I think it was only 4 weeks ago I got the Consumer Preview to where I wanted it!).

    I will keep this thread updated with my results for those enthusiasts that are interested.

    There is no fast upgrade path from the Consumer Preview, IE you cannot keep any programs or files like you can from Win 7 to Win 8.

    So, my ArtRage, Sketchbook, etc will have to be re-installed. I am using the Easy file transfer to keep files. Just go to search and type easy file transfter, and Windows pulls up the transfer program.

    It is not recommended to transfer settings, so I am going to save all my files, and then do a clean install of Win 8 Release Preview.

    Let's see what happens... :rolleyes:
     
  2. bb_145

    bb_145 Pen Pal - Newbie

    Messages:
    49
    Likes Received:
    1
    Trophy Points:
    16
    I installed it last night, though have't had a chance to really play with it yet. So far it seems snappier and more refined than the CP version. I was also pleasantly surprised to find that the bluetooth worked right after the install. (Though the other buttons and screen rotate still don't.)
     
  3. pellegew

    pellegew Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    BECAREFUL: The Atheros Bluetooth driver that installed automatically with my EP121 caused TERRIBLE battery drain. Disabled the driver and gained more than 1hr in anticipated battery life instantly. I switched the driver to Windows 8 default generic Bluetooth driver and it works perfectly. No problem with battery drain.

    To get over 4 hours I reinstalled ASUS's video driver. Again, the windows 8 caused some unneeded drain.
     
  4. chapmattman

    chapmattman Pen Pal - Newbie

    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    15
    Bluetooth is installed and working over here as well. I agree the system seems a little more snappy, but things like the icons loading when you go to search seem to hang for a second (you guys too?)

    We'll see what happens next, I am installing Office to see if the OneNote bug has been fixed (pinch/zoom didn't work).
     
    Last edited: Jun 2, 2012
  5. chapmattman

    chapmattman Pen Pal - Newbie

    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    15
    @pellegew can you describe how to change the drivers? Just uninstall the Atheros? Where did you download the asus driver. all specifics help, thanks!
     
  6. chapmattman

    chapmattman Pen Pal - Newbie

    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    15
    Well, some erratic behavior from it but I haven't installed all drivers. OneNote will pinch to zoom ONCE when it is started, and then never again.

    Oh well.

    its late so I am gonna go to bed, I tried downloading WORDAMENT and found out that I can't cause my gamertag is associated with the Netherlands, and my LIVE account is associated with the US. I guess you can't live in two countries according to MS. (SIGH).

    Keep you guys posted tomorrow.
     
  7. ShinNoNoir

    ShinNoNoir Pen Pal - Newbie

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    5
    It's a bug since the Developer's Preview. :(
     
  8. Steve S

    Steve S Pen Pro - Senior Member Super Moderator

    Messages:
    7,818
    Likes Received:
    3,298
    Trophy Points:
    331
    <<...OneNote will pinch to zoom ONCE when it is started, and then never again...>>

    ...I'm noticing a similar behavior on my Q. I can get apps to start, but sometimes they will only function the first time. After that, if I start them, I just get a white screen or no response...

    Maybe it's just me, but this close to RTM, I find the number of "loose ends" more than a little disturbing...
     
  9. chapmattman

    chapmattman Pen Pal - Newbie

    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    15
    Well, morning time update. The devices are all working pretty well. I was able to delete the windows.old install, though it is disturbing that I still have some of the settings in my machine, such as the lock screen picture. I thought that by saving "nothing" I was going to get a full fresh install, but that was not the case.

    And, the morning came with some good news. I did a search for Pen, and all my Pen options were available in the device settings. I did a pen calibration, and it asked if I wanted to run the WACOM calibration tool, and to my excitement, ran in 16-point calibration mode. I think in the previous version I only got 8 points. This is a welcome change, and after running the tool (click where it LOOKS like the point intersects, ignore the cursor...) the pen is completely working. Great pressure, in ArtRage and Sketchbook.

    The other thing that is good is that while MS still makes it difficult to disable touch, it can be done through the device manager. In the consumer preview disabling touch caused the on-screen keyboard to be reduced to a super miniature version, and you had to restart to fix it. That makes me think that at the very least a script can be written a la touchtoggle.exe to help in the future.

    OneNote works great except it still doesn't recognize pinch to zoom. It seems like this shouldn't be such a big deal, but really I am shocked at how much I miss that in the software.

    Office 15 comes out in June or July for beta, so maybe we'll see something new there.

    @steve s. Did you do a clean install or an upgrade install? I had a couple buggy apps to begin with but after a couple restarts everything has been working well. The new Metro apps for News/Sports/Kindle are GREAT. I am a little more impressed with METRO.
     
  10. Steve S

    Steve S Pen Pro - Senior Member Super Moderator

    Messages:
    7,818
    Likes Received:
    3,298
    Trophy Points:
    331
    <<...@steve s. Did you do a clean install or an upgrade install? I had a couple buggy apps...but after a couple restarts everything has been working well...>>

    matt: Did a clean install. I'm not a fan of upgrades as my experience is that sooner or later, upgrade installs begin to develop problems.

    I am also noticing that a few restarts down the road, some things are working more reliably. I wonder why that is...???
     
Loading...
Similar Threads - Installing using Windows
  1. lblb
    Replies:
    0
    Views:
    945
Thread Status:
Not open for further replies.

Share This Page