I *think* I got rid of the CPU noise for good, on Core Duo. Please read.

Discussion in 'Hardware' started by ins0mni4c7, May 1, 2014.

  1. Yubastard

    Yubastard Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    Hi, I just recently recieved an M285 Core Duo T2500 2.0Ghz Gateway Convertible, and, like many of you, noticed that damn noise.

    Now, many of you recomend using RM CPU Clock and checking: "Run HLT command when OS is idle (restart required)", on the Management page, as an effective method of silencing the noise. It does work. However, battery life takes a hit.

    As I have gathered from Apple MacBook blogs, the noise comes when the processor switches power states, between Hard C4 (battery power state) and all other states.

    I knew RMClock was the tool but didn't know how to use it until tonight. The above "Run HLT..." option works because it takes the CPU out of the Hard C4 state(battery), you can see Task Manager @ 100% (because RMClock idles instead of Windows), thus reducing battery life noticiably.

    Instead, use these settings:

    1. Management page:
      • unckeck: "Use OS load-based management"
      • uncheck: "Run HLT command when OS is idle(requires restart)"
      • check: "Restore CPU defaults..." - both options
      • select: from the "CPU defaults selection" drop-down menu: "CPU-defined default FID/VID"
    2. Profiles page(if you know what ur doin'):
      • for AC power choose Maximal Performance profile and, under AC tab, check "Use P-States..." and "Use Throttling(ODCM)", use index #6 for both.
      • for battery power choose Power Saving profile and, under battery tab, check "Use P-States..." and use index #1, unckeck "Use Throttling(ODCM)", or, alternatively, use "Performance on Demand" profile and check nothing.
    3. Advanced CPU Settings page:
      • Processor Tab:
        • uncheck: "Enable Thermal Monitor 1" (makes CPU jumpy when it gets hot, that's why there's TM2)
        • check: "Enable Thermal Monior 2" (replaces TM1)
        • check these Enhanced Low Power States: C1E, C2E, Hard C4E.
      • Platform Tab:
        • check: "Enable Popdown Mode"
        • THE MOST IMPORTANT!! uncheck: "Enable Popup Mode"

    That last one is the most important as it's the one that silences the noise! All of the other ones where just to preserve battery life and keep everything safe if you exit RMClock. You can also check: "Run application automatically when Windows session starts" for hassle-free power management (tho' it seems to keep working after you exit!).

    Press "Apply" and ur done... but wait, these settings, if improperly set, may heat up any computer, so, please, do it at your own risk. I'm a computer engineering student and know my way around, more or less, but it works and preserves battery, on my Core Duo T2500 2.0Ghz with BIOS version 78.03, haven't tested it with newer 78.04.

    Also, it pumps it up on AC power, without too much heating or jumpyness after long standby.

    Hope it works for other Core Duo users and even Pentium M, and I hope I was clear enough. I wish I could keep experimenting and try to get more life out of battery but it's 5:30am and I'm tired. @ least, I don't have the whinning anymore and have more than 4 hours of battery life

    If you try please reply and give your opinion. :) if it works or not.
     
  2. Yubastard

    Yubastard Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    I forgot!!!

    In "Adavcend CPU Setings" page, check the "Apply these settings at startup", beside the Refresh button, at bottom.

    This is so when you restart, these power management settings will kick in.
     
  3. rickyder

    rickyder Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Yubastard: GENIUS!!! Your fix worked perfectly on my Dell laptop Intel Core Duo 1.83 GHz. Battery life is superb. I thought I was going to have to permanently plug in a USB device to keep me from going insane. Thank you so much.
     
  4. Yubastard

    Yubastard Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    that's good to hear! :)

    wow, even a Dell has same problems. Must be cheap Centrino manufacturing.
     
  5. L33tmaster

    L33tmaster Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    I just tried it out, it works perfectly and doesn't noticeably affect the battery life. Thanks!
     
  6. Yubastard

    Yubastard Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    that's great! you're welcome!!

    could you please post your system specs? so that other people with the same system might try it out? thanx!
     
  7. L33tmaster

    L33tmaster Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    I have a CX210X, Core Duo T2500
     
  8. thetick244

    thetick244 Pen Pal - Newbie

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    I tried this on a t7200 core 2. It works generally, but the buzz hmm or jingle jangle comes back if the system is idle for more than a few seconds. Which works if you do notes fast. Thank you you(beautiful)bastard. It does raise the temperature to about 50 C. Which I am going to watch and I have not seen the original, but I think it was a little cooler. I am not sure I will get back to you on that.
     
  9. Yubastard

    Yubastard Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    16
    wow, didn't know core 2 duos had the same problem... mine gets hot, too, but I believe it was like that from the beggining... might want to use "Power on demand" profiles, instead of "Maximal Performance" profile, and Balanced setting, if you tend to leave it ON conected to AC for a long period of time.

    Thanx for replying! :)
     
  10. thetick244

    thetick244 Pen Pal - Newbie

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    5
    Yes the core 2 does and the problem is persistant as my bad spelling. I did get rid of the sound by McGuyvering. I put a USB memory doo-hicky in the whatcha mazoo and the sound was gone and pulled the magigar out and the sound was gone. When the power went into hibernate the sound returned and the trick does not work until the computer restarts. but the RM clock did cut a part of the noise out. So bastard we meet again. Thanks also for you meddling and help for all of us out here.
     
Loading...

Share This Page