HP Pro Tablet 608 G1 Discussion Thread

Discussion in 'Hewlett Packard' started by dellaster, Sep 14, 2015.

  1. Vince Antonelli

    Vince Antonelli Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    Has anyone found a usb-c (m) to USB-a (f) adapter that will power a standard 10/100 ASiXS Ethernet adapter, or a cheap usb-c Ethernet adapter that works.
    Does this tabley need a powered USB hub to connect an USB to Ethernet adapter.
     
  2. Projects

    Projects Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Just installed Windows 10s and the HP608 is like a different machine, so much more responsive. All the drivers are working no issues.
     
  3. IsLNdbOi

    IsLNdbOi Scribbler - Standard Member

    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    31
    Is there anything available now in the USA that's like this HP tablet (8" screen, Windows 10)?
     
  4. HJK

    HJK Scribbler - Standard Member

    Messages:
    541
    Likes Received:
    63
    Trophy Points:
    41
    How did you do that? Why is it more responsive?
    I have some old atom tablets that have really slowed down to the point of being unusable on Windows 10. I wonder if 10s could bring them back to life.
     
  5. Looker1122

    Looker1122 Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I'm on 1.06 BIOS - no touch screen lag issue.

    I thinking about carefully updating BIOS.
    So I have a question:
    do you think that absent of HP's "Prevents the BIOS from being rolled back to an older version" or "Due to security changes, after this BIOS update is installed, previous versions cannot be reinstalled." disclaimer/note in BIOS update files description is reliable?

    I plan to update to 1.07 (considered lag-free), but this version can't be rolled back ("Prevents the BIOS from being rolled back to an older version" - but is not clear that for this version only or for every future versions?).

    Then I plan to update to 1.09 (considered as probably with a touchscreen bug) and this version don't have any above disclaimers - so theoretically could be downgraded.
    Same for 1.10, 1.12 and 1.13.

    The next version with non-downgrade note is 1.15.

    What do you think?
    It is safe to update to 1.09 and still have option to downgrade?
     
    Last edited: Jul 25, 2018
Loading...

Share This Page