HP Elite X2 1012 Discussion Thread

Discussion in 'Hewlett Packard' started by SF6, Dec 27, 2015.

  1. zeek

    zeek Scribbler - Standard Member

    Messages:
    222
    Likes Received:
    17
    Trophy Points:
    31
    Try comparing it to the price on the HP web site. They have some special discounts this week but I'm not sure any of them apply to this model. You'll have to check. You could also compare to other resellers by doing a Google search.
     
  2. Marucha07

    Marucha07 Pen Pal - Newbie

    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    6
    I have bought the Tab (M5, 8/256GB, LTE-Modulle, Keyboard) from HP Germany's online store some days ago but am returning it now. It is because the LTE-Module isn't working at all. I live in Germany and am with Deutsche Telekom (T-Mobile) as carrier. There never was any smallest problem with my SIM-Card in my previous Galaxy Pro 12 Android Tablet. But I couldn't make the HP X2 to work with the mobile network of Telekom. Perhaps some of you has similar problems and a solution to that, or, your tablets make no such problems with your Internet providers?
    After initial setup and after investing many hours in configuring the tab I decided to give it a try with LTE-Connectivity. It worked well at first but then stopped working without apparent reason. A message like: A Connection with this network is not possible, please give a valid APN and try again" kept popping up but the APN I did provide were either ignored or refused or not working.
    It was driving me nuts!
    So on Thursday evening I did full factory reset and started anew, slowly and carefully, with SIM already inserted. And it did work quite beautifully. It connected and disconnected to and from LTE-Network of the Telekom like a charm. Till Friday noon, when it stopped working altogether... Was it a Microsoft update in the background? Or is the LTE-Module faulty? I have no experience with mobile connectivity under Windows, only with Android. I hope to get some advice from you.
    LTE is essential for me, as I intended to use the tab primarily for mobile Photoediting on weekend trips etc.
    Apart of that, an excellent Tablet, Lightroom was running smoothly and I could make a good use of the pen. I had to drive/screw the spring that holds the main pens-battery down to its base to avoid the initial dropouts. After that it worked absolutely well.
    Very good keyboard too, for me even better than that of my Dell XPS 15 Laptop.
    But I was not willing to accept the lack of an essential functionality on a tablet so expensive like this one.
    So it goes back to HP for now...
     
    Last edited by a moderator: Feb 22, 2016
  3. zeek

    zeek Scribbler - Standard Member

    Messages:
    222
    Likes Received:
    17
    Trophy Points:
    31
    You might want to try:

    1. Replacing your SIM card with a new one. Sometimes that helps with intermittent problems.

    2. Double check that your APN settings are correct.

    3. Make sure the WWAN modem supports your carrier.
     
  4. Marucha07

    Marucha07 Pen Pal - Newbie

    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    6
    @zeek
    Thanks for your input,
    1. I tried another sim from same carrier, no success
    2. I have checked and double checked the APN-Settings. Here I have to put in, that after initial initial setup of the tab, when the WWAN-module was still functioning, it didn't ask for or request of any APN. It connected to Telekom LTE quite of itself, like, automatically. And after several hours, out of nothing and suddenly it stopped working...
    3. Even after it stopped working, it still saw the network. LTE Telekom was displayed in the Mobile Settings but the modem couldn't connect to it, no matter what...
    I strongly suspect, that a major background-OS-Update by Microsoft could be the trigger of the problem. What do you think?
     
  5. zeek

    zeek Scribbler - Standard Member

    Messages:
    222
    Likes Received:
    17
    Trophy Points:
    31
    I would tend to doubt that it is due to a faulty MS update or modem. There might be some missing updates. Do you have all the MS updates installed as well as all the HP updates?

    I dont have my system anymore but I didnt have to creäte an APN either. The system automatically created the one needed for the type of SIMs I was using. In my case that was Verizon and AT&T in the US.

    What model WWAN card is in your system? You can check in device manager.

    Are you sure the WWAN card supports your carrier?

    Are your SIMs on a contract or are they month-to-month prepaid? If prepaid, are you sure there is a non-zero balance?

    Try using your system in a different location. I suppose it could be a signal strength problem.
     
  6. mathartist

    mathartist Pen Pal - Newbie

    Messages:
    64
    Likes Received:
    13
    Trophy Points:
    16
    Unbelievably, my Elite X2 has lost the ability to auto-rotate. The option is not located in the display settings nor in the action center, it has completely disappeared.

    The trackpad does not work when waking up unless I bend the keyboard around backwards, then forwards into normal "laptop" mode either.

    Everything was working fine until I installed some updates yesterday (a firmware update from the HP site, among them).

    Doubt anyone here has similar experiences or a solution but I'm tossing this out anyway.
     
  7. SF6

    SF6 Scribbler - Standard Member

    Messages:
    261
    Likes Received:
    43
    Trophy Points:
    41
    Sure I have. I've posted the issues with auto rotate a few posts ago. I've also experienced problems with the trackpad.
    But the reason I sent the machine back was that the USB C dock is unable to drive any resolution above 2560x1600 even though it has DisplayPort and USB 3.1 Gen 2 should be able to do so.
     
  8. Majirefy

    Majirefy Pen Pal - Newbie

    Messages:
    10
    Likes Received:
    3
    Trophy Points:
    6
    Do you have the issue same with mine?

    Sometimes when I flip the keyboard back too quickly, it recognizes this action as "close the lid", then fells to sleep. But if do it very slowly, it has chance to pop up the dialog asking switching between tablet and desktop mode.
     
  9. mathartist

    mathartist Pen Pal - Newbie

    Messages:
    64
    Likes Received:
    13
    Trophy Points:
    16
    I have that "issue", which I learned to deal with.
     
  10. YK100

    YK100 Pen Pal - Newbie

    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    5

Share This Page