Galaxy Book Flex Unresponsive/ Skipping Pen

Discussion in 'Samsung' started by Steve B, Jan 6, 2021.

  1. Steve B

    Steve B Moderator Moderator

    Messages:
    3,405
    Likes Received:
    578
    Trophy Points:
    181
    Of course, I need to get work done for a deadline, but my pen is now not working regularly. It'll work for a bit, then starts skipping. I've tried rebooting, to no avail. The little Samsung Air thing is popping up a TON as well. Has anyone else had issues like this?

    I've tried resetting the nib, and have tried 3 different pens. So, it's definitely something with the laptop and not the pen. I'm currently working in SBP. Any help would be appreciated.
     
  2. DRTigerlilly

    DRTigerlilly Tablet Lead Mod (Retired) Super Moderator

    Messages:
    7,587
    Likes Received:
    747
    Trophy Points:
    301
    Interesting haven't been able to use my SGB12 either regardless of pen... Any recent updates?

    Sent from my SM-N9600 using Tapatalk
     
  3. darkmagistric

    darkmagistric Pen Pro - Senior Member Senior Member

    Messages:
    3,092
    Likes Received:
    2,254
    Trophy Points:
    231
    My SGB10.6 pen is still working.....for now....
     
  4. Steve B

    Steve B Moderator Moderator

    Messages:
    3,405
    Likes Received:
    578
    Trophy Points:
    181
    Well, after some testing, I can replicate the problem now. The pen becomes non-response when I fold the screen backwards to use it as a tablet. And it won’t consistently work right again until I put it back into laptop mode. The pen works just fine when I use it as a laptop. Perhaps using touch and then using the pen again sort of “triggers” it, but I’m not sure, because sometimes it’ll work for a few strokes as a tablet before it stops.

    Sorta sounds like a call to customer service. :( I didn’t drop it or anything, so I’m pretty surprised, but it sounds like maybe a hardware issue? I think it’s still under warranty. Bleh. I hate dealing with customer service.

    As an interim, maybe I should try out an iPad Pro 12.9? I just want something that works. Ergh! And I just bought a Photodon matte screen protector for pen work.

    Still up for any input on ways to fix things.
     
  5. Steve B

    Steve B Moderator Moderator

    Messages:
    3,405
    Likes Received:
    578
    Trophy Points:
    181
    Good news. I called Samsung support and they were helpful. The pen is working again. It's been a while since I've had issues like this (basically since the last time that I had an EMR laptop 5 years or so ago), but she basically just had me uninstall the Wacom HID pen device in the device manger, reinstall it with a hardware search, and reboot the device. I actually felt a bit silly that it was this simple. I'd forgotten these steps from days gone by, but yes... all seems to be back to normal for now. :)
     
    WillAdams and DRTigerlilly like this.
  6. DRTigerlilly

    DRTigerlilly Tablet Lead Mod (Retired) Super Moderator

    Messages:
    7,587
    Likes Received:
    747
    Trophy Points:
    301
    Will try same & let you know if it works for me too!


    Sent from my SM-N9600 using Tapatalk
     
  7. Steve B

    Steve B Moderator Moderator

    Messages:
    3,405
    Likes Received:
    578
    Trophy Points:
    181
    Well, it stopped working again. I think it went to sleep during the day, and I had sign back in, at which point the pen issue returned. In addition, the Samsung Air Command program has been popping up like mad. I think it's being trigged by something in the digitizer.?? They seem to go hand in hand.

    Samsung has decided I need to send them the laptop, as it's still in warranty. i will say that Samsung has been very nice. No long wait. Useful humans. They made my ticket be for 2-day air, in an attempt to get me the laptop back in a week. Hoping it all works out, but we'll see.
     
    thatcomicsguy, Marty and DRTigerlilly like this.
  8. Shogmaster

    Shogmaster Pen Pro - Senior Member Senior Member

    Messages:
    4,341
    Likes Received:
    1,563
    Trophy Points:
    231
    Sounds like you have intermittent connection between EMR digitizer and computer. Maybe damaged/loose ribbon cable. If the symptoms are same no matter which UD-EMR/S-pen you use, it's the digitizer for sure.
     
  9. Steve B

    Steve B Moderator Moderator

    Messages:
    3,405
    Likes Received:
    578
    Trophy Points:
    181
    I had similar thoughts, which is why I tested with multiple pens. They've supposedly repaired it and are sending it back, but boy... it was a very quick turnaround from when I was notified that they got... and when I was notified that they repaired it. I'm hoping they also think it's a hardware issue, but the fix was so quick, I'm concerned they think it was just software. Well, I'll get it back in a few days, and then I'll put it through the tests.
     
    thatcomicsguy likes this.
  10. Steve B

    Steve B Moderator Moderator

    Messages:
    3,405
    Likes Received:
    578
    Trophy Points:
    181
    I got the device back today, and it's in working order. Seems great. The notes in the box indicate that they swapped out the entire monitor, so it does seem like we had some sort of electrical short or a broken ribbon. There was a kind of plastic "peel off" layer on the hinges. So they definitely replaced things. The pen works fine again, so that's the most essential thing.

    All told, about 10 days from start to finish, including a holiday weekend. Not bad. I also keep a spare laptop around (my old Thinkpad 14) for just such emergencies, so it wasn't as if I couldn't work.
     
    Marty likes this.
Loading...

Share This Page