Disable Intel's automatic 60hz to 40hz refresh rate change on Batt

Discussion in 'HP Elitebooks' started by 2.0™, Nov 28, 2011.

  1. 2.0™

    2.0™ Been Inkin' Staff Member

    Messages:
    395
    Likes Received:
    87
    Trophy Points:
    41
    This is how to fix the annoying automatic 60Hz to 40hz refresh rate switch when one goes from AC to Batt. (you will notice the screen go blank temporarily as it switches). To see what I'm referring to, simply right click your desktop, choose Graphics properties and make sure you are using the advanced layout. There you will see the current refresh rate.

    Open regedit (type regedit in start menu search box)

    Navigate to:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Classes

    Now hit Ctrl+F or select find from the edit menu.

    Search for: FeatureTestControl

    When you find it, change whatever it currently is to f840 (as hex) or 63808(decimal).

    Reboot. Now it will stay on 60Hz whether you run on A/C or Batts. :)
     
  2. rjh

    rjh Pen Pal - Newbie

    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    16
    I've never seen (or been aware of) this tweak on my 2730p, Win7. Both AC and battery show 58Hz.
     
  3. Unlogic

    Unlogic Scribbler - Standard Member

    Messages:
    232
    Likes Received:
    40
    Trophy Points:
    41
    Same thing on the 2710p. Guess this only applies to newer Core iX based 2740/2760 models.
     
  4. 2.0™

    2.0™ Been Inkin' Staff Member

    Messages:
    395
    Likes Received:
    87
    Trophy Points:
    41
    Yes, it only affects Intel's HD 2000/3000 integrated GPU driver.
     
  5. jiggerjosh

    jiggerjosh Pen Pal - Newbie

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    5
    Will this have any effect on our battery life?
     
  6. 2.0™

    2.0™ Been Inkin' Staff Member

    Messages:
    395
    Likes Received:
    87
    Trophy Points:
    41
    Lose about 1-5 mins at the most. Depends on your brightness level and what you set for screen dim/sleep interval. Really negligible difference. Sort of pointless for Intel to implement it.
     
  7. SNorton

    SNorton Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    Apologies for bumping this topic. I just want to publicly thank the OP for helping me solve this annoying problem on my laptop, an HP Pavilion dm4t-2100 with an integrated Intel HD 3000 series GPU. Apparently, that same registry setting was also responsible for preventing my laptop from entering sleep mode on lid close (the computer would continue running hot, would not resume Windows, and would eventually blue screen and shut down), as that error was resolved by changing the value.
     
  8. radpilot

    radpilot Pen Pal - Newbie

    Messages:
    31
    Likes Received:
    1
    Trophy Points:
    16
    This screen refresh range, doesn't happen any more on my 2760P with the latest HP released Intel driver.
     
  9. SNorton

    SNorton Pen Pal - Newbie

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    5
    F840 = 63552 in decimal. Did you mean F940?
     
  10. Epi

    Epi Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    This fix may work, but it's better to just go to the Graphics Options > Power tab of the Intel HD Graphics application, and disable 'Display Refresh Rate Switching' directly from the 'On battery' panel.
     

Share This Page