Can anything be done about the brightness that keeps dimming? (Surface Pro)

Discussion in 'Microsoft' started by MosquitoSmasher, Oct 24, 2013.

Thread Status:
Not open for further replies.
  1. MosquitoSmasher

    MosquitoSmasher Scribbler - Standard Member

    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    31
    I find this highly annoying when i am working on my Surface Pro. It's hooked up to the power supply and just for no reason while I have the brightness set to maximum, it dims and then after a few seconds or a minute or so it goes back to the maximum brightness again. Is there anything that can be done about this? Why is it even happening? I checked the power options and I have the settings so that when its connected to the power cable, it never ever dims. Yet it keeps doing it.
     
  2. Mesosphere

    Mesosphere Geek. Senior Member

    Messages:
    5,320
    Likes Received:
    2,085
    Trophy Points:
    331
    There are two possibilities I can think of. If the connection isn't good on the power cable it can do this. Also the ambient light sensor can do this. I find the ambient light sensor highly annoying on all devices I've used that have it. You can turn this off in Settings -> Change PC Settings -> PC and devices -> Power and Sleep -> Brightness -> "Adjust my screen brightness automatically" .
     
  3. MosquitoSmasher

    MosquitoSmasher Scribbler - Standard Member

    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    31
    This is odd. I can't seem to find PC and devices. From the main Windows 8 screen i swipe on the right side of the tablet, there i choose settings, pc settings, and there i can only find something called devices, but that is only to add a xbox 360, or anything else. My Windows 8 is in Dutch, but that shouldn't matter. Do i go into the correct PC settings?

    Hmmm..i searched on google and i just did this

    http://www.youtube.com/watch?v=7JjnmOXEAT4
     
    Last edited: Oct 24, 2013
  4. Mesosphere

    Mesosphere Geek. Senior Member

    Messages:
    5,320
    Likes Received:
    2,085
    Trophy Points:
    331
    The instructions I gave were for 8.1, do you have 8.0?
     
  5. MosquitoSmasher

    MosquitoSmasher Scribbler - Standard Member

    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    31
    Yes, still 8.0 here. But i will change to 8.1 this weekend. I want to take my time with it. Cause i LOVE using my Surface and i'd hate for anything to go wrong.

    I've did option two of this link

    Adaptive Brightness - Turn On or Off in Windows 8

    Should be fine now. I hope so, cause i'll be very glad if it just stops dimming. Thanks for helping!
     
  6. be77solo

    be77solo Scribbler - Standard Member

    Messages:
    674
    Likes Received:
    171
    Trophy Points:
    56
    Mine still does a slight change in brightness, even with Adaptive Brightness off in Windows. My laptop did this as well, and I found that it's an additional option in the Intel Graphics Control Panel that I had to disable... it was related to a power saving feature that had nothing to do with the ambient light sensor, as the laptop doesn't have a light sensor. I believe it was related to colors on the screen or something and dynamic brightness... way less aggressive than the light sensor but still noticeable.

    Unfortunately, on the SP2, I can't find the Intel Control Panel and I can't get the latest Intel drivers that do include the control panel to install. They installed just fine on my SP1 for comparison.
     
  7. MosquitoSmasher

    MosquitoSmasher Scribbler - Standard Member

    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    31
    Where in Windows 8 can I do this? Cause the dimming keeps still happening here too, not as often anymore though, but I want to get rid of it completely.
     
  8. be77solo

    be77solo Scribbler - Standard Member

    Messages:
    674
    Likes Received:
    171
    Trophy Points:
    56
    In the Intel Control Panel, there is an option under the Power tab for "Display Power Saving Technology" which "extends battery life by lowering backlight intensity." On my MSI laptop it solved the screen brightness issue that is similar to the SP issue.... problem is, in Microsoft's infinite wisdom they have decided to block the Intel Graphics Control Panel, so we don't have ready access to this option. There are workarounds that allow you to install the actual Intel graphics driver that installs their control panel, you just have to watch and not let Windows Update reinstall the Microsoft Driver right back over it.

    I have installed the Intel Driver on my SP2 from Oct 17th, and have disabled the Display Power Saving Technology. I'll report back if that has solved the problem.
     
  9. MosquitoSmasher

    MosquitoSmasher Scribbler - Standard Member

    Messages:
    109
    Likes Received:
    4
    Trophy Points:
    31
    I couldn't find those options in the intel control panel. What I did do however was I went into power options>change plan settings(balanced)> change advanced power setttings>display>adaptive brightness. I disabled it for when its on the charger. It should hopefully finally be fixed now.
     
  10. be77solo

    be77solo Scribbler - Standard Member

    Messages:
    674
    Likes Received:
    171
    Trophy Points:
    56
    Yes, by all means disable adaptive brightness in Windows, as that's the biggest contributor... I assumed based on previous posts you had already done this. The screen brightness changes/dimming that remains is much more subtle and not noticed all the time.
     
Thread Status:
Not open for further replies.

Share This Page