Blast from the past: Latitude XT with N-trig and pressure sensitivity

Discussion in 'Dell' started by bbz_Ghost, Jun 14, 2017.

  1. bbz_Ghost

    bbz_Ghost Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    5
    Ok, I know it's an oldie but I consider it a "goodie" more or less so bear with me. :)

    I just picked up a nearly mint condition Latitude XT without a mark on it, with the original battery and 0% wear on the cell as if it's never ever been used, with the 120GB Samsung 1.8" PATA drive (no bad sectors, no issues), original 45W AC adapter in excellent untouched shape too, all for $25 so I consider myself lucky.

    So my issue if anyone out there remembers this little beauty of a machine is that it has the infamous N-trig digitizer - it was missing the original stylus but I ordered the kit and got it today with the stylus, 5 tips (3 blue + 2 black), the tether cord and the tip removal tool for $8 - and I'm having issues with getting any potential pressure sensitivity working at all in Photoshop CS6 (can't stand the CC versions personally) or any other artistic drawing or whatever app (I've tried Sai, Inkscape, etc) so I'm curious if anyone else out there has any suggestions.

    Yes I realize this is a very old device - this one literally shipped on June 28 2008 so it'll be 9 solid years old in another 2 weeks but again it's literally new in every aspect that matters. The hard drive reports it was only powered on for less than 45 hours when I first fired it up which again I consider to be a lucky thing - apparently this was purchased by some startup that tanked and it was in storage almost from the day it was received till the now previous owner found it and decided to sell it on craigslist.

    Anyway, I've tracked down the latest N-trig drivers for this particular device showing:

    Driver version: 1.26.8.47
    Firmware version: 4.9.15.13.15
    Software bundle version: 3.118

    I've done a lot of research, read every post here that I can track down about the Latitude XT (there aren't as many as I had hoped, guess this tablet/laptop wasn't nearly as popular as I thought it would have been), I've hit Google and other search engines, tracked down what appears to be a utility or driver from N-trig called WinTab and the latest or last one appears to have been 1.09 and that's installed - my current OS on the XT is Windows 7 Pro 32-bit, I may put 64-bit on at some point in the future, I don't know just yet but I do have the RAM maxed out at 3GB by adding a 2GB DDR2 667 stick since it has 1GB on the mainboard. I also plan to get an mSATA drive at some point along with an mSATA to ZIF adapter card so it'll improve performance over the slow 5400 rpm PATA drive (the Samsung Spinpoint HJ122JC) capability.

    Having said all that everything does work without any issues so far except for pressure sensitivity in any app I'm attempting to get it with so, that's where I'm at with this old but still awesome machine.

    If anyone has tips or suggestions or information I can run with I'd appreciate hearing them (except maybe telling me to dump it and get something more current, of course). :)

    I did have Windows 10 Pro on here but that was last week and before I had the stylus, everything worked there as well so I might reinstall it today (I have a spare 60GB 1.8" PATA ZIF drive) and see if there's any pressure sensitivity working in that OS because I think but I'm not 100% sure that the N-trig drivers that Windows 10 uses are slightly updated versions of the ones that came from N-trig as distributed by Dell.

    I know that Microsoft bought out N-trig for use with the Surface devices and their website is history so finding the 32-bit and even the 64-bit latest drivers was a bit of a chore but I do have them here now.

    Ok, I'm done and again I appreciate any info at all, really, if anyone cares to chime in.

    Thanks.

    EDIT:
    Originally thought the hard drive was 4200 rpm and posted as such, turns out it's a 5400 rpm and I didn't even know it so, that's why I see a difference in performance between that drive and the 60GB spare I have which is a Toshiba 4200 rpm, DOH! :)

    EDIT 2:
    I did get Windows 10 Pro installed (32-bit) and no issues, and yes the pressure sensitivity does appear to work as expected in most apps. My Wife uses Sai which is a relatively popular art program written by some Japanese developer and while that works properly on her laptop since she has an external Wacom tablet, it's not working (at least for the moment) with pressure sensitivity on the XT. Now the XT is mine, of course, but I figured I'd at least make it work with some of the stuff she uses so it's a fallback if she gets a sudden burst of creativity and doesn't have access to her laptop with the Wacom attached, like it we go out for some reason.

    Anyway, still interested in getting it working with Windows 7 in the same manner, under Windows 10 Pro all I actually tested it with is the Windows Inking thing (can't even recall the name of it) but it has a scratchpad or whatever and the pressure sensitivity absolutely works as expected so I presume that with other apps that have better support - Sai's digitizer support is pretty limited from what I can tell - will more than likely work fine so I'll do some experimenting with that soon enough.
     
    Last edited: Jun 14, 2017
    azelll likes this.
Loading...
Similar Threads - Blast past Latitude
  1. darhol
    Replies:
    1
    Views:
    442

Share This Page