Back From Repair

Discussion in 'Asus' started by SAM 2013, May 2, 2014.

Thread Status:
Not open for further replies.
  1. SAM 2013

    SAM 2013 Scribbler - Standard Member Senior Member

    Messages:
    859
    Likes Received:
    221
    Trophy Points:
    56
    There are posts starting to trickle in with the
    results of repairs both successful/unsuccessful.


    Here are my results

    Model:
    32gb

    Date Manufactured:
    01/2014

    Purchased from:
    Miscrosoft Store
    2/10

    1st Time to Digitizer failure:
    32 days

    Time to total failure:
    42 days

    Time in for Repair:
    34 days

    ::::::::::::::::::::::::::::::::::::::::::::::::::

    Repairs Listed:

    Repair Detail #1-(04-16-2014)
    LCD Screen Leaked
    Replace M8-TA-1B PAD SYSTEM ASSY

    (I did not send it in for this reason)

    Repair Detail #2-(04-29-2014)
    Error Message
    Replace M80TA-1B BASE FRAME AASY
    Replace M80TA DIGI FFC 8P, 0.5MM, 35MM

    (It looks like it has a new screen w/ plastic on it &
    the outer bezel had a packing tape around it)


    :::::::::::::::::::::::::::::::::::::::::::::::::::

    Someone may know what these parts are.
    I do not see the I/O board replacement
    like NAVUS' repair.

    Maybe they are just replacing different parts,
    checking the message boards to see what works/doesnt work.

    I think they may have broke the screen taking it
    apart or re-assembling it, thus the
    "unforseen circumstance" delay.

    At least the screen is brighter now & does not seem
    to gather finger prints as bad.

    But it is not clear if they fixed the orginal problem....
     
    Last edited: May 2, 2014
  2. SAM 2013

    SAM 2013 Scribbler - Standard Member Senior Member

    Messages:
    859
    Likes Received:
    221
    Trophy Points:
    56
    NAVUS, I hope you do not mind me pasting your post
    results of your repair here:

     
  3. Azule

    Azule Pen Pal - Newbie

    Messages:
    69
    Likes Received:
    27
    Trophy Points:
    26
    Posted this in the "Pen Stopped Working" thread, but here is my repair statement:

    So I said I would update everyone on what they did. They returned my original Note 8. ...and the pen works great! This is what was on my slip: "Replace M80TA IO_BD. (Pen) /AS".

    Originally bought from eBay with a working digitizer. Used it for a week and a half before critical pen failure. Repair took about two weeks. 18 hours since it was returned. Still working. Probably a bit too early to have compete faith in the repair.:D
     
    Last edited: May 2, 2014
  4. Mesosphere

    Mesosphere Geek. Senior Member

    Messages:
    5,275
    Likes Received:
    1,979
    Trophy Points:
    331
    Yep, they were using it as a coaster.
     
    Bronsky and SAM 2013 like this.
  5. Bronsky

    Bronsky Wait and Hope. Senior Member

    Messages:
    7,823
    Likes Received:
    4,462
    Trophy Points:
    331
    So you got it back and it's working? The Digi FFC 8P, 0.5mm, 35mm - is that the pen? I wonder if the I/O board is included in the base frame assembly? Anybody able to locate a parts catalogue on-line?
     
  6. SAM 2013

    SAM 2013 Scribbler - Standard Member Senior Member

    Messages:
    859
    Likes Received:
    221
    Trophy Points:
    56
    Yep, and when I called 2 days ago, they did not have
    any updatescon the status. According to the repair slip,
    it had already been shipped out...

    The pen does work...for now
     
  7. SAM 2013

    SAM 2013 Scribbler - Standard Member Senior Member

    Messages:
    859
    Likes Received:
    221
    Trophy Points:
    56
    Apparently unit was the crash test...
    they were probably so frustrated trying to figure out the problem,
    it was thrown out a high window

    I have no idea what these part numbers are are.
    No ones posted anything similar.
    I was hoping someone may have a parts list.
     
  8. BobWerk

    BobWerk Pen Pal - Newbie

    Messages:
    48
    Likes Received:
    10
    Trophy Points:
    15
    I sent mine in about 3 weeks ago. After just 2 days in for repairs, they already sent it back to me.
    According to the RMA document, they only reinstalled Windows, but I have some doubts about that. Partly due to the loose back cover I had to snap back in, as well as my digitizer that actually still works without any further issues.
    I got serviced in Germany.
     
    Last edited: May 2, 2014
  9. Mesosphere

    Mesosphere Geek. Senior Member

    Messages:
    5,275
    Likes Received:
    1,979
    Trophy Points:
    331
    Think that is encouraging news for SAM. How long have you had it back and how bad was it when you sent it in?
     
  10. Bronsky

    Bronsky Wait and Hope. Senior Member

    Messages:
    7,823
    Likes Received:
    4,462
    Trophy Points:
    331
    Please let us know if any of these repaired devices fail again. I'm hoping that Asus is onto the issue and fixes it in production. I'll wait a month or so before taking my unit back to the MS Store for repair.
     
Loading...
Thread Status:
Not open for further replies.

Share This Page