ATI HD 4550 10.3 Catalyst Driver for tm2

Discussion in 'HP TouchSmart TM2 (Wacom)' started by dgitalchaos, Apr 27, 2010.

Thread Status:
Not open for further replies.
  1. tscottmommy

    tscottmommy Scribbler - Standard Member

    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    31
    ^^^^^^^^^^^^^ This whole thread worked through how to get the most current ATI drivers with switchable graphics still...My machine seemed to be the most problematic. IF you follow the instructions, it should work for you. Good luck!
     
  2. lovelaptops

    lovelaptops My friends call me Jeff Senior Member

    Messages:
    2,559
    Likes Received:
    1,063
    Trophy Points:
    181
    Bump.

    Am I just lucky (not so much, if you read my horrible experience with a 2740p!), or what, but I am having virtually no problems at all with all the original graphics drivers. The one thing I cannot do is have proper calibration with one of the portrait modes. I can live with this for now, even if it takes 6 months for a couple of drivers to simply install and make everything work (or is that even optimistic for HP?). I read this thread and my eyes go bleary! So many steps, so many *different* suggestions, nobody claiming everything works with either 10.4 drivers or 10.3 drivers! Switchable graphics is also something I've decided to pretend this machine does not have. I just switch manually. Usually, I use the Intel, because I am not a gamer and it works fine for streamed video, which on this machine I usually only use in a tiny window in the corner while I am otherwise "working."

    My hat goes off to all you pioneers, truly. But is it worth it?
     
  3. BlindWolf8

    BlindWolf8 Comparer of tm2s

    Messages:
    285
    Likes Received:
    0
    Trophy Points:
    31
    tscottmommy was having major issues on his/her end, and we were just helping him/her with it. I, on the other hand, had really no issues. These issues were only apparent when installing the 10.4 drivers. The 10.3 install I had no issues with.

    Installing 10.3: http://forum.tabletpcreview.com/hp-...50-10-3-catalyst-driver-tm2-2.html#post183801

    Installing 10.4: http://forum.tabletpcreview.com/hp-...50-10-3-catalyst-driver-tm2-8.html#post184042

    I tried to make things as simple as possible.
     
  4. dgitalchaos

    dgitalchaos Guest

    I couldn't get a full resolution on the 1080p TV with the HP drivers, and I could not scale the image either. Even then, it lagged and kept having to "refresh," plus I couldn't get the HDMI to pass audio through. With the 10.4 (and 10.3) drivers -along with the HDMI update, I get perfect 1080p resolution on the HDTV, and the option to scale if necessary (though not needed), as well as perfect audio.

    It wasn't too much of a hassle for me, but to me it is worth it. Plus I have the Blu-Ray drive, so that makes a nice difference on the HDTV.
     
  5. tscottmommy

    tscottmommy Scribbler - Standard Member

    Messages:
    295
    Likes Received:
    0
    Trophy Points:
    31
    @ Blindwolf and dgitalchaos: and boy do I appreciate your help!

    @ Lovelaptops: I have to agree with dgitalchaos that it was worth it. For me, it was less hassle and more puzzle. I'm not sure why mine was hanging so much, but if I'd done a "smart" install in the first place, knowing these were not built specifically for the switchable graphics (gotten rid of the old ATI stuff), I'd probably have spent much less time with it. I'm glad the time was spent because my graphics are better in general...And don't know why, but since I got them installed my machine temps are back down: just over 36 C with ATI on, below 34 C on intel. Before getting these drivers working, I was leaving it on ATI because I had fewer issues with orientation and calibration and my battery still lasted more than 4 hours with little attention to power management.

    It's nice to be able to port to the big screen via HDMI and get such a great picture without hassles and a separate set of speakers running off the TM2.

    Also, I may not have had the same problems had I not installed and uninstalled so many times...Once I found the registry keys that were left behind after uninstalling the ATI, everything went very smoothly.
     
  6. jkenny23

    jkenny23 Scribbler - Standard Member

    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    31
    I was trying to upgrade to 10.7 via the method in the first post and after uninstalling all my old ATi drivers, I tried installing the HP ATi driver, but every time I run setup (any of the setups in the folder) it crashes, in safe mode as well. Tried the older 1.00 A version, also crashes. Any ideas? I'm currently stuck with only the Intel driver/card. Windows doesn't recognize the ATi card anymore after it updated the ATi driver.
     
  7. muntu

    muntu Pen Pal - Newbie

    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    15
    Guys,

    If you haven't already tried catalyst 10.7a for your 1G_TM2T then do so. Holy crap the hydravision is soo cool. I haven't explored it in depth but I am able to do all the cool things using an hdmi screen and the tm2's screen.
     
  8. jkenny23

    jkenny23 Scribbler - Standard Member

    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    31
    Can you post instructions on how you upgraded to 10.7? I managed to get my ATi drivers back by doing a system restore, but after that whole deal I'm not too enthusiastic about trying to upgrade again.
     
  9. muntu

    muntu Pen Pal - Newbie

    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    15
    I am somewhat baffled that others are experiencing issues with installations of catalyst drivers. In my case, I was on 10.3 and took the leap to 10.6 and then 10.7. I wasn't very happy with 10.7's drivers because they disabled using both the tm2's lcd and an hdmi display so i downgraded to 10.3. Then a poster on this forum pointed me to 10.7a and I have that installed at the moment. Throughout all of these procedures, all I did was download the unmodified packages and install as usual. If it's a factor at all, I have not clean installed windows on this machine yet.
     
  10. jkenny23

    jkenny23 Scribbler - Standard Member

    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    31
    Fixed the issue using the method described here: AMD Game Forums - Catalyst Installer crash

    Just ran the installer via command line and it installed without any errors/crashes.
     
Thread Status:
Not open for further replies.

Share This Page