asusparts.eu

Discussion in 'EP121 Slate' started by wicked1, Jul 26, 2012.

Thread Status:
Not open for further replies.
  1. wicked1

    wicked1 Scribbler - Standard Member

    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    31
    Has anyone actually ordered from them? I did.. a month ago.
    The part still hasn't shipped!! Not that it simply hasn't arrived.. It hasn't left their warehouse yet!
     
  2. CF77

    CF77 Love Tablet. Senior Member

    Messages:
    2,303
    Likes Received:
    8
    Trophy Points:
    56
    What did you ordered?
     
  3. wicked1

    wicked1 Scribbler - Standard Member

    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    31
    ep121 IO Board

    They had no stock, apparently, and are still waiting to receive one from Asus.
     
  4. wkinva

    wkinva Pen Pal - Newbie

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    5
    I placed an order with them in Jan12 they shipped the complete order in Apr12. I ordered a bunch of small parts.

    The wait was on a replacement back cover.

    Everything showed up just fine when it did arrive. Waiting can be hard in this day and age but it turned out OK in the end. I really needed a new thermal sensor cable (got a spare as well) to make my slate "usable" again.
     
  5. JustDavid

    JustDavid ASUS EP121 Slate user

    Messages:
    178
    Likes Received:
    1
    Trophy Points:
    31
    I ordered from them on 27 June, no parts have shipped and today when I tried to log in, it said I didn't have an account under my email address. I've used the Contact Us link on the webpage, just hope they respond soon. I really need that damned thermal sensor!

    EDIT: They might have been doing maintenance on the site because now I can log in and see my order, but it still hasn't shipped!
     
    Last edited: Aug 2, 2012
  6. teardrop

    teardrop Pen Pal - Newbie

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    5
    I ordered a heat sensor from Them. Arrived in just over a month, to Canada mind ya.
     
  7. wicked1

    wicked1 Scribbler - Standard Member

    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    31
    It arrived today. Hope it fixes the issue!

    --edit-- YEP! it's fixed.
    (it was an odd problem, wouldn't turn on unless it was plugged in, but worked after being unplugged, as long as it was started.)
     
    Last edited: Aug 15, 2012
Thread Status:
Not open for further replies.

Share This Page