Asus Eee Note, a peek within....

Discussion in 'Asus (Android)' started by whazzup, Jan 12, 2011.

Thread Status:
Not open for further replies.
  1. DaEvil1

    DaEvil1 Pen Pal - Newbie

    Likes Received:
    Trophy Points:
    Handwriting recognition function of the keyboard? Don't quite follow that. You mean the virtual keyboard on the Eee Note?

    Anyway, I did a system update with the latest update, and this is what happened:

    1: The update took a while to download.

    2: When I tried to update, it took a while for the Eee Note to speak with the PC after it went into update mode. A few minutes at least. (I just left it for 40 minutes, and it was done when I came back.)

    3: language changed back to chinese (of course.)

    4: Since the update cleaned the user data on the Eee Note, I just tried directly restoring my user data with the "en" for keyboard in the sys.config file. And that worked fine.

    Think I'm done for today, but tomorrow I'll try to fill out the wiki in the Open-Eee-Note project to make it a tad more accessible.

    EDIT: One last comment. At first glance, the Eee Note seems to have a lot less lag moments compared to what I've experienced so far.
  2. pbarrette

    pbarrette Scribbler - Standard Member

    Likes Received:
    Trophy Points:
    Hi DaEvil1,

    When you're using the virtual keyboard, hit the button with the flag, then hit it again. That puts you into a mode that has a handwriting recognition input panel.

    The input panel has 4 buttons on the right side with the 3rd button (chinese input) selected by default.

    I tried taking a screenshot, but the input panel always disappears whenever I hit the screenshot button.

  3. wahaha432

    wahaha432 Pen Pal - Newbie

    Likes Received:
    Trophy Points:
    I have wrote a dvt_check script to get some info without opening the Eee Note.

    pwd > /mnt/extsdcard/enote/pwd.txt
    whoami > /mnt/extsdcard/enote/user.txt
    uname -a > /mnt/extsdcard/enote/uname.txt
    cat /dev/cpuinfo > /mnt/extsdcard/enote/cpuinfo.txt
    cat /dev/meminfo > /mnt/extsdcard/enote/meminfo.txt
    df > /mnt/extsdcard/enote/diskinfo.txt
    dmesg > /mnt/extsdcard/enote/dmesg.txt
    ls -alR / > /mnt/extsdcard/enote/filelist.txt
    My Eee Note has been updated to version

    The output of dmesg:
    Linux version 2.6.21 (root@helen-desktop) (gcc version 4.2.4) #26 PREEMPT Thu Jan 13 18:11:18 CST 2011
    CPU: XScale-V3 based processor [69056881] revision 1 (ARMv5TE), cr=0000397f
    Machine: ASUS EEE Note
    Memory policy: ECC disabled, Data cache writeback
    On node 0 totalpages: 65024
      DMA zone: 508 pages used for memmap
      DMA zone: 0 pages reserved
      DMA zone: 64516 pages, LIFO batch:15
      Normal zone: 0 pages used for memmap
    Run Mode Clock: 312MHz
    Turbo Mode Clock: 624MHz
    High Speed I/O Bus Clock: 208MHz
    CPU0: D VIVT undefined 5 cache
    CPU0: I cache: 32768 bytes, associativity 4, 32 byte lines, 256 sets
    CPU0: D cache: 32768 bytes, associativity 4, 32 byte lines, 256 sets
    Built 1 zonelists.  Total pages: 64516
    Kernel command line: root=/dev/mss/blk0p5 rootfstype=ext2 initrd=0x80600000,669065 console=ttyS1,38400 quiet
    PID hash table entries: 1024 (order: 10, 4096 bytes)
    Console: colour dummy device 80x30
    Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
    Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
    Memory: 254MB = 254MB total
    Memory: 252928KB available (3664K code, 295K data, 132K init)
    Calibrating delay loop... 622.59 BogoMIPS (lpj=3112960)
    Mount-cache hash table entries: 512
    CPU: Testing write buffer coherency: failed, enabling work-around
    NET: Registered protocol family 16
    SCSI subsystem initialized
    usbcore: registered new interface driver usbfs
    usbcore: registered new interface driver hub
    usbcore: registered new device driver usb
    Time: pxa_timer clocksource has been installed.
    NET: Registered protocol family 2
    IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
    TCP established hash table entries: 8192 (order: 4, 65536 bytes)
    TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
    TCP: Hash tables configured (established 8192 bind 8192)
    TCP reno registered
    checking if image is initramfs... it is
    Freeing initrd memory: 653K
    Intel(c) Memory Management - Heterogeneous Memory 		Allocation
    Intel(c) Memory Management - Page Attribute Manipulation
    Intel(c) Memory Management is now Enabled
    Register device ipmc successgul.
     <6>Initialize IPM performance perfiler.
    NetWinder Floating Point Emulator V0.97 (double precision)
    JFFS2 version 2.2. (NAND) (C) 2001-2006 Red Hat, Inc.
    aufs 20090126
    io scheduler noop registered
    io scheduler anticipatory registered
    io scheduler deadline registered
    io scheduler cfq registered (default)
    request gpio2 irq success
    request gpio79 irq success
    ************bq27541 init************
    ************S1 init************
    ************S2 init************
    i2c /dev entries driver
    Gauge IC chip_id=95
    The Gauge IC is bq27541.
    I2C: i2c-0: PXA I2C adapter
    i2c: max8660 detected
    pxa2xx-fb pxa2xx-fb: machine LCCR0 setting contains illegal bits: 00200000
    Load PXA Overlay driver successfully!
    2D Graphics Driver for Monahans Linux
    m2d: unable to register character device /dev/m2d
    m2d: probe of m2d failed with error -16
    pxa2xx-uart.0: ttyS0 at MMIO 0x40100000 (irq = 22) is a FFUART
    pxa2xx-uart.1: ttyS1 at MMIO 0x40200000 (irq = 21) is a BTUART
    pxa2xx-uart.2: ttyS2 at MMIO 0x40700000 (irq = 20) is a STUART
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
    loop: loaded (max 8 devices)
    PPP generic driver version 2.4.2
    PPP Deflate Compression module registered
    PPP BSD Compression module registered
    NET: Registered protocol family 24
    Linux video capture interface: v2.00
    usbcore: registered new interface driver uvcvideo
    USB Video Class driver (v0.1.0)
    PXA_CAMERA: PXA Camera driver loaded for/dev/video0 
    ov2655 camera: idH=0x26,idL=0x56
    camera************************OV2655 detected.
    Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
    ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
    id:0xf1ad, chipid:0xf1ad
    Try to allocate dma buffer(len:2176)for data buffer + 2*descriptor + command buffer
    NAND device: Manufacturer ID: 0xad, Chip ID: 0xf1 (Hynix NAND 128MiB 3,3V 8-bit)
    relocation table at page:63
    Bad block table found at page 57344, version 0x01
    Bad block table found at page 57280, version 0x01
    nand_read_bbt: Bad block at 0x03cc0000
    Creating 5 MTD partitions on "NAND 128MiB 3,3V 8-bit":
    0x00000000-0x00060000 : "Bootloader"
    0x00060000-0x00260000 : "EngineKernel"
    0x00260000-0x00660000 : "EngineInitrd"
    0x00660000-0x06fa0000 : "UserStorage"
    0x06fa0000-0x07020000 : "BBT"
    usbmon: debugfs is not available
    ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
    pxa3xx-ohci pxa3xx-ohci: PXA3xx OHCI
    pxa3xx-ohci pxa3xx-ohci: new USB bus registered, assigned bus number 1
    pxa3xx-ohci pxa3xx-ohci: irq 3, io mem 0x4c000000
    usb usb1: configuration #1 chosen from 1 choice
    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 3 ports detected
    usbcore: registered new interface driver cdc_acm
    drivers/usb/class/cdc-acm.c: v0.25:USB Abstract Control Model driver for USB modems and ISDN adapters
    Initializing USB Mass Storage driver...
    usbcore: registered new interface driver usb-storage
    USB Mass Storage support registered.
    usbcore: registered new interface driver usbhid
    drivers/usb/input/hid-core.c: v2.6:USB HID core driver
    usbcore: registered new interface driver cdc_ether
    usbcore: registered new interface driver cdc_subset
    pxa3xx_udc: version 01-Jul-2005
    mice: PS/2 mouse device common for all mice
    input: pxa3xx_keypad as /class/input/input0
    ****&&&*&&^$%&($ chip_id:0
    start gpio_init_sensor_board
    init sensor board ok
    input: gpio-keys as /class/input/input1
    pxa-rtc pxa-rtc: rtc core: registered pxa-rtc as rtc0
    PXA Real Time Clock driver v1.03
    Driver for 1-wire Dallas network protocol.
    no card detect IRQ for MMC1, slot:0.
    Device major:254, first minor:0
     mss/blk0: p1 p2 p3 p4 < p5 p6 >
    Device major:254, first minor:8
    no card detect IRQ for MMC2, slot:0.
    Advanced Linux Sound Architecture Driver Version 1.0.14rc3 (Wed Mar 14 07:25:50 2007 UTC).
    ASoC version 0.13.0
    <Restore>: readback ID = 0x59b4
    RT5610/RT5611 SoC Audio Codec 0.01
    asoc: AC97 HiFi <-> pxa3xx-ac97 mapping ok
    ALSA device list:
      #0: zylonite (RT5611)
    TCP cubic registered
    NET: Registered protocol family 1
    NET: Registered protocol family 17
    XScale iWMMXt coprocessor detected.
    load mobm into address: 0xcf868000
    Current operating point is 4
    pxa-rtc pxa-rtc: setting the system clock to 2011-01-30 12:11:09 (1296389469)
    Freeing init memory: 132K
    kjournald starting.  Commit interval 1 seconds
    EXT3 FS on mss/blk0p6, internal journal
    EXT3-fs: mounted filesystem with ordered data mode.
    ipmc_open: device opened!
    BMM init with size=8MB
    serio: Serial port ttyS0
    input: Wacom serial digitizer as /class/input/input2
    create char dev wac_tch success
    This dvt_check script was run as root. Therefore a lot of things can be done with some scripts.
  4. wahaha432

    wahaha432 Pen Pal - Newbie

    Likes Received:
    Trophy Points:
    The default language can be switched with the dvt_check script as well:

    sed -e 's/default=tc/default=en/' /eTablet/etc/setting/sys.config > /mnt/extsdcard/enote/sys.config
    cp /mnt/extsdcard/enote/sys.config /eTablet/etc/setting/
    There's no need to backup/restore, just reboot your Eee Note and it will be done.

    Note: The dvt_check script should be executable. I am not sure how to change the mode of this script under windows, I wrote the script in ubuntu.
    And, the script should be placed in the root of the external sd card.
  5. Joshua.Lamorie

    Joshua.Lamorie Pen Pal - Newbie

    Likes Received:
    Trophy Points:
    The filesystem on the SD card I use is FAT, so Linux assumes that the execute bit is set on all files.
  6. copadevino

    copadevino Pen Pal - Newbie

    Likes Received:
    Trophy Points:
    Thx pbarrette !!!
    I changed language English to Chinese.
    Thx a lot. :):)

    my blog(I'm just an user)

    You can perform a backup using the Sync software. If you look in the backup directory, there should be a "setting" folder that contains a "sys.config" file.

    Edit the sys.config file with notepad and find the section that looks like this:

    Now change it to this:

    Now restore the backup and reboot your EeeNote.

    That should do the trick, but I haven't tried this method. I opened up the EeeNote, mounted the SD card partition in linux and edited the file there.

    I would have used the above method, but I had trouble getting the Sync software to install on Win2K8-x64. The installer only likes XP, Vista and Win7.
    Last edited by a moderator: May 18, 2015
  7. Durasl

    Durasl Pen Pal - Newbie

    Likes Received:
    Trophy Points:

    I tried to do what you wrote and my ee note is still in chinese. What's wrong with my sequence?

    1. I reset the eee note.
    2. Backup the eee note.
    3. Edit the file.
    4. Restore the eee note.
    5. Reboot the eee note.

    When I check a new back up the file is still in chinese.

    Any ideas?
  8. pbarrette

    pbarrette Scribbler - Standard Member

    Likes Received:
    Trophy Points:
    Hi Durasl,

    You could try wahaha432's solution with an external SD card.

  9. pbarrette

    pbarrette Scribbler - Standard Member

    Likes Received:
    Trophy Points:
    Hi All,

    While snooping around the Asus FTP server, I found a very old version of the English ROM files:

    Please note that the ROM is version, so it's at least 3 revisions old, and older than the .71 factory version.

    I would caution everyone against loading this ROM. Please don't do it.

    The bootloader for this ROM appears to require a TFTP server with a very specific file structure and IP address. If you don't have the proper setup, you may brick your Eee Note.

    The reason I mention it is because the ROM image contains a binary that we haven't seen on the Eee Note yet. The phonebook.
    I was able to extract the required phonebook files and load it on my Eee Note by removing the internal SD card, mounting it on my PC and copying the files over.

    The PhoneBook app is a bit buggy:
    - The contacts count doesn't get updated in the Launcher home screen properly.
    - You are supposed to be able to add a photo for each contact, but trying to do so crashes the app.
    - There's a "related notes" button for each contact that is broken.
    - The search feature doesn't find your contacts.
    - The soft buttons are disabled in the "edit contact" screen.

    That said, here's a couple of screenshot of the phonebook.

    Here it is in the home screen:

    Here is the contact list:

    I don't have a screenshot of the contact edit screen because, as noted above, the soft buttons are disabled.

    To add the phonebook, you will have to edit the launcher's Config.xml file to add:
    <Ap thumbnail="icon/icon_b_phonebook.png" note="Take a picture of your contact. Or take a photo of their business cards. All the contacts in the phonebook can be quickly added to meeting minute notebooks as participants." action="Startup" path="phonebook" icon="icon/icon_s_phonebook.png" name="PhoneBook"/>
    You will also need to add the required phonebook files. You can extract them from the ROM file, but I've taken the liberty of doing that for you:

    I've also got some ideas on how we can use our own custom apps, but I still have some research to do.




    It would be awesome if you could create a package containing a dvt_check script to install these.
    I'm lacking an external SD card at the moment and I'm crap with shell scripts.

    It would be nice to build a zip package that people could extract to their SD card and load up all the custom fixes we have.
    - Change to english
    - Add the phone book app
    - Whatever the next customization is...

    A single zip file repository with dvt_check loader would be an easy way for people to get these fixes without having to crack open their EeeNote.

    Last edited by a moderator: May 18, 2015
  10. Durasl

    Durasl Pen Pal - Newbie

    Likes Received:
    Trophy Points:

    Unfortunatly, I don't even understand what a "dvt_check script" is.
Thread Status:
Not open for further replies.

Share This Page