700T adjusting the screen brightness - problems!

Discussion in 'Samsung' started by Zeezus, Nov 20, 2012.

  1. Zeezus

    Zeezus Pen Pal - Newbie

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Hi all,

    I've just got my Ativ Pro today (at a ridiculous price of £700!) but I'm having some real trouble adjusting the screen brightness and it currently seems to be stuck on the max which is burning holes in my eyes!
    I've done all the usual, disabling the auto adjust, both from the pc settings directory and through the advanced panel in power options, restarted multiple times and updated all the drivers.
    However I still cannot manually change the brightness of the screen.

    Is there anyone out there who has had the same initial trouble and has found a resolution for it?

    I should mention that I restored factory settings almost immediately to get rid of all Samsung's bloatware but I have since re-installed all the drivers I could get my hands on.

    Thanks very much in advance
     
  2. FlameStream

    FlameStream Pen Pal - Newbie

    Messages:
    20
    Likes Received:
    1
    Trophy Points:
    6
    Yes, I went through the whole thing too.
    It seems that the Intel Graphics driver from Intel's website won't be able to control it.
    You will have to get the one from Samsung. I gave in and installed the SW Update application which lets me download the drivers manually (using save setup files) and manually run it. The file is named Intel IvyBridge Windows8 GFX driver - 64bit 9.17.10.2817 (WHQL Jones) by the way.

    Of course, by installing SW update you will end up with Samsung Software installed, which displays annoying notifications once you install application or haven't updated a particular one.

    I decided to keep it for now to avoid what I went through to troubleshoot it until things stabilize.
     
    Last edited: Nov 20, 2012
  3. Zeezus

    Zeezus Pen Pal - Newbie

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Bah, always intel! Cool, thanks for the heads up :)
     
  4. Zeezus

    Zeezus Pen Pal - Newbie

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Installed those drivers and I'm still having the same issue.

    I have however realised that the screen is actually dimming slightly when set on 0%. So it does seems to actually adjust, just not much at all!

    Has anyone else got this problem? Would really appreciate a video or something demonstrating min and max brightness so I get a real feel for how much mine is off!

    Thanks
     
  5. FlameStream

    FlameStream Pen Pal - Newbie

    Messages:
    20
    Likes Received:
    1
    Trophy Points:
    6
    The 0-100 brightness range is pretty noticeable. But, we're getting there.
    Unfortunately, just installing Intel graphics did the trick for me. Perhaps doing a clean driver installation will do the trick.
    I'll try to fiddle with brightness behaviour later. I'd like to know ho exactly the luminosity sensor works.
     
  6. Zeezus

    Zeezus Pen Pal - Newbie

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    5
    Samsung released an updated driver today on my machine and now the brightness adjusts properly, Huzaar! :D
     
  7. skallal

    skallal Pen Pal - Newbie

    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    15
    What is you latest driver version? My latest graphics driver is v9.17.10.2817, and the latest update was NOT today...
     
  8. Anewjam

    Anewjam Pen Pal - Newbie

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    5
    Most of the answers were to get a software driver manually from Samsung and install it manually (which I did and I am using currently and it didn't make it worse) but that didn't solve the brightness problem. I've now ALSO turned off adaptive display brightness or ambient light sensor, it's possible to do this from the Samsung Control Center (Adaptive Brightness > Off) (How To Turn Off\On The Ambient Light Sensor For The 9 Series Laptop (Windows 7) my samsung) or within Windows 8 with no additional manufacturers software, open Charms (Windows Start Key) search Power Options. In the Power Options dialog > Change plan settings > In this dialog Change advanced power settings > In this dialog expand Display > and it's called Enable adaptive brightness BUT DISABLE it.

    Immediate the brightness control in the Windows 8 Charms, Settings > Screen slider is working and the Fn + Brightness Up or Brightness Down keys on the keyboard are working too.

    swindmiller (on another thread) was nice enough to post a version of the Intel HD 4000 graphics driver not the absolute newest but it's what I'm using now and it works with adaptive brightness off I installed this driver manually before finding help with adaptive brightness now I'm not sure if the advice to install the driver manually was even necessary but…

    https://www.dropbox.com/s/9p8xr9ldvv9b3p2/Intel%20IvyBridge%20Windows8%20GFX%20driver%20-%2064bit%209.17.10.2817%20%28WHQL_Jones%29.zip

    So depending on your situation you might need to install the Intel HD graphics driver manually but FIRST you most likely need to try to turn off ambient light sensor also known as adaptive brightness. You might get in the habit of turning this before you shutdown if you're going to be traveling with the notebook because this might also be the setting for the sensor that when ON prevents the computer from turning on in low light without pressing an additional button (like when it's in a bag).
     
Similar Threads: 700T adjusting
Forum Title Date
Samsung Ativ 700t (and 500t ?) : how to backup and restore tutorial Tuesday at 12:49 PM
Samsung Ativ 700t touch / screen problem Saturday at 2:24 AM
Samsung Samsung ativ smart pc 700t network shutting off problem [solved] Nov 17, 2014
Samsung ATIV 700T : is there a way to cleanly extend the battery capacity ? Nov 12, 2014
Samsung problems with my touchpad 700t1c Nov 5, 2014

Share This Page