To any user still running Windows 7 (W8 AMD Brightness issue)

+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Super Moderator
    Join Date
    Aug 2006
    Location
    Coimbra, Portugal
    Posts
    759
    Rep Power
    11

    Default To any user still running Windows 7 (W8 AMD Brightness issue)

    As of now, Windows 8 AMD drivers don't have brightness controls. This seems to be due to incorrect values in the registry.

    If you're running Windows 7, and have a 2G Tm2 (Core i3/i5) could you please check the correct values in the registry? More info here: The Ramblings of Adrynalyne: Fix Brightness Control for Windows 8 AMD SG Drivers

    Please post both the values for 0001 and 0000. Thank you in advance!
    Last edited by Seketh; 01-06-2013 at 12:21 PM.
    Tm2-2050ep (Core i3)

  2. #2
    (x) / fashion
    Join Date
    Jun 2010
    Posts
    2,505
    Rep Power
    18

    Default Re: To any user still running Windows 7, please read.

    Quote Originally Posted by Seketh View Post
    If you're running Windows 7, and have a 2G Tm2 (Core i3/i5) could you please check the correct values in the registry? More info here: The Ramblings of Adrynalyne: Fix Brightness Control for Windows 8 AMD SG Drivers
    Tell me exactly which keys and values to look for and I'll try to help.
    Hi! I'm a Tablet PC and I'm not a goddamn toy.
    HP TM2 | HP TC1100 | Galaxy Note 3 Neo


    WPrime/WEI Benchmark thread for Tablet PCs:
    http://forum.tabletpcreview.com/hard...ablet-pcs.html

  3. #3
    Super Moderator
    Join Date
    Aug 2006
    Location
    Coimbra, Portugal
    Posts
    759
    Rep Power
    11

    Default Re: To any user still running Windows 7, please read.

    It's simple, just follow these steps (assuming you don't know how to):

    1) Open regedit (write regedit on the start menu search)

    2) Click and open "HKEY_LOCAL_MACHINE" -> "SYSTEM" - "ControlSet001"

    3) With "ControlSet001" highlighted, go to "Edit" - "Locate" and write "FeatureTestControl". Click locate next.

    4) It should take you to a folder called "0000" and to the key "FeatureTestControl". The key should have something like "0x0000f920". What I need is the "f920" part of that number". It might be "f900", "f920"...

    5) Check the same key value in the folder "0001".

    Thanks!
    Tm2-2050ep (Core i3)

  4. #4
    (x) / fashion
    Join Date
    Jun 2010
    Posts
    2,505
    Rep Power
    18

    Default Re: To any user still running Windows 7, please read.

    Quote Originally Posted by Seketh View Post
    It's simple, just follow these steps (assuming you don't know how to):

    1) Open regedit (write regedit on the start menu search)


    You should have started with "first, ensure your computer is securely plugged to a power source". I know my way through the Registry, I just didn't want to read that dude's whole webpage.... Not sure if my specific TM2 model applies to your study. Here's the data I found:

    Edit: I always boot with Intel Graphics. I rarely use the AMD graphics.



    HP TM2 (i5-430UM, ATI HD-5450)

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Vi deo\{2...9}\0000]
    "FeatureTestControl"=dword:0000f800

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Vi deo\{2...9}\0001]
    "FeatureTestControl"=dword:0000f800
    Last edited by e-schreiber; 01-06-2013 at 11:42 AM.
    Hi! I'm a Tablet PC and I'm not a goddamn toy.
    HP TM2 | HP TC1100 | Galaxy Note 3 Neo


    WPrime/WEI Benchmark thread for Tablet PCs:
    http://forum.tabletpcreview.com/hard...ablet-pcs.html

  5. #5
    Super Moderator
    Join Date
    Aug 2006
    Location
    Coimbra, Portugal
    Posts
    759
    Rep Power
    11

    Default Re: To any user still running Windows 7, please read.

    I know you knew , I did it so anyone could check it.

    Anyway, it didn't work. Intel GPU brightness is working fine, AMD GPU won't work regardless of the value in the registry.

    I have no idea on how to solve this one...
    Tm2-2050ep (Core i3)

  6. #6
    Pen Pal - Newbie
    Join Date
    Aug 2010
    Posts
    14
    Rep Power
    4

    Default Re: To any user still running Windows 7, please read.

    have you tried a hybrid of the two? 800 for the intel 840 for AMD. I seem to remember him saying that the 0001 was the dedicated card.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -5. The time now is 04:15 PM.
Powered by vBulletin® Version 4.2.2
Copyright © 2014 vBulletin Solutions, Inc. All rights reserved.
Search Engine Friendly URLs by vBSEO 3.6.1